Macros not working in Mojave

Everything related to our flagship word processor.
Post Reply
mikecass
Posts: 8
Joined: 2016-02-27 13:18:36

Macros not working in Mojave

Post by mikecass » 2019-01-01 04:28:27

Twice the re-installation of Mojave has caused the separation of Nisus Writer from my macros, which are invaluable to me. Where should I place the NWP macros folder?

adryan
Posts: 303
Joined: 2014-02-08 12:57:03
Location: Australia

Re: Macros not working in Mojave

Post by adryan » 2019-01-01 04:56:49

G’day, mikecass et al

I think the default location for the Macros folder is:–

~/Documents/Nisus Documents/Macros

According to P. 624 of the Nisus Writer Pro User Guide, it should be in one of your Libraries, but this no longer seems to be the case.

Cheers,
Adrian
MacBook Pro (mid-2014)
macOS Mojave 10.14.6
Nisus Writer user since 1996

mikecass
Posts: 8
Joined: 2016-02-27 13:18:36

Re: Macros not working in Mojave

Post by mikecass » 2019-01-01 10:11:59

Thanks, Adrian, but that didn’t work. Is this possibly a "sandbox" problem?

martin
Official Nisus Person
Posts: 4583
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Macros not working in Mojave

Post by martin » 2019-01-04 13:52:22

Did you choose a "synchronized settings location" in your Nisus Writer preferences? If so, your macros will be loaded from within that folder. For example, if you use Dropbox your macros folder path might be:

Code: Select all

~/Dropbox/Nisus Writer Settings/Macros
If you don't have a sync folder, then your macros are probably being loaded from your Document Manager folder.

The easiest way to know is by using the menu Macro > Show Macros Folder in Finder. You can then move your other macros into that folder.

mikecass
Posts: 8
Joined: 2016-02-27 13:18:36

Re: Macros not working in Mojave

Post by mikecass » 2019-01-04 14:25:10

Problem solved. Thank you!

Post Reply