getting, & not wanting, curly/straight quotes--in same d

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
jdd
Posts: 11
Joined: 2006-09-13 17:42:08
Location: Japan

getting, & not wanting, curly/straight quotes--in same d

Post by jdd » 2006-09-13 18:20:45

I've assembled several documents recently. They contain mostly English with a few lines of Japanese here and there. Within the same document (the English sections) in one place if I type a word like don't I get curly quotes, but if I move to another place and type the same I get a straight apostrophe (same thing happens w/double quotes).

The parts used to assemble my docs came from both mac and windows platforms, and they came in different file types and fonts (Word and non-Word files). After I assemble the parts I sanitize it all--converting everything to 12 point Times New Roman.

In preferences > quick fix the "Use Smart Punctuation" box is checked. And I've tried toggling it on off to no avail.

I'm pretty sure that the part of my doc where I am able to get curly quotes came from a mac platform, and that the text where I have been unable to get curly quotes originated on windows. So I'm thinking windows/word has something to do with it.

I'm able to paste in curly quotes case by case, from one part of the document to another, but search and replace all doesn't work--the straight apostrophes are not replaced by curly ones.

I was using 2.6.something and have just upgraded to 2.7 but the situation still exists.

Any ideas/suggestions? I'd like to used one of these docs as a template, but if it's something about NWX I'd like to solve this rather than making it an ongoing thing. Alternatively, what can I tell the folks who supply me with text to do to their settings to keep from continuing to import this problem from them?

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

Post by cchapin » 2006-09-14 06:41:09

Hi, jdd.

I wonder if your problem has to do with the language assigned to various parts of your document? I can't be sure of this because in my brief experiments just now I wasn't able to recreate the problem, but I've heard that Word doesn't do the greatest job in applying language settings to text. As you move from one part of the document to another, do you see any change to the flag in the status bar?

Either way, you might try selecting the English text (perhaps using the font tag in the status bar) and then clicking the language tag (the flag) and applying English. I don't know for sure whether this will help, but it might be worth a try.

Or it might be that Word embedded some "smart-quote-off" code in documents that Nisus is honoring. I'm afraid that I don't know enough about rich text format to say whether that's possible.

--Craig

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

punctuation in mixed documents

Post by Mark XM » 2006-09-14 07:15:54

Has the stuff imported from Word all been created by whoever it is that is producing the Japanese? I often have a somewhat similar problem with the many documents that I deal with from Chinese colleagues who have created them with Word on PCs running the Chinese versions of Windows.

The thing is, in that situation, when they change to entering English, what is happening is not that they are using a fundamental language switch like NWE does, but merely using the Times-New-Roman-alike characters that come as part of the Chinese font set. Not only are these badly designed, kerned and hinted, but they don't come with European punctuation marks but use the set from the Chinese font. Chinese--I don't know if it is the case for Japanese--is monospaced throughout, so punctuation marks occupy the same amount of line space as Chinese characters. Apart from anything else, this looks horrendous in English.

I suggest that you try selecting the whole document, switching it all to whatever variety of English you use--if the Japanese behaves like Chinese does you should at worst see a change of font ... Chinese people tend to use Hei, the equivalent of Arial for everything, so when I change languages and it goes to the default Times, the Chinese switches font to Kai--and then try a search and replace for all single and double quotes.

Because of the summer holiday, it's some time since I've had to do it, but I think it works for the texts I deal with ... except that Chinese people have a tendency to put spaces in the wrong places in relation to punctuation, which screws things up further!--e.g. "Like this "he said "I think ,"and started laughing hollowly.

Mark

jdd
Posts: 11
Joined: 2006-09-13 17:42:08
Location: Japan

Post by jdd » 2006-09-14 15:00:43

Mark and Craig,

Thanks for the suggestions. I had tried "re-fonting" the whole document--first going to MS RMincho and then to Times New Roman. But I hadn't considered applying a language (English) to these documents...

VIOLA! It works! And it is only now that I've noticed that the flag symbol at the bottom right of the window had been signifying Japanese in one of the problem sections of my documents. I've now got them all converted to U.S. English.

Again, thanks!

Incidentally, the Japanese text in my files was coming from me; the English came from several Japanese and one american colleague. I've only just restarted using Nisus, I bought a copy last spring and have been playing with it a little, without switching completely over. But I thought I'd use it for this current project. I was a long-time user of Nisus Classic (and loved it), but when OSX came along I switched to Appleworks and then Pages (with only a little of Word sprinkled in so I could read what others sent me).

(I only wish Express would do line numbers like Classic did. I have several dozen files that relied heavily on that feature.)

Post Reply