funny style sthing

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
Agnostus
Posts: 50
Joined: 2006-03-16 01:00:50
Location: Lawrence, KS
Contact:

funny style sthing

Post by Agnostus » 2006-09-14 22:52:05

Hello!

I encounter some funny behaviour here. I have a document that once was a word .doc file. I have importet that in NWE and safed it as RTF. Opening the RTF all the fonts are changed :shock:; from Times to Helvetica that is. I have defined styles (in NWE; I removed all the Word styles that came with the import), using Times only, these styles are applied to everything, so the action "use styles only" in the styles palette removes all the Helvetica and makes it Times again. I work with the doc, save it. Next time I open it, its Helvetica again. I have gone thorugh this I-dont-know-how-many times. Has anyone else had an experience like this?

Martin

UPDATE: Now, after openeining it for the I-dont-know-how-many-and-first time the styles don't work anymore, it is Helevtica all over and there seems nothing I can do about that :cry:

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Post by Mark XM » 2006-09-15 02:16:10

Hi, Agnostus,

This sounds very strange. I suggest two things:

(1) For yourself: open the document, select all and copy, then open a new document and from the Edit menu choose <Paste Text only> or use Cmd-shift-V. That will insert only the text without any of the formatting information, so you should then be able to re-do the formatting as you wish ... it'll all come out in your default font ... or the "Normal" style you have set in your "Nisus New Document".

(2) To find out what on earth is going on (which may help us all): if you can, write to support@nisus.com explaining and attaching both the original Word doc, and your RTF (on the assumption that they are not so top secret ...), so that they can have a look at what is going on behind the scenes and identify why this is happening. It may help them sort out a hitherto unsuspected issue. I have sent Martin fairly confidential documents before, asking him to destroy them as soon as they have identified the problem, which he has always complied with.

Mark

Agnostus
Posts: 50
Joined: 2006-03-16 01:00:50
Location: Lawrence, KS
Contact:

Post by Agnostus » 2006-09-15 23:06:40

Hi, Mark,

thanks for your advice. I guess I will send Nisus a copy of the document.

However I have found a bizarre workaround for this bizarre probelm. I saved the RTF in Nisus (even with the Helvetica font), then opened it in Word - surprisingly, no Helvetica here, but exactly the formatting I specified. I then saved the RTF in Word again and reopened it in Nisus. Now everything is fine. It is very weird! It seems to be matter of the file-DISPLAY rather then what's in the file.

Martin

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Post by Mark XM » 2006-09-16 01:01:46

Agnostus wrote:Hi, Mark,

thanks for your advice. I guess I will send Nisus a copy of the document.

However I have found a bizarre workaround for this bizarre probelm. I saved the RTF in Nisus (even with the Helvetica font), then opened it in Word - surprisingly, no Helvetica here, but exactly the formatting I specified. I then saved the RTF in Word again and reopened it in Nisus. Now everything is fine. It is very weird! It seems to be matter of the file-DISPLAY rather then what's in the file.

Martin
My suspicion is that you ended up with a whole string of nested font tags at various points in the document, and that each time you were trying to change it, all you were doing was adding yet another. The other way to try and solve this kind of problem--I had it early in the 2.6 betas, I think it was--is to click on the font tag in the status line at the bottom and choose <remove font> from the menu that pops up. That should remove extra font tags, leaving only the one set by the style sheet; doing the same with the style tag will remove nested styles, so you can clean it up like that.

One of the thing I hate about Word documents, particularly ones produced by people who know nothing about style-sheets and templates, is that they come with about 150 useless style definitions cluttering the thing up. For that reason, on opening a Word document, I now automatically select all, change the language to British English--Word sets the language throughout according to the Windows system language, which in the case of the docs I handle is almost always Chinese ... so if I don't make the change and try to edit the English, it is the Chinese keyboard and editing system that comes up!--and then copy and paste it into a new document selecting "Keep existing styles". In that way, I'm in full control, with my styles and font settings, and if I need to add any or change any, NWE makes it easy.

Mark

Post Reply