Headings Numbering

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
thf
Posts: 64
Joined: 2006-10-13 11:26:49

Headings Numbering

Post by thf » 2006-10-13 11:35:01

I have a problem with the numbering styles.
I want to get automatic numbering in the following way:

1 Heading
1.1 Subheading
1.1.1 Sub-Subheading
2 Heading
2.1 Subheading
2.1.1 Subheading

My question is the following: how can i avoid the dot after the last number.

I clicked everything in the headings-list-style. All i get is the correct format for the top-level-heading. So it looks like this:

1 Heading
1.1. Subheading
1.1.1. Sub-Subheading
2 Heading
2.1. Subheading
2.1.1. Subsubheading

Any hints or maybe someone can help me out with a working template file?

User avatar
scottwhitlock
Posts: 174
Joined: 2004-10-26 07:10:40
Location: Tucson, AZ
Contact:

Post by scottwhitlock » 2006-10-15 04:05:08

I sent you the template via email that does what I think you want to do. However, dealing with this and trying to figure it out was much harder than it should have been, with everything from disappearing Level #'s in the List box to the List styles simply not reacting the way that they should have. Lists need a major rethinking for the next version as this struck me as uncharacteristically buggy compared to the rest of the workings of Style Sheets in Nisus, which is I think the best implementation of styles in any word processor. Just not when it comes to lists.

Scott

martin
Official Nisus Person
Posts: 4601
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin » 2006-10-16 16:26:21

I'll give the instructions for the recommended way to make this change:

1. Switch your document to Stylesheet view.
2. Select the name of the List style you want to modify from the list on the left (I'll assume the "Headings" list style).
3. On the right side of the screen, select the first level of the style (eg: click the text "1. Level 1").
4. Using the Lists palette, configure the selected level to use a custom level format. You do this by clicking the "#" tab (instead of the "1.1" tab).
5. Delete the period that appears after the level marker (the grey bubble that displays "1").
6. Repeat steps 3-5 for all levels of the style that you wish to modify.

Once this is completed all the text in your document that has been marked with the "Headings" list style should be automatically updated to use the new format.

If these instructions don't yield the desired results, or you find a particular step difficult, please let me know. Perhaps we can refine the process to make it easier.

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Post by Mark XM » 2006-10-16 18:25:36

martin wrote:If these instructions don't yield the desired results, or you find a particular step difficult, please let me know. Perhaps we can refine the process to make it easier.
Hi Martin,

After a couple of moments fiddling about I got the hang of this, and found it apparently straightforward. It took me a moment to realise that having clicked on the # in the line that shows 1 1.1 #, I then had to edit the string using the little pop-up labelled # further down the palette, deleting what was there already, and adding the level markers one by one with full-stops between.

Having got the hang of it, I went to preferences to edit the heading styles in "Nisus New File.dot" ... did it all, resetting indents as I would like them on the way, saved it ...

Then when I opened a new file, I found there were no changes from the default. I re-opened "Nisus New File", only to find that none of the changes to the headings styles had been kept.

What can I have done wrong?

Mark

User avatar
scottwhitlock
Posts: 174
Joined: 2004-10-26 07:10:40
Location: Tucson, AZ
Contact:

Post by scottwhitlock » 2006-10-16 20:18:07

Martin,

That's what I ended up doing (editing the Numbers List style and then copying it into my template). However, here were some problems I ran into along the way:
  • The text box where you edit the Level # fields does not scroll and there is no way you can resize it, so sometimes (especially when you're at Level 9), your numbers disappear (scroll out of view) and you have to edit them "blind".

    Sometimes, when you move from one Level to another, your Level #'s disappear completely. The List palette then does not let you type in the text box at all, however, if you select a Level #, it will show up in your document (or your stylesheet). This happens more often when the List palette is docked.

    If you try to create a new list style (as I tried to do for the original poster before I gave up and just edited an existing style), the style does not act the way it should. It will look like it should in the style sheet window, however, once you apply it and start typing your list, things go screwy. You may have the style window say "1.1.1.1 Level 4" and have the proper codes in the Level #'s box ( something like [1].[2].[3].[4] ) and the correct increments in the Stylesheet, but not when you apply the style sheet. You will sometimes only get 1. for each heading (even in the same level) or something as equally screwy, and the custom text box will show what your seeing in the document (the incorrect format) but when you switch back over to the Stylesheet view, it will be correct.
Of course, I may be doing something wrong here.

Scott
_____

2.0 Ghz Dual Core Black MacBook
1 GB of RAM
10.4.8
NWE 2.7

martin
Official Nisus Person
Posts: 4601
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin » 2006-10-17 14:00:55

Mark XM wrote:I re-opened "Nisus New File", only to find that none of the changes to the headings styles had been kept.
Hm, I have no idea what could have gone wrong. I just tried it and didn't have any troubles. Can I assume that you used the Edit File button in the Advanced section of the New Document preferences? Also, were you editing the List style directly, or was it applied to a Paragraph style (eg: Heading 1)?

martin
Official Nisus Person
Posts: 4601
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin » 2006-10-17 14:17:15

scottwhitlock wrote:The text box where you edit the Level # fields does not scroll and there is no way you can resize it, so sometimes (especially when you're at Level 9), your numbers disappear (scroll out of view) and you have to edit them "blind".

Sometimes, when you move from one Level to another, your Level #'s disappear completely. The List palette then does not let you type in the text box at all, however, if you select a Level #, it will show up in your document (or your stylesheet). This happens more often when the List palette is docked.
I just tried editing some of those higher List style levels and indeed the palette's custom format editor does get wonky. I'll file bugs on these points and hopefully we'll see a fix for the next version.
If you try to create a new list style, the style does not act the way it should ... You will sometimes only get 1. for each heading (even in the same level) or something as equally screwy, and the custom text box will show what your seeing in the document (the incorrect format) but when you switch back over to the Stylesheet view, it will be correct.
I hardly believe it, but I've also reproduced this! Thanks for the bug reports Scott.

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Post by Mark XM » 2006-10-17 21:37:59

martin wrote:
Mark XM wrote:I re-opened "Nisus New File", only to find that none of the changes to the headings styles had been kept.
Hm, I have no idea what could have gone wrong. I just tried it and didn't have any troubles. Can I assume that you used the Edit File button in the Advanced section of the New Document preferences? Also, were you editing the List style directly, or was it applied to a Paragraph style (eg: Heading 1)?
Yes, the Edit File button in Advanced or New Document preferences. I had tried setting up a new template, with the headings list levels applied to appropriate headings paragraph styles, but it didn't seem to work too well, and then I thought that it was easy enough to apply the headings list manually when necessary, so decided it would be better to simply modify my Nisus New File to set the headings list formats. So it was all done using the headings list levels, just as described in your post. I have no idea why it didn't save ... in fact I saved as I finished setting each level in turn.
I'll have another go and report back.

Mark

martin
Official Nisus Person
Posts: 4601
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin » 2006-10-17 23:13:56

Mark XM wrote:I'll have another go and report back.
Thanks Mark, that would very much be appreciated. If the List style modifications fail to save again, could you check to see if any changes to your Nisus New File stick? Perhaps there is a more general problem here.

Ooshima
Posts: 8
Joined: 2005-10-09 01:48:28

Post by Ooshima » 2006-11-02 01:50:53

same problem too, and no idea how to fix.

ne 2.7, german language, 10.4.x (problem exist from 10.4.x - 10.4.7.)

Post Reply