Copy disabled

Everything related to our flagship word processor.
Post Reply
agilefalcon
Posts: 8
Joined: 2010-11-28 19:46:45

Copy disabled

Post by agilefalcon » 2019-04-15 10:29:22

I am writing a newsletter and it seems that this document and any other that I open have a problem: I can no longer copy any section of text or a table to paste it elsewhere.

I've opened several documents and none of them have a contextual menu that permits me to copy the text!!

Any ideas?

Chris

credneb
Posts: 162
Joined: 2007-03-28 07:30:34

Re: Copy disabled

Post by credneb » 2019-04-16 08:54:00

Every now and then Nisus also stops responding to any keyboard input for me. I have never been able to correlate this to any specific action I have taken, but the problem has been resolved by quitting and restarting Nisus. I have usually been able to quit using the mouse, and when not, cmd-escape to force quit works -- but curiously it does NOT report Nisus as not responding (hung).

Using NWP 3.01 on a mid-2014 MBPro with OSX10.11.6.

adryan
Posts: 244
Joined: 2014-02-08 12:57:03
Location: Australia

Re: Copy disabled

Post by adryan » 2019-04-16 13:54:44

G’day, Cliff et al

I think these sound like two different problems.

Since upgrading to Mojave, I have noticed frequent (but unpredictable) annoying intervals of keyboard unresponsiveness; however, it is not confined to Nisus Writer. The period of unresponsiveness resolves itself within (say) 5 seconds, without any intervention on my part. The keyboard buffer has been working in the interim because its contents (including any commands represented) are then dumped into the current document or executed. I get the feeling that some sort of autosaving process is in operation, but I have Time Machine turned off and I can’t see where else I might be able to stop this behavior.

I note that Cliff is using El Capitan rather than Mojave; I never used El Capitan. It’s hard to know whether his and my problem are related somehow, but I thought it was worth mentioning, in case someone else had some words of wisdom on the subject.

To me, Chris’s problem sounds different. It might be helpful (but probably not to me!) to know the specifications of computer, operating system and NWP version. In the first instance, I would restart the computer, relaunch NWP, and see whether the behavior persisted. If it did, I would reinstall NWP.

If contextual menus are also absent in other applications besides NWP, I’d suggest reinstalling the operating system.

I should perhaps mention that, on a MacBook Pro with Touch Bar, Control-clicking on a Finder selection does not seem to reveal a contextual menu as it did in previous models. To see contextual menus, you need to single-click with two fingers simultaneously. This is the “Secondary click” in System Preferences… > Trackpad > Point & Click.

Cheers,
Adrian
MacBook Pro (mid-2014)
macOS Mojave 10.14.3
Nisus Writer user since 1996

User avatar
martin
Official Nisus Person
Posts: 4473
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Copy disabled

Post by martin » 2019-04-17 09:14:05

Hello Chris: we're sorry you're having trouble copying. We'd like to help but need a few more details to narrow this down. A few questions:

1. You implied the copy command was both "disabled" and/or perhaps missing. Is the command entirely missing or just disabled?
2. You said this was a problem with the contextual menu. Do you see copy commands on the main menu under Edit > Copy?

exegete77
Posts: 188
Joined: 2007-09-20 17:58:56

Re: Copy disabled

Post by exegete77 » 2019-04-18 14:54:07

I have had this problem for the past 2-3 months. I use Paste Text Only (OPT + SHIFT +CMD + V). When I use the mouse and select the menu, it works, but with the key command, nothing happens.

Mojave 10.14.4

NWP 3.0.1
iMac 21.5” / MBP 13” Retina
Mac user since 1990

User avatar
martin
Official Nisus Person
Posts: 4473
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Copy disabled

Post by martin » 2019-04-19 07:57:13

exegete77 wrote:
2019-04-18 14:54:07
I have had this problem for the past 2-3 months. I use Paste Text Only (OPT + SHIFT +CMD + V). When I use the mouse and select the menu, it works, but with the key command, nothing happens.
Does your keyboard shortcut always fail? If so can you please check and verify that your keyboard shortcut is properly set in the "Menu Key" preferences? I normally use Command + Shift + V for Paste Text Only, but setting your shortcut worked properly for me:
prefs.png
prefs.png (65.93 KiB) Viewed 57 times

Post Reply