Reply to topic  [ 3 posts ] 
Attribute sensitive Find and Replace 
Author Message

Joined: 2008-04-18 09:17:38
Posts: 3
Why doesn't this macro work? Its goal is to place a "±b±" in front of any text that carries the bold attribute and a "±/b±" after, and etc.. This lets me translate these attributes to my final product in InCopy and InDesign. If I create these expressions in the find/replace dialog, they work just fine, but that's a manual process.

In case it does not show up on your browser, I am applying the appropriate attribute to the ".+" in the Find Expression of each line.

#Mark any BoldItalic Text
Find and Replace ‘(.+)’, ‘±bi±\1±/bi±’, ‘Eau’

#Mark any Bold Text
Find and Replace ‘(.+)’, ‘±b±\1±/b±’, ‘Eau’

#Mark any Italic Text
Find and Replace ‘(.+)’, ‘±i±\1±/i±’, ‘Eau’


2008-07-09 08:05:04
Profile

Joined: 2007-03-03 09:55:06
Posts: 494
Location: Europe
It works flawlessly in my computer. Remember to save the macro as a Nisus Macro (.nwm).

Cheers, Henry.


2008-07-09 08:59:45
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
You might make sure there are no stray attributes in your macro file. I'd select all your text and use the menu Format > Remove All Attributes and Styles. That menu does everything except remove the "Normal" style, so afterwards you'll also want to use Format > Paragraph Style > Remove Paragraph Styles. That should ensure your text is free from any unwanted attributes so you can apply the bold/italic as desired.


2008-07-09 11:58:56
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software