Reply to topic  [ 8 posts ] 
.nwm opening in TextEdit? 
Author Message

Joined: 2007-11-09 15:27:25
Posts: 86
Not so long ago, Nisus Macro files (.nwm) opened automatically in Nisus when double-clicked.
But now they open in TextEdit. What did I do?

I thought I saw something not too long ago about this, but perhaps I dreamed. Sorry if I missed it.

When I open the Info panel (CMD-I) for any given .nwm file and attempt to direct the OS to open all such files with Nisus, it tells me that all *rtf* files will be opened with Nisus. Huh?

Thanks


2009-11-11 06:57:19
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Although internally Nisus Macro files are RTF data, that is odd. I thought OSX differentiated files by their extension. What version of OSX are you using?


2009-11-11 14:42:16
Profile WWW

Joined: 2007-11-09 15:27:25
Posts: 86
Hi, Martin.
I have 10.5.8


2009-11-11 14:51:52
Profile
User avatar

Joined: 2008-01-20 11:08:35
Posts: 89
Location: California
This is a problem that I read somehwere had to do with the Apple OS. even using Command-I to change the Open with choice is failing for some reason. Do a google search.


2009-12-05 13:30:19
Profile WWW

Joined: 2006-03-12 12:32:47
Posts: 138
Sometimes the global "Open With" setting in "Get Info" works more reliably if you first apply it to just the selected document, close the Get Info window, then re-open Get Info and then click the button to "Change All".


2009-12-18 13:46:47
Profile

Joined: 2007-11-09 15:27:25
Posts: 86
The problem is actually worse than it sounds.

If I Get Info on a .nwm file and set to open with Nisus and then click Change All (whether I've closed the Get Info and reopened or not), the setting for the file in question *reverts to TextEdit*. wtf?

I take it that this is an OS problem so I won't hold my breath for a fix.


2009-12-28 09:13:17
Profile

Joined: 2008-05-17 04:02:32
Posts: 400
Perhaps you can fix it by using a free preferences pane Default Apps.
http://www.rubicode.com/Software/RCDefaultApp/
Install it, open it, switch to Extensions tab and choose Nisus Writer Pro as the Default Application for nwm. If nwm is not listed, add it.

Also, try to rebuild Launch Services database using a utility such as Onyx.


2009-12-29 01:58:51
Profile

Joined: 2007-11-09 15:27:25
Posts: 86
Thanks. This seems to have done the trick. :)


2009-12-29 08:19:29
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software