Shading Fail in Big Sur

Everything related to our flagship word processor.
Post Reply
hatchmo
Posts: 92
Joined: 2004-03-01 10:35:56
Location: Cotati, CA

Shading Fail in Big Sur

Post by hatchmo »

Shading Blend fails for Paragraph Shading and Cell Shading, because both foreground and background are set to the same color.

Set Pattern to None.
Click Foreground. Both Foreground and Background change to Black.
Set Pattern to None.
Click Background. Both Foreground and Background change to White.
Set Pattern to None.
Change Foreground color to any color at all. Both Foreground and Background change to that color.

This behavior appeared immediately after upgrading from Catalina to Big Sur. It did not appear in Catalina.

Mac Mini 2018
Nisus Writer Pro 3.2.1
macOS 11.4 Big Sur
Al Hatch

hatchmo
Posts: 92
Joined: 2004-03-01 10:35:56
Location: Cotati, CA

Re: Shading Fail in Big Sur

Post by hatchmo »

Just tested on a 2015 iMac. The problem did not appear while running Catalina.
I upgraded to Big Sur. Same problem. Foreground and background are always set to the same color.
Al Hatch

User avatar
phspaelti
Posts: 1201
Joined: 2007-02-07 00:58:12
Location: Japan

Re: Shading Fail in Big Sur

Post by phspaelti »

I think I know what you mean. You have to set the pattern to some blend (say 15%, etc.) first or you cannot set the foreground and background color indepedently.
philip

hatchmo
Posts: 92
Joined: 2004-03-01 10:35:56
Location: Cotati, CA

Re: Shading Fail in Big Sur

Post by hatchmo »

Thanks, Philip. What you say is true… sometimes.
This video demonstrates my issue.
https://www.dropbox.com/s/b1re6sgz8nm9y ... g.mp4?dl=0
Al Hatch

User avatar
phspaelti
Posts: 1201
Joined: 2007-02-07 00:58:12
Location: Japan

Re: Shading Fail in Big Sur

Post by phspaelti »

Hi Hatchmo,
I can reproduce what happens to you, and what you describe is obviously a bug, and needs to be fixed. I hope Nisus can fix this, and that this is not something that depends on Apple.

The way I work around it—and the reason I in fact often fail to notice the problem—is that I use the two "colors" fields below the Pattern selector. So as long as you use the sequence, (1) choose pattern then (2) select the "colors", you can get around this. Obviously not great, but…
philip

User avatar
martin
Official Nisus Person
Posts: 4958
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Shading Fail in Big Sur

Post by martin »

hatchmo wrote:
2021-06-08 07:51:36
Thanks, Philip. What you say is true… sometimes.
This video demonstrates my issue.
https://www.dropbox.com/s/b1re6sgz8nm9y ... g.mp4?dl=0
Thank you for that video Al, which makes the problem very clear. This does look like a Nisus bug. I'll make a note that we need to get it fixed– thanks!

Post Reply