Changes Word icons to Nisus icons

Everything related to our flagship word processor.
Cochise
Posts: 5
Joined: 2007-08-25 07:37:44

Changes Word icons to Nisus icons

Post by Cochise » 2007-08-25 07:53:24

I have always used Nisus for my personal writing. However, since I have installed Nisus Writer Pro, it has changed all the hundreds of Microsoft Word file icons related to my work, not my personal writing, to Nisus icons. Thus, when I double-click on a file I need to open in Word, it opens instead in Nisus. If I open the file from the Word File Menu, then Save it as a Word file, the icon remains a Nisus icon. This creates a major problem for me because my job requires that I use Word, and that others using Word be able to have access to my Word files. Does someone know of a remedy short of removing Nisus Writer Pro from my computer (G4 Powerbook 17)?

TommyW
Posts: 27
Joined: 2007-04-21 06:33:48
Location: Ireland
Contact:

Post by TommyW » 2007-08-25 08:38:42

Just use the Finder to reset which app opens those files. Choose one of the documents in the finder with a single click, then Cmd+I to bring up the Get Info window. Then in the Open With section, choose Word. Click on the Change all to change all documents to open with Word.

To open them in NWPro, you'll have to right-click on the document icons and choose NWPro from the Open With menu.

Oh and for what it's worth, none of my Wintel+Word weilding colleagues have ever had a problem with any NWPro doc I've sent them...it mightn't be the problem you imagine. Try a test run with one of them.

Cochise
Posts: 5
Joined: 2007-08-25 07:37:44

Post by Cochise » 2007-08-25 08:58:12

Thanks for the help. It seems to work one file at a time, even though I click Change All in the Info pane, and the subsequent dialog box asks "Are you sure you want to change all your Microsoft Word documents to open with the application "Microsoft Word"? and adds "This change will apply to all Microsoft Word documents with the extension ".doc".

The fact that the change doesn't apply to all seems like a separate problem.

Cochise
Posts: 5
Joined: 2007-08-25 07:37:44

Post by Cochise » 2007-08-25 09:11:37

Come to think of it, that's mighty intrusive of Nisus to change all my icons and force me to change them back, don't you think? Sounds more like something Microsoft might do.

TommyW
Posts: 27
Joined: 2007-04-21 06:33:48
Location: Ireland
Contact:

Post by TommyW » 2007-08-25 09:20:23

It's the Finder who does it...

Try logging out and in again, it might refresh everything.

Cochise
Posts: 5
Joined: 2007-08-25 07:37:44

Post by Cochise » 2007-08-25 09:40:51

Thanks again. That was refreshing indeed.

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin » 2007-08-27 13:40:13

Yes, the Finder controls which application opens which documents- I can assure you that Nisus does nothing to try to change all your .doc files to open in Nisus Writer. I can only assume that since we tell the Finder that we can open .doc files, and we are the "newer" application, it decides to use us.

Cochise
Posts: 5
Joined: 2007-08-25 07:37:44

Post by Cochise » 2007-08-27 14:00:44

The Finder is biased in the right direction.

ericjs
Posts: 1
Joined: 2007-11-08 22:37:49

Post by ericjs » 2007-11-08 22:44:49

Suddently, Word documents sent to me acquire a Nissus icon and open in Nissus. How can I stop it doing this other than trash the application?

Eric

User avatar
mrennie
Posts: 173
Joined: 2004-11-10 07:31:31

Post by mrennie » 2007-11-08 23:29:51

This is not a Nisus Writer Pro issue, it's a Finder/Mac OS X issue. To make Word documents open in Word again, ctrl-/right-click one of these documents and select Get Info from the contextual menu. In the Get Info window, expand the Open With section, select Microsoft Word from the dropdown list and click on the Change All button.

shades
Posts: 118
Joined: 2002-11-12 18:51:49

Post by shades » 2007-11-09 05:05:22

Unfortunately, that only works for about 2-3 days, and then it is back to the same practice. Even logging out and back in does not solve this problem.
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08

User avatar
mrennie
Posts: 173
Joined: 2004-11-10 07:31:31

Post by mrennie » 2007-11-09 06:34:24

Have you tried repairing disk permissions with Disk Utility? If not, go ahead and try it; there's a small chance that this might solve the problem.

User avatar
Ryan
Posts: 211
Joined: 2005-01-31 14:36:45
Location: Portland, OR
Contact:

Post by Ryan » 2007-11-10 10:14:09

ericjs wrote:Suddently, Word documents sent to me acquire a Nissus icon and open in Nissus. How can I stop it doing this other than trash the application?

Eric
Again, to reiterate what Martin said (two posts before), the Finder controls this. Changing the default application and logging out/logging back in ought to fix the problem, but if it doesn't, repairing disk permissions is a good idea.

If that still doesn't solve the issue, lay blame on the Finder. It has many detractors.

shades
Posts: 118
Joined: 2002-11-12 18:51:49

Post by shades » 2007-11-10 12:31:36

mrennie wrote:Have you tried repairing disk permissions with Disk Utility? If not, go ahead and try it; there's a small chance that this might solve the problem.
I use it every time I add software to the hard drive. Still no help.
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08

shades
Posts: 118
Joined: 2002-11-12 18:51:49

Post by shades » 2007-11-16 09:17:32

Every time I start the computer, I have to go into the System Preferences > Default Apps, and change the .doc setting from Nisus to Word, because when it shuts down, for some reason the Finder changes the settings in Default Apps to Nisus.

While I like Nisus, this is irritating. Repairing Permissions does nothing to help.

(It doesn't take much for old codgers to get frustrated. :D)
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08

Post Reply