Reply to topic  [ 7 posts ] 
strange en-dash behavior with courier fonts 
Author Message

Joined: 2007-09-02 09:32:02
Posts: 41
Location: Hartford, CT
Hello all,

I'm not sure how to phrase this question. In the courier font NWP produces a strange auto correct when I type "--" that conjoins the two characters when I press the space bar. That is, it seems to try to do an autocorrect of some kind. However, I have no such autocorrect set and it doesn't do this in other fonts.

Does anyone know what is the matter?

best,
Sam


2007-09-02 09:45:46
Profile
User avatar

Joined: 2004-10-26 07:10:40
Posts: 174
Location: Tucson, AZ
Post 
I can't reproduce this. When I type "--" followed by a space bar in Courier, they remain as typed.

Scott

_________________
MacBook Pro 15
2.66 Ghz Core i7
8GB RAM
10.8.3
NWP 2.0.4
iPad 3


2007-09-03 01:18:42
Profile

Joined: 2007-09-02 09:32:02
Posts: 41
Location: Hartford, CT
Post 
Thanks for trying, Scott. A few weeks ago I would not have been able to reproduce this either. This issue has just recently cropped up. But it's driving me crazy.

Sam


2007-09-03 07:26:38
Profile
User avatar

Joined: 2004-10-26 07:10:40
Posts: 174
Location: Tucson, AZ
Post 
I bet...what's really weird is that it only shows up in Courier...so that rules out any kind of QuickFix problem.

Hopefully Martin can help you out.

Scott

_________________
MacBook Pro 15
2.66 Ghz Core i7
8GB RAM
10.8.3
NWP 2.0.4
iPad 3


2007-09-03 11:14:13
Profile
User avatar

Joined: 2007-03-31 14:59:22
Posts: 333
Location: Frankfurt, Germany
Post 
Well -

I too can't reproduce this - it reminds me somehow of Publius' theorem on:

Derick wrote:
Am I missing something or does NWP not automatically convert two dashes ( -- ) to an em-dash?


So in a way we had this before - did you do a count of the so-called "conjoint"?
Make sure it is not just a display thing. What Courier, at what size?

HE

_________________
MacBook Pro i5
SSD 840/850 Pro
macOS Sierra 10.12.6
Nisus Writer Pro 2.1.8


2007-09-03 12:57:42
Profile
User avatar

Joined: 2007-04-12 04:01:46
Posts: 767
Location: Melbourne, Australia
Post 
If the document is not totally confidential, why not send it to the Solanums to look at using the bug reporting facility in the Help dialog?

By the way -- have you checked Quickfix? Although that would be very odd if it fixed something in only one font. Hmm -- forget that! Just report it as a bug.

Cheers, Geoff

Geoffrey Heard, Business Writer & Publisher

"Type & Layout: Are you communicating or just making pretty shapes" -- Revealed! The secrets of how you can use type and layout to turbocharge your messages in print. See the book at http://www.worsleypress.com


2007-09-03 13:13:46
Profile WWW

Joined: 2007-09-02 09:32:02
Posts: 41
Location: Hartford, CT
Post 
Thanks to all. I sent a sample text to Nisus. Although, perhaps they will not encounter see the problem--I opened the same document in Word and Mellel and it didn't have this issue!

Completely weird. Maybe I should re-download Nisus (and the courier font?) and see if that helps.


2007-09-03 14:07:24
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: Bing [Bot] and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software