Numbered Lists - UK legal Style

Everything related to our flagship word processor.
Post Reply
Simon Knight
Posts: 13
Joined: 2007-10-31 02:15:13

Numbered Lists - UK legal Style

Post by Simon Knight » 2007-10-31 02:33:57

I have been experimenting with the demo version and wish to create a list style that follows the UK convention of legal numbering e.g.

1 para one
1.1 Sub para 1
1.2 Sub para 2
2 para two
2.1 sub para 2
2.1.1 sub sub para

Unfortunately I have not found a way of preventing the final stop from occuring e.g.

1.
1.1.
etc

Is it possible?
Simon

User avatar
Hamid
Posts: 734
Joined: 2007-01-17 03:25:42

Re: Numbered Lists - UK legal Style

Post by Hamid » 2007-10-31 08:40:39

Simon Knight wrote:Unfortunately I have not found a way of preventing the final stop from occuring e.g.Simon
You can remove the final stop from the Lists palette in the Tooldrawer; just delete the stop from the 'After Text' field.

User avatar
greenmorpher
Posts: 767
Joined: 2007-04-12 04:01:46
Location: Melbourne, Australia
Contact:

Post by greenmorpher » 2007-10-31 13:22:27

In the "Tiered List" it isn't "After text" it is "Separator", so deleting the point in that field removes the points between the numbers too, Hamid. You get:

1
11
111
1111

etc.

How this works needs to be changed by the Nisoids, I think. The point needs to be "Before Text" applying to numbers after the first figure. Or After Text applying only to numbers after the last figure. There needs to be that exception introduced.

You can't fix it by making the point "Before Text", by the way -- that just puts it in front of the number.

Cheers, Geoff

Geoffrey Heard, Business Writer & Publisher

"Type & Layout: Are you communicating or just making pretty shapes" -- Revealed! The secrets of how you can use type and layout to turbocharge your messages in print. See the book at http://www.worsleypress.com

User avatar
martin
Official Nisus Person
Posts: 4361
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin » 2007-10-31 16:30:09

What you'll need to do:

1. Switch to stylesheet view.
2. Select the list style you want to change from the list on the left.
3. Select the first list level in the preview text on the right.
4. Use the Lists palette to change the list level format to "custom" (click the tab labeled "#", next to "1.1").
5. Delete the period that follows the last level number bubble.
6. Repeat steps 3-5 for the other list levels you intend to use.

If this is a list style you want to make use of often, you probably want to make the change in your Nisus New File (the new document template). You can open that for editing in your preferences:

1. Switch to the New File preference pane.
2. Click the Advanced tab.
3. Click the Edit Nisus New File... button.
4. Make the changes to the list style as above.
5. Save and close the file.

User avatar
greenmorpher
Posts: 767
Joined: 2007-04-12 04:01:46
Location: Melbourne, Australia
Contact:

Post by greenmorpher » 2007-10-31 21:27:55

Hi Martin

In Stylesheet view, the lists palette "#" is inactive.

NWPro 1.0.1, OS X.4.10

Cheers, Geoff

Geoffrey Heard, Business Writer & Publisher

"Type & Layout: Are you communicating or just making pretty shapes" -- Revealed! The secrets of how you can use type and layout to turbocharge your messages in print. See the book at http://www.worsleypress.com

User avatar
martin
Official Nisus Person
Posts: 4361
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin » 2007-10-31 21:29:50

That's an unfortunate bug in NWP 1.0.1 and NWX 3.0. It has been fixed for the NWP 1.0.2 and NWX 3.0.1 public betas.

User avatar
greenmorpher
Posts: 767
Joined: 2007-04-12 04:01:46
Location: Melbourne, Australia
Contact:

Post by greenmorpher » 2007-11-01 03:31:46

Okay, got it thanks, Martin.

Cheers, geoff

Simon Knight
Posts: 13
Joined: 2007-10-31 02:15:13

Post by Simon Knight » 2007-11-01 08:51:59

Thanks for all the replies: I'm glad that it was not an obvious switch to remove the final stop.

Simon

Simon Knight
Posts: 13
Joined: 2007-10-31 02:15:13

Post by Simon Knight » 2007-11-02 00:56:17

Hi (again),

I've down loaded the public beta and have been changing the tiered list ending as described above. It seems to be working except that at level 9 only the first four character groups are displayed in the edit box - I have not managed to scroll down to the last character group; it could be me or a minor bug.

Simon

User avatar
greenmorpher
Posts: 767
Joined: 2007-04-12 04:01:46
Location: Melbourne, Australia
Contact:

Post by greenmorpher » 2007-11-02 14:18:43

I got this too, Simon, but just go the right arrow and it will scroll down to the end (and out of sight), do a back space, and all will be well.

Cheers, geoff

Post Reply