100% processor usage & fonts (somewhat related thread)

Everything related to our flagship word processor.
Post Reply
kveldalf

100% processor usage & fonts (somewhat related thread)

Post by kveldalf » 2007-12-02 15:20:48

I'm not trying to flame the board seriously, but there are so many things that keep happening, I can barely keep up. E.g. I am trying to learn how to use the program, so I wanted to turn off the typeface preview in the list of fonts so that I could simply see the typeface names. In course of my searching, I found the languages panel in the preferences pane and saw the setting for a secondary font. I clicked that and the font palate opened, then Nisus started tapping the CPU at 97% to 100% = beachball and long waits. I was just preparing for a crash to be honest.

It didn't crash,but after each 12 - 15 second wait, I'd click, get the beach ball and wait again. There's just something up about the fonts and Nisus that I can't put my finger on---I know, start another thread. But seriously, I select a Hebrew font from the list, and it doesn't change the typeface. I opened TextEdit to test the font, fine. Mellel, fine. Nisus, nothing; it's like I had chosen no different font than that one that was displaying. Don't get me wrong, It looks like Nisus has some really cool features which is why I'm really wanting it to work out, but it comes off as fussy, having font issues, and you never know when it will hang.

So what system is all of this happening on?
Powerbook G4, 1.25 Ghz, 1.25 GB RAM, OS X Leopard 10.5.1
Seriously, if this program flies on one of your configurations let me know what it is, I'm curious to know what makes it hang so much on mine.

ssampler
Posts: 84
Joined: 2006-06-29 07:56:30
Location: Hudson River Valley, NY

Post by ssampler » 2007-12-03 08:24:05

I have a setup similar to yours: NWP 1.0.2 PB G4, 2GHz memory, 10.5.1. Font preview turned on. I cannot reproduce your CPU usage problem here or in 10.4.11. When I try, NWP's CPU usage doesn't arise more than a few percentage points, if any, above the current usage.

You might send the console log to the Nisus Folks with details: Did you have a document open? How big? Was it trying to 'autosave' during this time? I don't really know what 'input managers' or 'haxies' are, but, if you have any, disable them and see if the problem recurs.

Your typeface problem: I cannot be sure what you are trying to do. On my system, NWP and Textedit behave identically. What was typed in English appears in English and what was typed in Hebrew appears in Hebrew, even if I select all text and apply a new font, Hebrew, English, Russian...or change NWP's language setting. However I don't use other languages except for occasional tests, so other users who use them extensively can probably provide you with better answers.

Good luck!

User avatar
martin
Official Nisus Person
Posts: 4251
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: 100% processor usage & fonts (somewhat related threa

Post by martin » 2007-12-03 15:31:39

kveldalf wrote:I wanted to turn off the typeface preview in the list of fonts so that I could simply see the typeface names.
This is not a language preference. You'll want to visit the Appearance preference pane and uncheck the option "font menu shows previews".
I select a Hebrew font from the list, and it doesn't change the typeface.
The "secondary font" option in the Languages preference pane does not in general control what font is used to display text. It only has any effect if the primary font (eg: the one that you've applied to the text directly) does not contain the characters it is applied to.
So what system is all of this happening on?
Powerbook G4, 1.25 Ghz, 1.25 GB RAM, OS X Leopard 10.5.1
Just to be sure- are you using the latest version (1.0.2) of Nisus Writer Pro that is compatible with Leopard?

Post Reply