Language Settings in Preferences

Everything related to our flagship word processor.
Post Reply
ProfT
Posts: 79
Joined: 2005-03-09 06:53:40
Location: Louisville KY

Language Settings in Preferences

Post by ProfT » 2008-12-01 11:06:24

When switching between two languages (English and Hebrew in this case), the font size set in the Languages section of the Preferences does not work as expected.

If writing in English (12 pt. Palatino based on style selection) and I switch languages to Hebrew (set with secondary font as New Peninim MT 16 pt) the font size does not change although the correct secondary font is selected. Likewise when returning to English, after manually increasing the font size, the correct secondary font is selected, but the font is unaffected by the setting in Preferences. I imagine that the "local" selection of font size in the document is overriding the preference setting, but I can find no way of changing this behavior.

Any help would be appreciated. Being able to change font size with the switch in languages is wonderful, especially for languages like Hebrew where a slightly larger size is needed to ensure continuity in the appearance of the text on the printed page (not to mention the appearance to aging eyes like mine!).

User avatar
martin
Official Nisus Person
Posts: 4261
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Language Settings in Preferences

Post by martin » 2008-12-01 16:15:36

Even though one can select a specific font size in the language preferences, that font size will not be used when automatically switching the font based on the language. So essentially you're correct that the "local" font size will always win out. We know that some users want font size switching and others not, so we have plans to add this as a separate feature/checkbox. Until then you might consider using a macro whenever you want to switch into Hebrew, eg:

Code: Select all

Menu ':Format:Language:Hebrew'
Menu ':Format:Size:16'

ProfT
Posts: 79
Joined: 2005-03-09 06:53:40
Location: Louisville KY

Re: Language Settings in Preferences

Post by ProfT » 2008-12-01 16:49:43

Thank you! I appreciate both knowing the feature is in the future plans and the suggestion of a much more pleasant work around in the interim. I look forward to using the macro (, but even more to the addition of the feature!).

This is why I tell everybody I know to give NWP a try. The product is tremendous, but combined with the responsive support and engaged user community it really cannot be matched.

Prof T

User avatar
martin
Official Nisus Person
Posts: 4261
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Language Settings in Preferences

Post by martin » 2008-12-01 17:14:01

Why thank you! We love having you all on here helping each other out. It's fantastic to see questions answered before we can even read them :)

ProfT
Posts: 79
Joined: 2005-03-09 06:53:40
Location: Louisville KY

Re: Language Settings in Preferences

Post by ProfT » 2008-12-02 11:16:23

This question will reveal why I didn't come up with a "macro solution" on my own!

I ran the macro and it did not work because the menu under Format:Size does not have 16 listed. I changed the macro instruction to 18 and it worked perfected as 18 is there in the menu. What command would need to be used to have the macro change the font size to something not already listed in the menu?

thanks,
Prof T

User avatar
martin
Official Nisus Person
Posts: 4261
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Language Settings in Preferences

Post by martin » 2008-12-02 12:15:27

Oops, you're quite right. I didn't even think to look if the size was listed, sorry about that. Here's the macro code that will work:

Code: Select all

Menu ':Format:Language:Hebrew'
Set Font Size 16

ProfT
Posts: 79
Joined: 2005-03-09 06:53:40
Location: Louisville KY

Re: Language Settings in Preferences

Post by ProfT » 2008-12-02 12:39:34

Thanks!

Post Reply