Cross-references with “above”/“below” and language settings

Everything related to our flagship word processor.
User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Cross-references with “above”/“below” and language setti

Post by martin » 2016-03-03 19:20:03

Thank you for the file axolotl. I took a look and the problem you were having earlier wasn't due to any preferences. It looks like there's a bug with the newly added language-sensitive cross-reference suffix, where Nisus Writer won't consider the language of any styles (eg: Normal). Nisus Writer incorrectly only considers the language applied directly to the text (aka: manual formatting). That's a shame, and something we'll have to fix.

I'm glad you brought this to our attention, and I hope the enhancement is still useful, despite its current limitations.

User avatar
axolotl
Posts: 15
Joined: 2011-12-23 08:02:54
Location: Europe
Contact:

Re: Cross-references with “above”/“below” and language setti

Post by axolotl » 2016-03-03 19:36:32

martin wrote:I took a look and the problem you were having earlier wasn't due to any preferences. It looks like there's a bug with the newly added language-sensitive cross-reference suffix, where Nisus Writer won't consider the language of any styles (eg: Normal).
Yes, you are right. In the moment when I add the language to the style attributes, the reference changes back to English :(
So the new prefs file only helped because it did reset my styles…
martin wrote:I'm glad you brought this to our attention, and I hope the enhancement is still useful, despite its current limitations.
Well, I’m more than happy that eventually you’ve started working on the bug. Slowly but surely Nisus is becoming a multilingual-capable word processor ;)

Post Reply