Search broken (possible conjecture as to cause)

Everything related to our flagship word processor.
Post Reply
tarakananda
Posts: 32
Joined: 2005-09-11 12:51:57
Contact:

Search broken (possible conjecture as to cause)

Post by tarakananda » 2012-08-13 12:09:27

We have noticed some strange behavior in the latest update to Nisus Pro: the search function breaks down under certain circumstances.

We have been working with large documents copied from PDFs from archive.com. These documents are 200 pages plus, and when they are copied from the PDFs, or if the PDFs are converted to text (an Adobe Reader function), the Nisus search will not find anything in the new document, even the most evident words, such as "the". We did a reboot of Nisus, to no effect. We did a restart, and that solved the problem, until we did another large copy/paste. Then it ceased to function again.

We assumed therefore that this had something to do with the clipboard, some kind of overload of its brains. Does this sound like a reasonable conjecture?

Since we can get it to work again, it is only an annoyance, not a total roadblock. But we would like to know your thoughts, and any other solutions.

Thanks, as always.

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Search broken (possible conjecture as to cause)

Post by martin » 2012-08-13 16:21:48

Since you say that restarting NWP doesn't fix the problem, but restarting your whole computer does, it sounds like a problem with OSX or your system/computer.

However, there is one way in which the system clipboard is connected to NWP's find feature: when you switch to the find panel, NWP will automatically fill the "find what" field with the contents of the system search pasteboard (note that this "search" clipboard is separate from the normal copy-paste clipboard). But perhaps there's something about this process that's triggering the issue?

Here's what I'd advise:

1. The next time the problem occurs, quit NWP; but this time, instead of relaunching NWP immediately, go copy something small and innocuous (eg: a single word from Safari or TextEdit). Then try relaunching NWP to see if the Find feature works again.

2. If that doesn't work, please use the menu Help > Send Feedback and we can look at the collected logs to see if some error was recorded.

Hopefully we can get this solved; thanks for your help!

Post Reply