Style problem

Everything related to our flagship word processor.
Post Reply
writerhoward
Posts: 48
Joined: 2013-02-03 05:10:26

Style problem

Post by writerhoward »

I'm using v. 2.0.4 on Snow Leopard.

I typed the first two lines in the image below, resetting the "Heading 1" line using the Styles menu in the Writing Palette Group. Then, I clicked in the second line, "Normal line 1," and in the Formatting Palette Group clicked Paragraph -> Indents and set the First Line Indent to 0.25. That worked.

Next, I skipped a line and typed "Heading 2," setting that to the Heading 2 style, and then added "Normal line 2."
Screen shot 2013-02-03 at 8.07.56 AM.png
Screen shot 2013-02-03 at 8.07.56 AM.png (14.42 KiB) Viewed 6909 times
I expected "Normal line 2" to also have the 0.25 first line indent as I thought I'd changed the normal style; however, it didn't.

I also tried to use "Redefine Style From Selection" to reset "Normal line 2" but that didn't even work. (Does it have a bug?)

What did I do wrong? I want the Normal style to have a quarter-inch first line indent.

Howard

martin
Official Nisus Person
Posts: 4791
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Style problem

Post by martin »

Hello Howard, and welcome to the forums.

There are two types of formatting (aka attributes) that you can apply to text in your document: styles and manual formatting. It sounds like you're familiar with styles, so I'll just explain the latter. Manual formatting is applied on top of text that may already have styles applied and takes precedence over formatting enforced by a style; in other words it overrides the formatting enforced by styles.

This might sound confusing but you've probably already used this system to good effect. For example, you've probably had a paragraph styled using Normal, selected a single word in that paragraph, and added bold so just that single word was bolded. That addition of bold is manual formatting that overrides the style for a single property (in this case font weight), while still retaining the rest of the properties enforced by the style.

Getting back to your question about indents:
writerhoward wrote:Then, I clicked in the second line, "Normal line 1," and in the Formatting Palette Group clicked Paragraph -> Indents and set the First Line Indent to 0.25. That worked.
Using the Paragraph palette in this way actually added manual formatting to text you had selected. In other words, your action told Nisus Writer to just add the "First Line Indent of 0.25" attribute to that single paragraph, overriding your Normal style's default indent of zero.

There's two ways to achieve what you'd like. Here's the first:

1. Modify your Normal paragraph style to add the desired indent:
a. Switch to the Style Sheet view, eg: using the menu View > Style Sheet.
b. From the list of styles on the left, make sure "Normal" is selected.
c. Adjust the indent as desired (you can do this using the ruler, Paragraph palette, or menus).

That will automatically update all paragraphs in your document so they use the new indent (assuming they don't have any manual formatting overrides, of course).

The other solution:

2. Redefine your style using some document selection:
a. In your document text, select any paragraph using the "Normal" style.
b. Format the paragraph however you like, eg: using the palettes and menus.
c. With that paragraph still selected, use the command "Redefine Style From Selection".

This will adjust the "Normal" style so it uses whatever formatting is applied to the current document selection. In your example screenshot you would have wanted to select the paragraph text "Normal line 1" and then used the command.

I hope this helps. Let us know if you have any questions.

writerhoward
Posts: 48
Joined: 2013-02-03 05:10:26

Re: Style problem

Post by writerhoward »

Martin,

Thanks for the comprehensive explanation.

One thing that caused some of what I did to not work correctly was that in Style Sheet View the Heading 1 style was based on Normal. When I changed that to None that made a big difference. That also leads to a new question. When I make changes in the Style Sheet View, what's the best way to save the changed document so it becomes the default template that appears whenever "New" is clicked in the File menu.

Howard

martin
Official Nisus Person
Posts: 4791
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Style problem

Post by martin »

writerhoward wrote:One thing that caused some of what I did to not work correctly was that in Style Sheet View the Heading 1 style was based on Normal. When I changed that to None that made a big difference.
Basing the Heading style(s) on Normal is intentional; it's often practiced that all styles are descendants of Normal at some level. If you choose to indent your Normal style in this style configuration that would also undesirably indent your Heading styles. To fix that you could just adjusting your "Heading 1" style so the indent is set back to zero, which would also zero out all other Heading styles.

But of course you should use whatever style hierarchy makes the most sense to you!
That also leads to a new question. When I make changes in the Style Sheet View, what's the best way to save the changed document so it becomes the default template that appears whenever "New" is clicked in the File menu.
You can change the set of styles present in new documents by editing your Nisus New File template via the "New File" pane in Nisus Writer's preferences. You can configure all aspects of the Nisus New File including styles, zoom, document window size/position, etc. We also have a style library where you can store styles and then later import them into documents.

writerhoward
Posts: 48
Joined: 2013-02-03 05:10:26

Re: Style problem

Post by writerhoward »

The reason I indent the first line in each Normal paragraph is that's how it's done in MLA format. (My indent was just testing how to do it. In MLA, the actual first-line indent is a half inch. In the past, I've just tabbed the first line; however, I've read where tabs aren't the best way to do it if you plan to convert your text into either MOBI or ePub form, so that's why I've used the first-line indent. Is there a way I can effect the indent without setting Normal's descendants to None?

Howard

P.S. After giving this some more thought, occasionally I do write using block paragraphs, which eliminates the need to convert Normal's descendant to None. In Style Sheet View, I know how to add spacing after a paragraph. What I don't know is how many "points" effect a single-spaced line.

exegete77
Posts: 194
Joined: 2007-09-20 17:58:56

Re: Style problem

Post by exegete77 »

Just a side note on style sheets and interrelationships...

In all my word processors over the years (Word, Nisus, Mellel, Papyrus), there is always a Normal style (no indent, single line spacing, etc.), but I never use it for an applied style in the document. It only serves as a base for all others. Then, I have two styles that are based on Normal: Heading and Text. Heading will serve as the base for all Heading styles, and Text for any kind of text styles. Thus, Text will have the line spacing I want (say, 15 pt, with 2 pt above and 2 pt below), left flush, etc. Then Text Body, Text First Indent, Quotation, Caption, etc. are styles based on Text. Similar pattern with Heading.

Thus, I make changes in essential three places. Overall font change/size, I change Normal, everything else I change Heading or Normal depending on what I need. Works very well for me and is adaptable. Have been using style sheets for 22+ years and it hasn’t failed me yet.
iMac 21.5” / MBP 13” Retina
Mac user since 1990

exegete77
Posts: 194
Joined: 2007-09-20 17:58:56

Re: Style problem

Post by exegete77 »

P.S. After giving this some more thought, occasionally I do write using block paragraphs, which eliminates the need to convert Normal's descendant to None. In Style Sheet View, I know how to add spacing after a paragraph. What I don't know is how many "points" effect a single-spaced line.
Part of that is determined by the font size. But more importantly, I think it is better to use line spacing set “exactly” and then use the points above/below. Much better control of spacing.
iMac 21.5” / MBP 13” Retina
Mac user since 1990

writerhoward
Posts: 48
Joined: 2013-02-03 05:10:26

Re: Style problem

Post by writerhoward »

exegete77 wrote:Just a side note on style sheets and interrelationships...

In all my word processors over the years (Word, Nisus, Mellel, Papyrus), there is always a Normal style (no indent, single line spacing, etc.), but I never use it for an applied style in the document. It only serves as a base for all others. Then, I have two styles that are based on Normal: Heading and Text. Heading will serve as the base for all Heading styles, and Text for any kind of text styles. Thus, Text will have the line spacing I want (say, 15 pt, with 2 pt above and 2 pt below), left flush, etc. Then Text Body, Text First Indent, Quotation, Caption, etc. are styles based on Text. Similar pattern with Heading.

Thus, I make changes in essential three places. Overall font change/size, I change Normal, everything else I change Heading or Normal depending on what I need. Works very well for me and is adaptable. Have been using style sheets for 22+ years and it hasn’t failed me yet.
Excellent idea. I added a Body style, which I modified from Normal to meet my specifications; however, whenever I press Return for a new paragraph, it's in Normal style rather than Body style. Is there a way to have Body style as the default paragraph style while maintaining it as a descendant of Normal style?

Thanks,
Howard
Last edited by writerhoward on 2013-02-05 08:42:32, edited 1 time in total.

writerhoward
Posts: 48
Joined: 2013-02-03 05:10:26

Re: Style problem

Post by writerhoward »

exegete77 wrote:
P.S. After giving this some more thought, occasionally I do write using block paragraphs, which eliminates the need to convert Normal's descendant to None. In Style Sheet View, I know how to add spacing after a paragraph. What I don't know is how many "points" effect a single-spaced line.
Part of that is determined by the font size. But more importantly, I think it is better to use line spacing set “exactly” and then use the points above/below. Much better control of spacing.
I have Line Spacing set to "1 Lin" and am using the Times font -- Is that how you would set the font size "exactly"? I'm still considering what to set the points above/below to.

exegete77
Posts: 194
Joined: 2007-09-20 17:58:56

Re: Style problem

Post by exegete77 »

writerhoward wrote:
exegete77 wrote:
P.S. After giving this some more thought, occasionally I do write using block paragraphs, which eliminates the need to convert Normal's descendant to None. In Style Sheet View, I know how to add spacing after a paragraph. What I don't know is how many "points" effect a single-spaced line.
Part of that is determined by the font size. But more importantly, I think it is better to use line spacing set “exactly” and then use the points above/below. Much better control of spacing.
I have Line Spacing set to "1 Lin" and am using the Times font -- Is that how you would set the font size "exactly"? I'm still considering what to set the points above/below to.
Just below where it says 1 line, it will indicate whether it is “multiple” or “Fixed”. Click and make sure it is Fixed.
iMac 21.5” / MBP 13” Retina
Mac user since 1990

exegete77
Posts: 194
Joined: 2007-09-20 17:58:56

Re: Style problem

Post by exegete77 »

writerhoward wrote: Excellent idea. I added a Body style, which I modified from Normal to meet my specifications; however, whenever I press Return for a new paragraph, it's in Normal style rather than Body style. Is there a way to have Body style as the default paragraph style while maintaining it as a descendant of Normal style?

Thanks,
Howard
In the Style settings, if you look under the name of the style, there will be two small drop downs. The first is “Based on” and the one below it is “Next style.” My guess is that the Next Style is set to Normal. Change that to whatever you want.

Example:

My first style I start a project with is “Title” and in the Next Style dropdown, I have it set to “Subtitle.” Then for Next Style with “Subtitle” I have it set to “First Para” (no indent for first paragraph), and the Next Style is “Body First Indent.” The Next Style for “Body First Indent” is “Body First Indent.”

Thus, when I hit return each time the new style will appear automatically.
iMac 21.5” / MBP 13” Retina
Mac user since 1990

martin
Official Nisus Person
Posts: 4791
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Style problem

Post by martin »

writerhoward wrote: I added a Body style, which I modified from Normal to meet my specifications; however, whenever I press Return for a new paragraph, it's in Normal style rather than Body style. Is there a way to have Body style as the default paragraph style while maintaining it as a descendant of Normal style?
exegete very graciously answered the first part of this about return switching to the proper next paragraph style, but as to changing the default paragraph style: that is possible. Just as with the default set of styles, you can configure this in the "New File" pane in NWP's preferences. To control the default style change the "Use Style" popup button, or edit the new file template directly to use whatever styles/formatting you'd like.

Post Reply