Styles palette problems

Everything related to our flagship word processor.
Post Reply
xiamenese
Posts: 422
Joined: 2006-12-08 00:46:44
Location: London or Exeter, UK

Styles palette problems

Post by xiamenese » 2013-05-08 18:36:43

I emailed Martin/Mark/profeedback about this a couple of weeks ago, but haven't had any answer ... I assume they are all busy with NWP 2.05, Infoclick upgrades, etc. ... but as it is something that's causing me problems, I wonder if anyone else has had this problem. My "Styles palette" no longer shows styles for footnotes or endnotes, or any of the list styles. Here's a screenshot to show what I mean.
Nisus Writer Pro 001.jpg
Nisus Writer Pro 001.jpg (97.44 KiB) Viewed 3680 times
The Styles palette on the left is floating on the desktop, but it makes no difference whether it is there or in the tool-drawer. As you can see, there are no "Note Styles" or "List Styles" given. But with the document on "Style view", you can see that the note styles and list styles are defined. These latter are less of a problem for me than the absence of note styles on the palette.

Much of my work is done in Scrivener, in particular reference translations of the texts I have set them to work on, with copious endnotes explaining why I have chosen a particular solution to a translation issue. I export the text with its endnotes from Scrivener and then tidy it up in NWP. One of the areas that needs tidying is the endnotes, because they come out of Scrivener with a . and a space after the index, and no hanging indent ... I want a tab following the index and a hanging indent. Also, I wish to have a gutter of 12pt between the text and the notes, rather than the 3pt default, and that the separator line should be centred in the gutter. However, I cannot change the style of the footnotes by simply clicking an entry on the palette as I can with every other type of paragraph.

Has anyone else had this problem? How do I get my footnote, endnote and list styles back on the Styles palette? I have tried removing the preferences and restarting, but it made no difference; I've tried closing the Styles palette and then re-opening it from the menu and from the palette manager, all to no avail. So ... can anyone advise, please?

Mark

Edit: Ooops, forgot the attachment. :oops:

User avatar
Hamid
Posts: 732
Joined: 2007-01-17 03:25:42

Re: Styles palette problems

Post by Hamid » 2013-05-08 21:02:42

That is normal:
Note styles are not available in the Styles palette (as mentioned in NWP help PDF, p. 96).
As for List styles, they have a separate palette of their own.

xiamenese
Posts: 422
Joined: 2006-12-08 00:46:44
Location: London or Exeter, UK

Re: Styles palette problems

Post by xiamenese » 2013-05-08 22:02:44

Thanks for the reply, Hamid. Thing is, I'm sure they used to appear there, especially endnote and footnote. And page 96 is a bit ambiguous, as it says note styles don't appear in the palette and then it then suggests they are there and highlighted in grey when the cursor is in a note.
The name of the style of the current selection is highlighted in gray.


•Endnote Use to determine the display of the text of your endnotes. This is the style
already present when you insert an endnote and your insertion point is in the endnote area;
•Footnote Use to determine the display of the text of your footnotes. This is the style
already present when you insert a footnote and your insertion point is in the footnote area.
I know there's the list styles palette ... I have that in the tool drawer, so, as I said, it doesn't give me a problem.

So the question is, when I've imported a document with footnotes or endnotes which are fundamentally unstyled and without the separator, and I want to format them into the style I have set up and imported from the style library, how do I go about it? I can't click on an entry in the styles palette; using the keyboard shortcut doesn't work, as that is for inserting a note when you're in the main text. The only ways I've found, are: (i) on the first note, set that up how I want, copy the ruler and then going down pasting the ruler into all the others; (ii) copy or cut the text of each note in turn, go back to the main text, delete the index there and then use the shortcut to set up a new foot/endnote and paste in the note text. The second way is very laborious, but at least it deals with the separator; the first way is slightly less laborious but I have to find a way of dealing with the separator.

So, given that, what do I do? Any suggestions welcomed.

Mark

User avatar
Hamid
Posts: 732
Joined: 2007-01-17 03:25:42

Re: Styles palette problems

Post by Hamid » 2013-05-09 00:13:40

Select all Footnotes/Endnotes and apply Footnote or Endnote as appropriate from the green tag in the Statusbar (at the bottom right of the document window).
This should work.
Any other overrides in the notes can be cleared by using tags in the Stausbar while the notes remain selected. For example, if a ruler other than the one set in your defined note styles affects your notes, a ruler tag will appear in the Statusbar when notes are selected. Applying 'Remove Ruler' from the ruler tag in the Stausbar will restore your defined ruler for all the notes.

xiamenese
Posts: 422
Joined: 2006-12-08 00:46:44
Location: London or Exeter, UK

Re: Styles palette problems

Post by xiamenese » 2013-05-09 18:08:37

Hamid wrote:Select all Footnotes/Endnotes and apply Footnote or Endnote as appropriate from the green tag in the Statusbar (at the bottom right of the document window).
This should work.
Now why didn't I think of that! :oops:

Actually, I hardly ever look at the status bar, as I can do everything (else) I want through the palettes or keystrokes. So let me try it ...

Thanks, Hamid

Mark

xiamenese
Posts: 422
Joined: 2006-12-08 00:46:44
Location: London or Exeter, UK

Re: Styles palette problems

Post by xiamenese » 2013-05-09 19:41:43

OK, further to my last …

Having exported a document with endnotes from Scrivener and opened it in NWP:
(i) the separator line was there but with the default 3 pt gutter with the line at the bottom;
(ii) the ruler is the default ruler, flush left, ragged right, no hanging indent;
(iii) the index is separated from the note text by a combination of full-stops + spaces — depending on the export setting from Scrivener I get a superscript index followed by a space and a full-stop then tab, or non-superscript index space full-stop space full-stop then tab — that I will need to sort out by find and replace anyway;
(iv) according to the status bar, the notes are recognised as endnotes, and clicking on "Endnote" makes no difference.

If I then choose "Edit style" from the dropdown on the status bar, or go to style view and choose "Endnote" there and make the changes I want: gutter 12pt, separator line in centre of gutter; hanging indent of about .66cm; "Note reference style" is already defined as "no superscript" though what I see in the text is what is defined in the Scrivener export, superscript if that is what the export setting is; default note text is a single space, so change that to a tab; set the paragraph to fully justified.
(i) the gutter is changed to 12pt, the separator line is moved to the middle of the gutter;
(ii) the index remains superscript if that's what it was;
(iii) the ruler does not reflect the ruler in the new style definition ... it is unchanged;
(iv) the paragraph remains justified left, ragged right ... no change.

So the only things that have changed with the style changes are the gutter and the separator line. I still have to select all the notes, change the ruler to give the hanging indent and set the justification. And as for the indices, if I have exported them as superscript, I cannot change that easily through the style sheet.

So I'm still rather stuck. I'm just wondering if in the past I made my own "Footnote" or "Endnote" style and that appeared in the style palette, overriding the default one. Perhaps I'll try that. As I'm going to be dealing potentially with hundreds of endnotes, I need to find a way of getting them the way I want less laborious ... unless of course Martin and co. read this and put the note styles into the style palette in such a way that one can apply all the changes at a click on the palette. Obviously, this is only an issue when one is importing documents with foot/endnotes in place like I am; there is no problem if one is writing and adding the endnotes in NWP itself.

Mark

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Styles palette problems

Post by martin » 2013-07-02 14:04:59

Hi Mark,

I believe we spoke about this a bit privately some time ago, but just to clarify a few points here:
Note styles are not available in the Styles palette
Hamid is correct in this. In fact, this has always been the case with Nisus Writer on OSX: note styles were never shown in the palette.

The reason for this is that it's very rare one will need to apply a note style. This is because any note in a file will always have a note style applied; it's impossible not to have a note style applied to a note, whether it be a footnote or endnote. Thus the only reason to apply a note style is if you need to convert footnotes to endnotes (or vice versa), which you can do using the menu Format > Note Style, the contextual menu, or the note tag.
"Note reference style" is already defined as "no superscript" though what I see in the text is what is defined in the Scrivener export, superscript if that is what the export setting is; default note text is a single space, so change that to a tab; set the paragraph to fully justified.
(i) the gutter is changed to 12pt, the separator line is moved to the middle of the gutter;
(ii) the index remains superscript if that's what it was;
(iii) the ruler does not reflect the ruler in the new style definition ... it is unchanged;
(iv) the paragraph remains justified left, ragged right ... no change.
All of this sounds like your document's note have manual formatting applied that overrides the style definitions. Remember that any piece of text in a document can have both styles and manual attributes applied, where the latter override the former.

An example: if you have some text with the Heading 1 style applied, which enforces a bold font, you can still select a single word in such a heading and turn off bold. What you've done is apply a "not bold" attribute that overrides the bold usually enforced by the paragraph style. If you want to use just the formatting enforced by the style(s) you need to remove the manual attributes using a menu like Format > Remove Attributes Except Styles. You could select all your notes and then activate this menu to have all your notes influenced just by styles.

You can also remove attributes piecemeal. For example, you say that the ruler for your notes was not updated when you adjusted your note styles. That's most likely because your notes have ruler overrides applied. To remove those overrides you can use the menu Format > Paragraph > Remove Paragraph Attributes, or the "Remove Ruler" command from the contextual menu of the ruler tag icon (at the bottom-right of every document window).

I hope that makes some sense. Let me know if you have any questions.

xiamenese
Posts: 422
Joined: 2006-12-08 00:46:44
Location: London or Exeter, UK

Re: Styles palette problems

Post by xiamenese » 2013-07-03 17:13:33

martin wrote:Hi Mark,

… …

All of this sounds like your document's note have manual formatting applied that overrides the style definitions. Remember that any piece of text in a document can have both styles and manual attributes applied, where the latter override the former.

An example: if you have some text with the Heading 1 style applied, which enforces a bold font, you can still select a single word in such a heading and turn off bold. What you've done is apply a "not bold" attribute that overrides the bold usually enforced by the paragraph style. If you want to use just the formatting enforced by the style(s) you need to remove the manual attributes using a menu like Format > Remove Attributes Except Styles. You could select all your notes and then activate this menu to have all your notes influenced just by styles.

You can also remove attributes piecemeal. For example, you say that the ruler for your notes was not updated when you adjusted your note styles. That's most likely because your notes have ruler overrides applied. To remove those overrides you can use the menu Format > Paragraph > Remove Paragraph Attributes, or the "Remove Ruler" command from the contextual menu of the ruler tag icon (at the bottom-right of every document window).

I hope that makes some sense. Let me know if you have any questions.
Martin, thank you. If we did talk about this privately some time ago, it is either so long ago that I've forgotten or somehow your mail must be in orbit in cyberspace.

I have come round to thinking that many years ago, probably while it was still NWP 1.x, I must have created my own footnote style for some reason and that was appearing in the palette ... or else I'm delusional.

As for your explanation of attached foot/endnote styles over-riding default styles in NWP that makes absolute sense. Your example of de-bolding a word in a paragraph style which has bold applied is something that I am aware of; I use it constantly in relation to colours, as when editing translations, I colour my changes red no-matter where they occur in terms of paragraph style. But I simply never thought of my endnote problem in those terms. The other thing is, before this potentially-magnum-opus I generally applied footnotes in NWP, not importing a document from Scrivener with existing endnotes. Of course Scrivener is applying a style, albeit minimal and not what I actually want, but it must be there and that is overriding the NWP default, so I'll experiment with using the Format > Paragraph > Remove Paragraph Attributes which you suggest. I'm pretty sure it will do exactly what I want.

So, thanks as always.

Mark.

Post Reply