BUG? Copying Hyperlink from Nisus Writer Pro to Apple Mail

Everything related to our flagship word processor.
Post Reply
jhecht
Posts: 34
Joined: 2004-12-09 10:41:48
Location: Boston area

BUG? Copying Hyperlink from Nisus Writer Pro to Apple Mail

Post by jhecht » 2013-11-18 07:00:12

I inserted hyperlinks in a few places in an RTF document. Now I am trying to copy those hyperlinks and insert them into Apple Mail, and I can't get it to work.

I read the instructions and found that clicking on the link with CONTROL down did produce a pop-up menu with an option to copy link. But what it copies is the text to which I have linked, not the link itself. When I try to insert the hyperlink into Apple Mail, Mail puts up a dialog and asks me to past the link into it - but what pastes is the text to which I have attached the hyperlink, not the hyperlink itself. I get the same behavior when I paste into Nisus Writer Pro.

When I press CONTROL and use the pop-up menu to EDIT the hyperlink, it presents me with a dialog box that shows the hyperlink, which I can copy, so the CONTROL key on my non-Apple keyboard seems to be correctly assigned.

That makes me suspect there is a bug in the COPY LINK routine.

I am running Nisus Writer Pro 2.0.6 on a MacMini running 10.6.8.

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: BUG? Copying Hyperlink from Nisus Writer Pro to Apple Ma

Post by martin » 2013-11-18 12:39:57

I just tested this on OSX 10.6 (and other OSX versions), and could not reproduce the bug. I believe I took the same steps as you, but to be sure, here's what I did:

1. Right-clicked a hyperlink in NWP, whose destination URL was http://nisus.com
2. Selected the contextual menu command "Copy Link".
3. Switch to Apple Mail.
4. Selected any word in an email composition window.
5. Used the menu Edit > Add Link.
6. With the insertion point in the sheet's edit URL field, activated the Paste menu.
7. The URL field showed http://nisus.com as expected.

Is that all correct? Or perhaps your link's destination URL makes a difference?

jhecht
Posts: 34
Joined: 2004-12-09 10:41:48
Location: Boston area

Re: BUG? Copying Hyperlink from Nisus Writer Pro to Apple Ma

Post by jhecht » 2013-11-18 13:39:49

This is weird. I opened the document, and tried pasting two links other than the one I first tried. They both worked. Then I tried again the one that I had tried before, and it did not work. I took screen shots, but they are too big to upload here (I am hitting a 100-kByte limit), so I clipped them down to just the boxes without a document background. The Nisus Writer Pro document is an article I wrote for a magazine, so it's not proper to post it here, although I can send it privately.

As far as I can tell, I am using the same procedure you described, although I have tried both CONTROL-CLICK and RIGHT-CLICK on the mouse for the COPY LINK stage. When open EDIT LINK I am able to copy the LINK into the MAIL document, but if I use the COPY LINK command, but when I PASTE I only get the selected text.

The links that worked for me were to other web sites and clicking on the link in NW Pro opens the Wikipedia page in the link that I can't copy to Apple Mail.

The only obvious difference I see in the selected text in the link giving problems includes a short quote enclosed on quotes: Deinocheirus for "terrible claw."

Thanks,
Attachments
Screen shot in Edit Link in.jpg
This is the edit link box from NWPro. I can copy from this, but I can't copy with the COPY LINK command.
Screen shot in Edit Link in.jpg (24.97 KiB) Viewed 2430 times
Screen shot of Mail post results-shrunk.png
And this is what I see in Mail when I paste after copying from COPY LINK in NWP. This is the phrase highlighted by the link, not the link itself.
Screen shot of Mail post results-shrunk.png (15.41 KiB) Viewed 2430 times

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: BUG? Copying Hyperlink from Nisus Writer Pro to Apple Ma

Post by martin » 2013-11-18 17:29:10

I just tried with the display text and URL you show in your screenshot, and it all works over here. Could you please send in a feedback report using the menu Help > Send Feedback? Preferably you could send along the document including the link, or a relevant snippet thereof, and with diagnostics enabled. Maybe we'll see something in the logs, or be able to reproduce the issue with your document in hand.

jhecht
Posts: 34
Joined: 2004-12-09 10:41:48
Location: Boston area

Re: BUG? Copying Hyperlink from Nisus Writer Pro to Apple Ma

Post by jhecht » 2013-11-18 18:10:39

I've sent in a copy of the file and an explanation of what I'm seeing. Thanks for you help on this.

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: BUG? Copying Hyperlink from Nisus Writer Pro to Apple Ma

Post by martin » 2013-11-19 10:44:03

Thank you for sending along the file. Our private correspondence revealed that this odd behavior is triggered when non-uniform formatting is applied to the linked text, eg: one word in the linked text was in italics, while the rest was not. We're going to get this fixed, thanks!

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: BUG? Copying Hyperlink from Nisus Writer Pro to Apple Ma

Post by martin » 2013-11-26 23:24:59

This bug should be fixed in the just released Nisus Writer Pro 2.0.7

Post Reply