Page 1 of 1

Problem with Character font size arrows

Posted: 2014-02-21 15:30:00
by tarakananda

We have recently begun having a problem with resizing text using the arrow buttons in the Character window. If text is 14 points, and we wish to resize it to 12 points, by clicking on the decrease arrow twice, the selected text goes down to 10 points, while reading 12 in the dialog box. By reselecting the text again, it shows it as 10 points. We can resize the text by typing the font size in the dialog box rather than using the arrows.

We have tested this on multiple documents, and suspect that it is a corruption passed on when copying and pasting from a particular document. We have found we can get rid of this behavior by command-shift pasting the offending document into a new document, but this strips out all italics and bolding, not a long term solution.

I am uploading two documents which have this problem, so you can check and see what might be wrong. It seems I can only place one per posting, so I will attach the next in a followup.

Your help will be appreciated.

Swami Tarakananda
Problem File.rtf
(31.51 KiB) Downloaded 125 times

Re: Problem with Character font size arrows

Posted: 2014-02-21 15:33:38
by tarakananda
Here is the second file, reduced in size as it was too big to upload.
zA Brief Sanskrit Glossary-reduced.rtf
(58.21 KiB) Downloaded 163 times

Re: Problem with Character font size arrows

Posted: 2014-02-24 16:27:46
by martin
Unfortunately I haven't been able to reproduce the problem in either of your attached documents.

However, your experience and symptoms sound very similar to another recently reported bug, where font sizes cannot decrease below 11pts when using the stepper arrows. You might read my full reply to the problem in that thread. If your problem has the same cause, you can likely workaround the issue by either:

1. Apply your Normal style to your document's body text. -or-
2. Change your Normal style definition (via the Style Sheet view) so it does not enforce that particular font size.

That said, it's curious that I cannot reproduce your problem as I can with the other bug. I'd like to narrow this down, so we can be sure to address your issue too. Can you please send in a feedback report using the menu Help > Send Feedback after you trigger the problem? Thank you!

Re: Problem with Character font size arrows

Posted: 2014-02-25 09:07:18
by tarakananda
Hello Martin,

Thank you for quickly replying to inquiry.

I have taken the document (problem file.rtf), which was actually prepared on another computer by another person, and opened it on my Mac. I tried to reproduce the problem in the first paragraph, but all was fine. I tried on the beginning part of page 4, and then the problem occurred. I first increased the font-size with the arrows from 12 pt. to 14 pt. Fine. But when I tried to take it back down to 12 pts., it went in 2 pt. increments per click of the arrow, from 14 to 12 to 10, while reading 12 pts when the text was 10. When I deselected and reselected the changed text, then it correctly read it as 10 pts.

I will send a report as you asked. I can send the changed document if you wish. Just let me know.

Thanks you for your attention to this problem.