nisus.com
https://www.nisus.com/forum/

Imported Footnotes not showing default note text
https://www.nisus.com/forum/viewtopic.php?f=18&t=5679
Page 1 of 1

Author:  swalkerc [ 2014-03-22 08:38:20 ]
Post subject:  Imported Footnotes not showing default note text

I'm new to Nisus Writer Pro and I'm stuck on a problem. I compiled a document in Scrivener to .rtf and then opened that file in Nisus Writer Pro. I then went through and applied styles from the Nisus Writer Pro style sheet to the text. Everything was great. The only thing I can't get to work is the footnotes that were in the document say they're formatted as the style sheet footnotes, but they don't include the autotext. So, they're all numbered correctly, but they're also all missing the period after the number. Any ideas?

Thanks!

Author:  martin [ 2014-03-24 16:41:39 ]
Post subject:  Re: Imported Footnotes not showing default note text

What you describe is the expected behavior for the "default note text" option of a Footnote style. That default text is only used when you insert a new note in that style. It does not affect any existing notes, nor those you open from another file. Put another way, the delimiter (eg: the period and space after the note number) is actually part of the note content; it is not part of the automatic note number, nor any other kind of automatic text. However, you aren't the first user to be confused by this, so perhaps we should revisit how this works.

In the meantime, you may find the attached macro helpful. If you run it on your document, it should allow you to globally adjust the delimiter for all notes in your document.

Attachments:
Note Delimiter Replace All.nwm [20.26 KiB]
Downloaded 137 times

Author:  phspaelti [ 2014-03-24 17:51:41 ]
Post subject:  Re: Imported Footnotes not showing default note text

Here is my version of such a macro. It works a bit different, in that it just uses the currently set default, and it checks whether the current footnotes need to be changed or not.

[Macro updated]

Attachments:
Fix Note Default text.nwm [18.9 KiB]
Downloaded 36 times

Author:  swalkerc [ 2014-03-25 09:13:54 ]
Post subject:  Re: Imported Footnotes not showing default note text

Thank you both so much! That's a really helpful fix.

Sarah

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/