Reply to topic  [ 8 posts ] 
Long Documents that Self-Destruct 
Author Message

Joined: 2013-05-05 12:52:00
Posts: 12
Any suggestions much appreciated.

I have encountered this problem with several documents of mine, but this is the worst. I have a book, about 225 pages long, with hundreds of items in the bibliography, and thousands of references to those books, and thousands of footnotes containing those references.

Even though the file is only 8 MB, the book has reached the point where it is ineditable. Pick an entry point, click the cursor, and the program goes into an infinite loop. Reliably. Sometimes it's repaginating, sometimes not, sometimes it just hangs.

Going into Draft view (if it lets me get that far) helps a little, but since the program always goes into Page view when I add a footnote, that's no solution -- I need the footnotes.

It had been doing this intermittently for weeks, often resulting in a checksum error, and copies of it and my other books are clogging Nisus Software's queue of files to be examined as a result. So far, I have heard nothing

The ideal fix would be to break the document up into smaller pieces, but then how do I get it to cross-reference to the bibliography? I suppose I could have left out the cross-references had I known in advance about this problem -- but I didn't.

I can't reduce the number of footnotes; this is a scholarly book.

(Suggestion to Nisus Software: How about some code that tells the software when it's in an infinite loop like this -- e.g. if it spends more than two minutes repaginating, it's HUNG -- so that it can STOP, and allow a manual pagination command or something?)


2014-09-03 09:26:06
Profile

Joined: 2007-04-12 14:59:36
Posts: 229
If the main reason for slow-down is the footnotes: How about taking the footnotes out with a macro, indicating their place with a marker. Then edit the text and the footnotes in separate documents until you are ready for printing, and in a final step placing the footnotes back with a second macro. But maybe you would find this too tedious.

Of course the hardware could make a big difference. And finally, depending on your time schedule, you could always hope that Nisus one day will offer a 64 bit version. I think it has been a long time now since we got something new from Nisus of some weight. Of course there have been the integration of graphics which must have been a big effort. Though personally I find integrating graphics from external software like Omnigraffle the better solution, leaving the word processor lighter.


2014-09-03 12:42:15
Profile

Joined: 2013-05-05 12:52:00
Posts: 12
js wrote:

> If the main reason for slow-down is the footnotes: How about taking the footnotes out with a macro, indicating their place with a marker. Then edit the text and the footnotes in separate documents until you are ready for printing, and in a final step placing the footnotes back with a second macro. But maybe you would find this too tedious.

It's an interesting thought, but is there a way to keep the links between the footnote NUMBERS in the main file and the footnotes file? The thing is, I'm not just adding things at the end; I'm adding in the middle.

An easier solution might be a macro to turn the cross-references into regular text; it would at least reduce the cross-reference burden. And would be easier to manage. But I don't find a relevant command in the documentation. That doesn't mean there isn't one, but I don't see it.

Don't misunderstand me; I'm going to fiddle around with the convert notes to text macro and see what I can do. But I'm not sanguine. :-(

My hardware isn't great -- a three year old MacBook. But this isn't lack of hardware; the problem is an infinite loop.

Thanks for the idea, though; it at least gives me something else to fool with.


2014-09-03 12:57:50
Profile
User avatar

Joined: 2007-02-07 00:58:12
Posts: 876
Location: Japan
I don't know if there is a built-in command to fix cross-references, but the following macro should do the trick. Obviously try this only on a back-up copy of your document.


Attachments:
Fix Cross Refs.nwm [4.02 KiB]
Downloaded 90 times

_________________
philip
2014-09-03 23:45:07
Profile
User avatar

Joined: 2007-01-17 03:25:42
Posts: 729
waltzmn wrote:
An easier solution might be a macro to turn the cross-references into regular text; it would at least reduce the cross-reference burden. And would be easier to manage. But I don't find a relevant command in the documentation. That doesn't mean there isn't one, but I don't see it.

The menu command to do that is Tools:Automatic Content:Convert to Fixed Content.
I would still retain a copy with automatic content.


2014-09-03 23:58:56
Profile

Joined: 2013-05-05 12:52:00
Posts: 12
Hamid wrote:

> The menu command to do that is Tools:Automatic Content:Convert to Fixed Content.
> I would still retain a copy with automatic content.

Well, given that it's ineditable with automatic content, that may not be feasible. :-)

Interestingly, the "Convert to Fixed Content" command doesn't seem to have worked -- all the links still seem to be live. (I may have to do more manual-digging to see what these commands actually do.) But that led to the preferences for automatic content. THOSE can be changed in a way that reduces CPU load. I'm going to try that. And I'll look at the macro posted by phspaelti.

Thanks to both of you. This should at least take me closer. :-)


2014-09-04 04:53:19
Profile
User avatar

Joined: 2007-02-07 00:58:12
Posts: 876
Location: Japan
waltzmn wrote:
Interestingly, the "Convert to Fixed Content" command doesn't seem to have worked -- all the links still seem to be live. (I may have to do more manual-digging to see what these commands actually do.) But that led to the preferences for automatic content. THOSE can be changed in a way that reduces CPU load. I'm going to try that. And I'll look at the macro posted by phspaelti.

I wonder if you selected the footnote text when you tried "Convert to Fixed Content"? That command only works on the selection, and if you select the document text, the cross-references in the footnotes are not affected.

My macro will convert all cross-references, without regard to any selection.

_________________
philip


2014-09-04 06:35:24
Profile

Joined: 2013-05-05 12:52:00
Posts: 12
> I wonder if you selected the footnote text when you tried "Convert to Fixed Content"? That command only works on the selection, and if you select the document text, the cross-references in the footnotes are not affected.

So I (eventually) discovered. An interesting behavior. That was indeed the problem.

Now I see if this has simplified the document enough to be helpful. :-)

> My macro will convert all cross-references, without regard to any selection.

So I see. A fascinating lesson in how much one can do with a short piece of macro code. Most of mine have been longer but not nearly as elegant. I'm going to dig into seeing if I can find ways to use the concept for other text-cleaning.

Thank you again.


2014-09-04 10:39:53
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: Bing [Bot] and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software