Strange TOC Behaviour
Page 1 of 1

Author:  Stef [ 2015-07-31 03:13:27 ]
Post subject:  Strange TOC Behaviour


Nisus is doing strange, unwanted things when it inserts a Table of Contents in a document I'm working on, and I just can't figure out what's going wrong.

Nisus does the following: for certain titles in the TOC it jumps to a new line before inserting the dots and the page number, so that the dots and the page number appear on the next line and not on the same line as the title, even when the title is very short. I've included an example below.

I have a document with 5 levels of titles, and Nisus does this for all the titles on levels 1-3. The level 4 & 5 titles in the TOC appear correctly, i.e., with everything on the same line.

The titles in the document have been customised. Here is a rough example of the title layout in the document:

Introduction [Level 1 / Based On No List Style. I.e., Lists - Styles - "Use None"]

Part I: Title of Part I [Level 2 / Based On No List Style]

Chapter I: Title of Chapter I [Level 3 / Based On the "Headings" List Style]

§1 Title of Section 1 [Level 4 / [Level 3 / Based On the "Headings" List Style & Customised]

§1.1 Title of Section 1.1 [Level 5 / [Level 3 / Based On the "Headings" List Style & Customised]

[And so on]

But when Nisus inserts the TOC, I get something like this (of course, the page numbers are flush with the right margin):

…… 1

Part I: Title
…… 3

Chapter I: Title
…… 5

§1 Title …… 5

§1.1 Title …… 7

Surely I should get something like this instead:

Introduction …… 1

Part I: Title …… 3

Chapter I: Title …… 5

§1 Title …… 5

§1.1 Title …… 7

I've been fiddling endlessly with this and have just noticed the following: I'm using the Linux Libertine font in the document, but, when preparing a working example to upload to the forum, I changed the font to a more common one (Times) and, lo and behold, the problem goes away and the TOC compiles normally. Is this a bug to do with the font? I want to avoid Times at all costs, so why is Nisus making problems with the other font used? I had a hunch that the customisation of the Title styles might be at the root of the problem, but I was far form imaging that it would be the font. Surely this shouldn't be happening?

Any help anyone might be able to offer would be greatly appreciated.


File comment: Example TOC Problem (PDF)
Example_TOC_Problem_PCF.pdf [95.67 KiB]
Downloaded 59 times
File comment: Example TOC Problem
Example_TOC_Problem.rtf [33.47 KiB]
Downloaded 58 times

Author:  Hamid [ 2015-07-31 05:47:56 ]
Post subject:  Re: Strange TOC Behaviour

I cannot reproduce the problem.
Both the RTF and the PDF files display correctly.
The font version I tried is LinLibertineOTF_5.3.0_2012_07_02.

Attachments: [94.77 KiB]
Downloaded 53 times

Author:  Stef [ 2015-07-31 13:03:46 ]
Post subject:  Re: Strange TOC Behaviour

Thanks, Hamid, for looking into the issue and for replying quickly.

I'm using the same version of the font as the one you indicated. So I guess it's just bad luck for me that you can't reproduce the problem. As for me, I can't do anything but reproduce it: on my system, the only way to make the problem disappear is to stop using Linux Libertine. I'd rather not do that, however, as all the parameters of the very long document have been set up using Linux Libertine. (And it's also a very nice font).

I'm thus wondering if the version of Nisus I'm using might be an issue. I'm still on version 2.0.7, but I don't want to update to 2.1.1 as I'm working closely with someone who's still on Snow Leopard (10.6), which version 2.1 no longer supports. I'd rather avoid possible problems of incompatibility between Nisus versions and keep things the same on both systems. In the meantime, this issue is causing a headache, especially since you say that you can't reproduce it.

Thanks again.


Author:  Elbrecht [ 2015-08-01 01:16:56 ]
Post subject:  Re: Strange TOC Behaviour

Hi Stef -

don't know anything about Linux Libertine - but did you Validate the Font in Apple's Font Book app?
And may be it's a Font Cache problem - try to clean the Font Cache - OnyX is for free…


Author:  Stef [ 2015-09-01 12:00:00 ]
Post subject:  Re: Strange TOC Behaviour

Thank you, Elbrecht, for taking the time to comment. I followed your advice, checking that the fonts were validated, and I cleaned out the font caches. Unfortunately, it didn't make any difference. This really is an odd problem which seems to occur with the "Linux Libertine O" font. In fact, in order for the TOC to display as intended in the document I'm working on, I've had to find a replacement for Linux Libertine in the TOC. It's a very strange issue, which seems to be font-related, and which I haven't been able to resolve. That's the only update I can give.

Author:  exegete77 [ 2015-09-01 17:25:13 ]
Post subject:  Re: Strange TOC Behaviour

I had used Linux Libertine O and B for most projects. Love the look of the font.. But in another program I discovered that there are problems with the fonts in certain situations. In that case I had to switch to a font that supported what I needed. In my case I switched to Minion Pro and have had no problems.

Not sure if this helps, but when I saw the font I thought I'd share my experience.

Author:  Stef [ 2015-09-01 22:58:34 ]
Post subject:  Re: Strange TOC Behaviour

Thanks, exegete77. Your comments reassure me somewhat. Hamid couldn't reproduce the problem, and so I was wondering if it was just my machine/setup. It thus seems that there can be issues with the Linux Libertine fonts in certain situations, which is really unfortunate, because, as you say, the fonts look great, and, for the most part, they function really well. For my part, I chose a font named Crimson to get the job done where Linux Libertine was acting strangely. As for the underlying problem, I just can't figure out what it might be.

Author:  Elbrecht [ 2015-09-02 01:56:10 ]
Post subject:  Re: Strange TOC Behaviour

Again –

in the net it looks like "Linux Libertine O" has known problems with Mac OS X since long – so don't wonder! BTW the "O" stands for OTF – Open Type Font – this font format is not 100% covered by Apple's text engine, you might try a TTF version if available…


Author:  Stef [ 2015-09-02 06:59:45 ]
Post subject:  Re: Strange TOC Behaviour

Thanks again, Elbrecht, your comments are helpful. I followed your advice and installed the TrueType version of Linux Libertine, and it solves the problem in the TOC. In other words, when using Linux Libertine (TrueType), there are no anomalies in the formatting of the TOC, as described above, and the TOC displays correctly.

However, the same formatting problems occurring in the TOC when using Linux Libertine (OpenType) also occur in the Index, and, unfortunately, changing to the TrueType version of the font does not resolve the formatting problem in the Index. It only resolves them in the TOC. Now that is strange!


Author:  Elbrecht [ 2015-09-02 07:06:49 ]
Post subject:  Re: Strange TOC Behaviour

Stef. –

"Rebuild Index" ?


Author:  Stef [ 2015-09-02 07:26:46 ]
Post subject:  Re: Strange TOC Behaviour

Yes, I tried that, thanks. I also tried deleting the Index and re-inserting it. But, unfortunately, neither of these things worked.
It's so strange that the solution you suggested works for the TOC but not for the Index.

Author:  Elbrecht [ 2015-09-02 08:34:01 ]
Post subject:  Re: Strange TOC Behaviour

Stef –

I can't check your "TOC" – and sorry no "NW 2.0.7" running anymore.


Author:  exegete77 [ 2015-09-02 10:49:00 ]
Post subject:  Re: Strange TOC Behaviour

One other thought. Linux Libertine comes in several variants. I had used the .otf fonts, which caused the problems. I downloaded the .ttf fonts, because i wanted to check in another program. The .ttf fonts seem to work better. I have tried in Mellel and iCalamus, and both seem to work better with this.

Author:  Stef [ 2015-09-02 11:32:32 ]
Post subject:  Re: Strange TOC Behaviour

Thanks, exegete77, you're right. Elbrechet pointed this out, too, and the TrueType version of the font does work better. Using the .ttf fonts actually solves the formatting problem in the TOC. However, even with the .ttf version the very same formatting problem remains in the Index. Go figure…

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group