Too frequent autosave

Everything related to our flagship word processor.
Post Reply
MichaelGli
Posts: 18
Joined: 2015-08-28 22:00:43

Too frequent autosave

Post by MichaelGli » 2015-10-06 20:32:51

I've got a largish document that kicks in auto-save way too frequently (just now, three times in 2 minutes, once with a single keystroke between). As it takes 10 seconds to save, it's a real bite out of my work time, waiting for save. Nisus preferences says auto-save is controlled by Mac but I can't find a control. I'm making much larger docs in InDesign and Photoshop with no similar problem.
Any ideas?

Actually I've noted that switching between open programs forces an auto save: I've been working back and forth between Nisus and a website, every time I switch I get a 10 second wait to save.

El Capitan on a 1988 MacPro 8-core Xeon, Nisus Writer Pro 2.1.1

dshan
Posts: 333
Joined: 2003-11-21 19:25:28
Location: Sydney, Australia

Re: Too frequent autosave

Post by dshan » 2015-10-07 06:12:49

See http://nisus.com/forum/viewtopic.php?f=22&t=6064 for info on autosave and NWP. As far as I know there is nothing you can tweak in OS X to alter the autosave frequency.

Þorvarður
Posts: 251
Joined: 2012-12-19 05:02:52

Re: Too frequent autosave

Post by Þorvarður » 2015-10-07 07:30:12

I have not had this problem, but I would first try toggling the auto-save feature here:

System Preferences > General > "Ask to keep changes when closing documents"

If that doesn't help, then you might want to consider disabling the auto-save feature in Nisus altogether.
Here is a tip with comments about how to disable auto-save per app in Mac OS X.

I haven't done this myself, so I can't say how good it works.
http://osxdaily.com/2012/07/11/disable- ... -mac-os-x/

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Too frequent autosave

Post by martin » 2015-10-07 12:38:12

It's true that Nisus Writer Pro (NWP) versions 2.1 and 2.1.1 leave autosaving frequency up to the Mac system (OSX), and a lot of users find the behavior too aggressive. The good news is that we're on the cusp of releasing a free update (version 2.1.2) that restores a preference that controls how often autosave is triggered.

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Too frequent autosave

Post by martin » 2015-10-08 13:02:14

We just released NWP version 2.1.2 which restores the ability to control how often OSX's autosave is triggered.

MichaelGli
Posts: 18
Joined: 2015-08-28 22:00:43

Re: Too frequent autosave

Post by MichaelGli » 2015-10-08 18:09:13

New version 2.1.2 fixes this: excellent!

MichaelGli
Posts: 18
Joined: 2015-08-28 22:00:43

Re: Too frequent autosave

Post by MichaelGli » 2016-01-30 00:06:34

NWP 2.1.3 has brought back my too-frequent auto-save problems that 2.1.2 fixed. I've got NWP auto save set to 20 minutes but it actually kicks in under 5 minutes and sometimes even at one minute. I'm working on a manual with screen dumps, its over 70MB and even on a newish MacBook Pro (quad core i7) with SSD it takes nearly 10 seconds, very interruptive.
What can I do?

User avatar
martin
Official Nisus Person
Posts: 4289
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Too frequent autosave

Post by martin » 2016-02-05 16:06:54

I'm sorry you're still having trouble with this Michael. I haven't seen any other reports of this problem in version 2.1.3. Can you please verify that you're using the most recent version? You can check the version number using the menu About Nisus Writer Pro, just look under the word "Pro" in the about box's logo.

If the version number is correct, can you please send us a feedback report using the menu Help > Send Feedback? It would be best if you sent the report just after you experience an autosave that occurred too soon.

Post Reply