No more autosave

Everything related to our flagship word processor.
Post Reply
lellius
Posts: 40
Joined: 2002-08-15 22:06:44

No more autosave

Post by lellius » 2015-10-14 10:43:40

Hallo Martin
when I discovered that Nisus 2.1.2 allows to disable autosave, I said “Finally” and so i decided to install it.
But it doens’t work. You can put any number in the box, from 1 to 999: the app saves automatically after about two minutes. And that it a thing I can’t tolerate.
Where may be the problem? Can anybody suggest a solution?
Thanks
gb

User avatar
martin
Official Nisus Person
Posts: 4361
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: No more autosave

Post by martin » 2015-10-14 14:33:13

Based on your (hidden) email address's domain of ".it" I thought perhaps this was an issue affecting the Italian localization, where any adjustments to the setting in the preferences pane (GUI) weren't being properly respected (by the code). However, after some testing I've been able to reproduce the problem in the normal English localization.

It seems that after some time threshold has elapsed (in my testing this was around 5 minutes), the autosave requests sent to Nisus Writer Pro by the system can become more urgent. When I take certain actions (eg: activating an edited document window) the system's autosave request is no longer marked as cancellable, and Nisus Writer obeys without consulting our recently added autosave timing preference.

I'm sorry that the new version gave you false hope, but thank you for letting us know about this problem. We'll investigate and test some potential solutions.

ngazidja
Posts: 124
Joined: 2005-01-23 17:12:16

Re: No more autosave

Post by ngazidja » 2015-10-23 02:54:11

I haven't upgraded yet, but perhaps someone (indeed, even Martin) can answer - my issue is not with autosave as such, but the fact that there is no initial prompt - which means that apart from anything else all my documents are called "Untitled (n)", where "n" was edging up into 3 figures before I deleted them all.

I would like to see an initial prompt (as in the past) rather than having to go through a "save as", rename the file, choose my folder and then delete "Untitled (47)" from my Documents folder to stop my hard drive filling up with redundant files. After that, I'm happy to have autosave.

Can this be done in 2.1.2?

Iain.

User avatar
martin
Official Nisus Person
Posts: 4361
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: No more autosave

Post by martin » 2015-10-23 11:13:02

Hello Iain,
ngazidja wrote:my issue is not with autosave as such, but the fact that there is no initial prompt - which means that apart from anything else all my documents are called "Untitled (n)", where "n" was edging up into 3 figures before I deleted them all.

I would like to see an initial prompt (as in the past) rather than having to go through a "save as", rename the file, choose my folder and then delete "Untitled (47)"
In general this is how it should work:

1. Create a new NWP document.
2. Start working in the document and some time passes.
3. Autosave kicks in, saving your document with an automatic file name (Untitled 123).
4. When you close the document, you will be prompted whether or not you want to keep the document. In that prompt you can choose a proper file name for the document, as well as its final location:
save.png
save.png (47.8 KiB) Viewed 1538 times
One preference that may be a factor: do you have "keep all new documents without asking me" enabled? If so, then you will not be prompted to keep, discard, or name your new documents when they are closed.

If you are seeing different behavior, please let us know what versions of NWP and OSX you are using. They are both a factor.

ngazidja
Posts: 124
Joined: 2005-01-23 17:12:16

Re: No more autosave

Post by ngazidja » 2015-10-24 04:08:58

Thanks Martin, this sounds good. All I want is the prompt... :) I'll give it a go.

Post Reply