Page 1 of 1

NWP 2.1.3 Crashes on Launch - With Solution

Posted: 2016-02-27 23:43:51
by dshan
Yesterday I found NWP suddenly started crashing on launch on my iMac (but not my MacBook Pro where it continued to work fine). After trying all the usual things - restarting iMac, deleting NWP plist files, reinstalling NWP, etc. I had a look at the stack trace it was producing (and sending to Apple). It seemed to be doing some network access at startup and crashing with an unhandled exception error for some reason. I also have NWE on the iMac and that was crashing with exactly the same error on launch too!

Then I discovered I couldn't login to the Mac App Store app, it came back with an error saying it'd encountered an "unexpected error" and couldn't verify my device or computer, please contact support. I suspected a connection between these two problems except that my NWP was not purchased from the Mac App Store, it was from the Nisus web store. Then I realised that even non-App Store apps have to verify their developer cert with Apple at launch, and if something is screwed up with connecting to the App Store then that check may not work either... Next I found this thread on the Apple support forums, where several others were having the same issue with logging into the Mac App Store and running some apps purchased from the store:

Deleting interfaces.plist file as described in this thread fixed both my App Store login issue and my crashing NWP issue.

But that's not the end of it - I also found this thread in reddit describing a borked "silent" software update that Apple issued yesterday and then fixed in another update the same day that affected the Mac Ethernet driver. Sure enough my iMac had applied the bad update and then the fixed update, but I suspect this two-step dance left the interfaces.plist file in an inconsistent state and that in turn caused the problems with Nisus and the App Store app: ... s_ethernet

Hope this helps anyone else who encounters this problem. Now all I have to do is remember why I wanted to use Nisus in the first place yesterday...

Re: NWP 2.1.3 Crashes on Launch - With Solution

Posted: 2016-02-28 02:01:44
by Ellen
First, let me say that dshan is great in posting something that he already has the solution to. I had exactly the same problem and fixed it in similar ways. I can add that Apple has now posted a fix here:

If the Ethernet connection on your Mac stopped working recently

However, I am not quite satisfied with the fact that Nisus wouldn't work even though I haven't purchased it from the App Store. When possible, I choose to buy directly from the developers instead of from the App Store so as not to be completely dependent on Apple. Also, although my App Store connection didn't work and my ethernet port had disappeared so I had to switch to wi-fi, other programs not purchased from the App Store worked. But not Nisus…

And when I have no connection at all (like sometimes on my MacBook), Nisus works fine.

So I would be happy to understand why Nisus crashed repeatedly on my Mac, with wi-fi and no connection to the App Store.


Re: NWP 2.1.3 Crashes on Launch - With Solution

Posted: 2016-02-29 13:51:08
by martin
Thank you very much dshan for posting that information! As you've both already mentioned, the issue was caused by an update from Apple that incorrectly disabled ethernet for some Macs.
Ellen wrote:I would be happy to understand why Nisus crashed repeatedly on my Mac, with wi-fi and no connection to the App Store.
This part of the problem is our fault, and is a bug. The lack of ethernet should not affect Nisus Writer.

The crash in Nisus Writer occurred at startup when it was attempting to find and validate a Mac App Store (MAS) receipt. Nisus Writer does this regardless of whether you are using the version purchased from the MAS or directly from Nisus. In the case of the directly purchased version, we do this to allow MAS customers to switch from the MAS version to the direct version.

That process of checking for an App Store receipt requires the computer's MAC (media access control) address, which is tied to the ethernet port. After Apple's update disabled ethernet, Nisus Writer could not obtain the desired MAC address. Unfortunately that triggered the crash, which is a bug. It shouldn't affect Nisus Writer one way or another. We plan to fix this in the next update to Nisus Writer.

If anyone can't resolve this using Apple's fix, please write to us privately at:
We already have a private beta version of Nisus Writer that fixes this issue.

Sorry for the trouble!

Re: NWP 2.1.3 Crashes on Launch - With Solution

Posted: 2016-03-03 13:58:43
by martin
We just released Nisus Writer Pro 2.1.4 which fixes this problem.