nisus.com
https://www.nisus.com/forum/

Soft hyphenation now uses en-dash?
https://www.nisus.com/forum/viewtopic.php?f=18&t=6531
Page 1 of 1

Author:  withoutFeathers [ 2016-11-24 17:57:45 ]
Post subject:  Soft hyphenation now uses en-dash?

Hi,
I just upgraded the Mac Os to 10.11 from 10.6.8, and Nisus itself to 2.1.5.

The main problem:
Soft hyphens now insert an incorrect longer dash, I believe an en-dash, instead of a true hyphen. This is annoying. Why would Apple suddenly decide to throw out 500 years of typography? :roll:

Plus, hyphenation doesn't seem to happen when I expect it to; as if it's turned off somewhere.

So, generally, I need help with hyphenation, which seems to have changed in the 5 or 6 years of the OS that I just skipped through. I know that in 10.6.8 the Mac OS had control of this (mostly), but in 10.11 I can no longer figure out where the Mac OS controls are. Or if there are any. Googling didn't help.

WF

Author:  ninjagame [ 2016-11-24 23:13:36 ]
Post subject:  Re: Soft hyphenation now uses en-dash?

withoutFeathers -

there has indeed been a change in the handling of the hyphen and it occurred around NWP 2.1.4 (I think). It somehow doesn't sit too well with Apple's hyphenation engine. (I hope I remember that right.)
One solution to the problem would be to set the "Hyphenation" ("View" menu) option to "Manual". Then you can enter Hyphens at will.
There are two "Hyphen" macros in the macro repository as well, a "soft hyphen" and a "non-breaking hyphen". They both work very well (for me, that is):

https://nisus.com/pro/macros/browse.php?keywords=Hyphen

Hope that helps

- ninjagame

Author:  withoutFeathers [ 2016-11-25 20:18:36 ]
Post subject:  Re: Soft hyphenation now uses en-dash?

ninjagame wrote:
withoutFeathers -
Hope that helps
- ninjagame

Hi ninjagame,
Thank you for your attention to this matter. :)
None of your suggestions fixed it... :D ...but working through them jogged my memory and caused me to understand what's going on.

In short, for anyone else who has this problem, it seems that:
A) It's caused by the fact that my font (New Century Schoolbook) doesn't have a soft hyphen in its character set, and so Apple throws in a default from some other font. (NCS becomes red in the sidepanel, indicating that it's not there, when I select the introduced soft-hyphen).
B) If I change the soft-hyphen font to something else (most other fonts), it's a nice-size regular small hyphen, indicating that those fonts do have a soft-hyphen character.

I believe I may have fixed this in the past by choosing Automatic Normal hyphenation, so that most of the hyphens are set by Apple, (which then uses a real hyphen in NCS), and then creating a character style with another font, and applying it after-the-fact, for the odd one that I want to force as a soft-hyphen.

I guess the elegant solution would be to have a place where I could change Apple's default of which font it replaces with, but I doubt if I have access to that anywhere.

WF

Oops! Spoke too soon. I discover now that I do have access to that: Preferences->Languages->Secondary Font. If I put a font in there that has a soft-hyphen, all is well, it gets used. Problem solved! :)

Author:  ninjagame [ 2016-11-27 02:59:18 ]
Post subject:  Re: Soft hyphenation now uses en-dash?

withoutFeathers -

Glad you could solve your problem!

- ninjagame

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/