Reply to topic  [ 9 posts ] 
PageBreaking samePageSectionBreaks 
Author Message
User avatar

Joined: 2007-07-18 01:33:44
Posts: 19
Just wondering if anybody has had the same experience:
Some of the same page section breaks I insert into my document break page anyway, while most don't. And I can't figure out why.
Is this behavior somehow expected and predictable, if you know where to look? Or is this a quirk?
Any input is much appreciated.

P.S. I'll attach the file.
P.P.S. Possibly not related: looking at the file in Finder with Quick Look reveals formatting irregularities, not visible in NWP.


Attachments:
00035888.rtf [97.93 KiB]
Downloaded 27 times

_________________
Sebastian
2017-05-24 09:09:38
Profile
User avatar

Joined: 2007-01-17 03:25:42
Posts: 729
That happens, (example on page 16), because of footnote number 10.
When there is a footnnote in a section, the following section begins on the next page. Unfortunately this is a shortcoming of NWP.
To test this, delete note number 10 and you will find the next section will begin on the same page as the section before it.


2017-05-24 09:35:55
Profile
User avatar

Joined: 2007-07-18 01:33:44
Posts: 19
Wow, thanks, Hamid!
That seems in fact to be the cause.
And an unfortunate shortcoming it is indeed!

_________________
Sebastian


2017-05-24 09:42:40
Profile
User avatar

Joined: 2007-01-17 03:25:42
Posts: 729
See if this workaround helps.
I have changed that particular footnote to endnote (placed at the end of section instead of end of document).
The starting number of the next footnote in the following secion will need to be adjusted.


Last edited by Hamid on 2017-05-24 23:02:17, edited 1 time in total.



2017-05-24 12:05:19
Profile
User avatar

Joined: 2007-07-18 01:33:44
Posts: 19
Thanks, Hamid, I just substituted the page breaks with the page breaking section breaks on the affected pages.
That's good enough for me (and visually more true to the original text replicated in the document).
Thank you for all your help.

_________________
Sebastian


2017-05-24 13:37:25
Profile

Joined: 2012-12-19 05:02:52
Posts: 225
Hello Sebastian, Hamid et al.,

I like Iowan Old Style, the font used in the document. It's a system font, and by me it resides in /Library/Fonts.
I have just realized now that this font doesn't show up in Nisus' Font menu, neither in Format > Font > All Fonts nor in Format > Font > Show Fonts. The same applies to the Character Palette.

If this font is already in a document, then my Character Palette looks like this:
Attachment:
1.png
1.png [ 35.5 KiB | Viewed 946 times ]

But when I create a new document with Lucida Grande as my default document font, then no traces of Iowan Old Style can be found in the Character Palette at all. In other words, the only way to use this font in new documents is to *paste* it from other documents that already have this font.

Other fonts in /Library/Fonts are not affected.

TextEdit, MS Word and Mellel display the font as expected.

Has anyone else noticed this? :?


2017-05-27 06:47:58
Profile
User avatar

Joined: 2007-03-31 14:59:22
Posts: 333
Location: Frankfurt, Germany
Hi –

never used the font – but all seems fine on Mavericks. But Sierra does not recognize this Bitstream 2005 TTC font – no appearance even in Font Book! Try importing into Font Book to get this TrueTypeContainer font recognized – maybe this helps somehow. To Font Book on Mavericks the contained fonts seem just fine. Or better save the TTC as OTF font – maybe…

HE

PS: Open & Save as OTF in Fontographer did the trick – but all kerning & other finer things stripped off. The font seems not to be compatible to Sierra's font/text engine anymore. Needs some fixing by Bitstream – download there or ask for fixing it.

_________________
MacBook Pro i5
SSD 840/850 Pro
macOS Sierra 10.12.6
Nisus Writer Pro 2.1.8


2017-05-27 07:30:57
Profile
User avatar

Joined: 2007-01-17 03:25:42
Posts: 729
Þorvarður wrote:
I like Iowan Old Style, the font used in the document. It's a system font, and by me it resides in /Library/Fonts.
I have just realized now that this font doesn't show up in Nisus' Font menu, neither in Format > Font > All Fonts nor in Format > Font > Show Fonts. The same applies to the Character Palette.

You are right, this is the case on Sierra, where I can only see it in PopChar http://www.ergonis.com/products/popcharx/
If this font is already in a document, then my NWP Character Palette looks normal, without the missing font highlight.
In NWP it appeared under Recent fonts after I opened the sample document; I could then apply it to some other text in another NWP document from Recent fonts.


2017-05-27 08:52:02
Profile

Joined: 2012-12-19 05:02:52
Posts: 225
Hamid wrote:
You are right, this is the case on Sierra

Hamid and Elbrecht, thanks for your confirmation. Good to know that my system/NWP is not damaged.
I can see the font in PopChar too, and in NWP it appears indeed under Recent fonts, as Hamid pointed out; so, on the whole, I think the inconvenience for me (on Sierra) is minimal.


2017-05-27 21:22:43
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software