Reply to topic  [ 6 posts ] 
Character Styles and Attribute Problems (Linux Libertine) 
Author Message

Joined: 2014-12-28 05:47:24
Posts: 31
Hello, All,

I’m writing with a question about character styles and formatting that I just haven’t been able to figure out.

The example document attached (RTF & PDF) is a truncated version of a much, much longer typescript, where the problem is shown. In this document, the footnote reference marks—or at least all of the footnote reference marks in the main paragraph style—have stopped playing ball. That is, they won’t appear in superscript in the the main paragraphs. Instead, they appear in regular, normal-size script.

The font definition indicates that they are in superscript; the character palette on the right-hand side indicates that they are in superscript; but, in fact, they appear in normal-size script.

I’ve fiddled with things to try to resolve the problem, but with no luck. No matter what I do, they won’t appear in superscript. It appears, perhaps, that the paragraph style is overriding the character style somehow. (I have of course read the important page by Martin, "Why aren't changes to a style showing in my document text? []", but nothing mentioned there works).

Any ideas anyone might have on how to resolve the problem would be much appreciated.


P.S. The font I’m using is Linux Libertine (the TTF version). If I change the font to something like Times, the problem goes away, but I have hundreds of pages written like this, all of which have been carefully proofread, and I’d prefer to keep the Linux Libertine font.

Downloaded 20 times
Downloaded 18 times
2017-12-04 09:52:42
User avatar

Joined: 2007-01-17 03:25:42
Posts: 729
You have to remove "Typography Options" from the footnote reference character style.
That will remove the old-style figure option which is now applied to that style.
Under Number Case select No change while that style is selected in the Style Sheet:
Number Case options.jpg
Number Case options.jpg [ 71.62 KiB | Viewed 612 times ]

Attachments: [5.4 KiB]
Downloaded 16 times
2017-12-04 10:19:09

Joined: 2014-12-28 05:47:24
Posts: 31
Thanks, Hamid, for your quick reply.

In my file, within the Character Style dialogue box, I’ve pulled up the “Typography Options” dialogue you’ve mentioned, and the option “No change” for Number Case is in fact already selected.

But when I click the “No change” option again, a “Baseline: +4pt” option gets added to the character style, as follows:

Typography_Options.pdf [63.12 KiB]
Downloaded 24 times

Consequently, in the text the footnote references 2 & 3 fly away up into the air.

In the document you kindly posted (which has added a baseline skip of +3pt to the character style), I don’t know if you can see it but there is a notable difference between the size of the footnote references “1”, “2”, and “3”. Number “1” looks right (but it hasn’t been affected by any of this), but both “2” and “3” appear to be too big. There is something going on here that I can’t understand.


2017-12-04 16:16:51
User avatar

Joined: 2007-01-17 03:25:42
Posts: 729
Does this appear any better?

Attachments: [5.41 KiB]
Downloaded 24 times
2017-12-05 02:16:04

Joined: 2014-12-28 05:47:24
Posts: 31
Thanks again, Hamid. You appear to have cracked it.

The problem—once again—appears to be the Linux Libertine font. Here's what I've understood this time: by changing the version of the font used— that is, by changing from the True Type version to the Open Type version of the font—the problem is resolved.

In the initial, problematic file, the styles were defined with the True Type version of the font. But in your recent file, you defined them with the Open Type font. I thus uninstalled the True Type version, and went back to the Open Type version, and the footnote reference marks now appear as they should: at the proper size and in superscript.

This seems odd, because although the Sourcefourge page for the Linux Libertine font indicates that the OTF version is the default for MAC, the font's README file indicates this: "Most often TTF is the better supported format […]". In this situation, that is not the case. However, I think I must have changed back to the TTF version some time ago, after encountering other problems with the OTF version (see, for example, this post:

Linux Libertine is a great font, but, at the moment, whether you use the TTF version or the OTF version, it doesn't seem to be 100% reliable.

2017-12-05 08:05:24

Joined: 2015-10-18 14:25:32
Posts: 10
There is a font called Libertinus Serif, which is a fork of Linux Libertine. It addressed a few issues. Not sure if it would address the issues you had.

2018-01-19 17:43:13
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: Bing [Bot] and 6 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software