Reply to topic  [ 5 posts ] 
autotext 
Author Message

Joined: 2017-12-21 04:36:37
Posts: 23
Hi, I understand that what is called "auto text" in MS Word (automatic entries which allow to save energy and time by completing the first few letters of an expression or a long word like 'phenomenologically') appears under the name of "glossary" in NW pro. I tried it and entered an auto text (I use several of them) along the lines indicated in the Manual, but it does not work. Might it be that the question is rather how to insert a glossary entry into the text of a Nisus file? Well I guess everybody has a lot to do these days, so I am willing to wait until next year.


2017-12-29 06:04:26
Profile

Joined: 2012-12-19 05:02:52
Posts: 226
Quote:
what is called "auto text" in MS Word […] appears under the name of "glossary" in NW pro.

"Auto text" in Word is an inferior feature, so let's better stick to the official Nisus term "Glossary".
Quote:
Might it be that the question is rather how to insert a glossary entry into the text of a Nisus file?

The steps required are:
    1. There must be a glossary file available that you created (Nisus Preferences > QuickFix; and in the lower part of the pane the glossary that you want to use must be ticked.)
    2. In the open glossary file you must enter (in this order):
      a) an abbreviation
      b) a tabulator
      b) a glossary entry
      c) Glossary Entry Break

Make sure you don't accidentally enter a Page or Section Break instead of a Glossary Entry Break.

PS
The glossary entry doesn't necessarily have to be text. You can also enter images and fully formatted tables! You can't do that in Word.


2017-12-29 13:09:14
Profile

Joined: 2017-12-21 04:36:37
Posts: 23
This works, many thanks for the help! I do not know why it was not the case precedently. This said, every time I get back to the Quick Fix, Nisus returns to the English sensitive fix, though I set it to French (my first and main language).


2017-12-30 06:03:33
Profile

Joined: 2007-03-28 07:30:34
Posts: 139
[quote]This said, every time I get back to the Quick Fix, Nisus returns to the English sensitive fix, though I set it to French[/quote]

If by this you mean that you create a Glossary entry as previously described such as, say,

fr<tab>French<glossary break>

where 'French' is some word in French, and in your French-formatted document you type 'fr' but the converted output sends you back to English, then what you probably need to do is

1. open the Glossary file and select the Glossary entry in the Glossary file
2. set it to Format:Remove Attributes and Styles
3. save

This tells Nisus to expand the Glossary entry into whatever styles (font, language, styling...) you have defined for the surrounding text.

Alternatively, suppose you are writing in French and want to use a Glossary entry to insert a word in Japanese. You could create a Glossary entry such as

jp<tab>日本<GB>

select the "日本" and in the menus define it as Japanese language with the desired Japanese font. It will then expand into your French document as 日本 with the Japanese language attributes. In this instance, however, you probably want to add a space formatted to French after the 日本 in the Glossary, or else you will continue to type in Japanese (or whatever language you have defined).

If this is a problem with all of your glossary entries, you can open the Glossary file, select all, and apply Format:Remove Attributes and Styles. Then all entries will expand into whatever formatting you have applied to the text where the glossary expands.

I have hundreds of glossary entries that convert text English <-> Japanese, and the glossaries work like a charm.

In short, if you Remove Attributes and Styles from the glossary entry, the glossary expands into the attributes and styles of the surrounding text.

If you define, in the glossary, the attributes and styles you want the expansion to use, the expanded text runs with those attributes.

HTH

Cliff


2017-12-30 13:58:28
Profile

Joined: 2012-12-19 05:02:52
Posts: 226
Yohanan wrote:
every time I get back to the Quick Fix, Nisus returns to the English sensitive fix, though I set it to French (my first and main language

Yohanan,

I'm glad that the glossary feature is now working for you. So it seems it's just the QuickFix feature (auto text in Word) that is giving you some headache.

To the right of "Language Sensitive QuickFix For:" at the top of the pane, you'll see a pull-down menu. Open this pull-down menu and select French. If you see a list of French typos and corrections, you are already ready to go.

Go back to your document and start writing. Make sure the text has the language attribute "French" (from Format menu > Language > French; OR use the small flag at the right bottom of your document.)
Every French QuickFix-typo you now make should be automatically corrected.

NB
If your text doesn't have the language attribute 'French' and you write "vosu", then nothing will happen, of course. BUT if the text has the correct language attribute, "vosu" will be automatically turned into "vous".


2017-12-30 15:48:41
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software