10.3.9 and Nisus Classic

Nisus Thesaurus, Nisus Writer Classic– this is the place for all other Nisus products.
Post Reply
User avatar
useeger
Posts: 73
Joined: 2004-06-28 00:03:01
Location: Germany

10.3.9 and Nisus Classic

Post by useeger » 2005-04-22 02:41:27

Hello,

since I updated my System to 10.3.9 Nisus refuses to start. It hangs when reading Preferences. When I kick out the hanging application Classic crashes too.

If I delete the Nisus Preferences in the Preference folder it starts again, but only 1 time. Next time it will crash again at startup.

So I have always to delete Preferences before starting Nisus. A little bit complicated. Does anybody know a better workaround?

Ulrich

User avatar
GeoffRoynon
Posts: 44
Joined: 2004-04-26 10:20:33
Location: London, UK

Post by GeoffRoynon » 2005-04-24 01:38:22

There is a recent topic on the MacFixit site that mentions problems with running Classic under 10.3.9.
Apparently this can be resolved by turning off the Apple Menu Options extension in Classic.
Check the MacFixit site for more info: http://www.macfixit.com/

Geoff
Geoff Roynon
Mac Pro 2.66MHz, MacOS X 10.8.1
NW Pro 2.0.4

User avatar
useeger
Posts: 73
Joined: 2004-06-28 00:03:01
Location: Germany

Post by useeger » 2005-04-24 22:53:27

Hello Geoff

[quote="GeoffRoynon"]
Apparently this can be resolved by turning off the Apple Menu Options extension in Classic.

Thanks for the hint. Tried it. It works only for 2-3 starts of Nisus for me, then the same problem occurs. Tried also to minimize the system extensions in Classic, but also without success. I think I have to wait for a Bugfix from Apple.

Nisus Classic users: Don't update your system to 10.3.9 !!

Ulrich

User avatar
GeoffRoynon
Posts: 44
Joined: 2004-04-26 10:20:33
Location: London, UK

Post by GeoffRoynon » 2005-04-25 12:21:31

Ulrich

I started having the same problem as yourself with Nisus getting part-way through its initialisation and then simply vanishing with no error messages.
I looked in the MacOS9 System Folder and found a Clipboard file which was 12K in size - this file should be zero size apparently (someone reported this on the Nisus list some time ago as causing problems). I stopped Classic, removed the Clipboard file, and restarted Classic and Nisus is running fine now. Don't know if it was the Clipboard or stopping and starting Classic.
You could check your System Folder and see if you have a Clipboard file and remove it - see if it helps.

Regards
Geoff
Geoff Roynon
Mac Pro 2.66MHz, MacOS X 10.8.1
NW Pro 2.0.4

User avatar
useeger
Posts: 73
Joined: 2004-06-28 00:03:01
Location: Germany

Post by useeger » 2005-04-26 00:59:08

Hello Geoff,

after a lot of trials the problem vanished for me too. But I can't say what the solution was. I switched of a lot of control panels and system extensions, so that it is still enough for Nisus and ATM. Made also what you mentioned from macfixit and <http://discussions.info.apple.com/webx? ... 9.68ac60e2>. Finally used the command "Repair MacOS 9 permissions" from the harddisc utility. And now Nisus starts again.

Thanks for your help!
Ulrich

dkaplan137
Posts: 10
Joined: 2004-12-14 07:14:39

Workaround for Classic in 10.3.9

Post by dkaplan137 » 2005-04-26 10:59:34

I had problems running Nisus Writer 6.5 under Classic in OS 10.3.9 until I disabled Apple Menu Options _and_ rebuilt the Classic desktop. Since then it's running fine.

Post Reply