Express 2.5 Beta Feedback Thread

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
phpbb
Site Admin
Posts: 5
Joined: 2002-07-11 16:41:22

Express 2.5 Beta Feedback Thread

Post by phpbb » 2005-07-20 19:31:16

If you would like to provide feedback, or comment on the beta release of Express 2.5, feel free to post it in here.

We ask that you do not post about these builds in other threads, since we want to make sure that people who are looking for support on the release version (2.1.3) do not get lost in a sea of comments about these beta builds.

Thanks in advance for your cooperation.

Cosimo
Posts: 5
Joined: 2005-05-12 02:51:47

Vertical Scroll Bar 2.5b1

Post by Cosimo » 2005-07-20 23:40:51

First of all, thanks for getting these builds out again to those of us not yet running 10.4. There have been great improvements in NWX.

Second, I was about to post a couple of anomalies I noticed on 2.5a7 when I saw and downloaded 2.5b1. One of these is still there in Beta1, and that is the vertical scroll bar does not always display properly in Page Width view (width of the bar varies as the it moves up and down). I have a screenshot if you'd like me to send it.

Apologies if this has been covered somewhere before. When I couldn't use the Alphas on 10.3.8 I didn't follow the thread regularly.

Keep up the good work.

Cosimo

midwinter
Posts: 333
Joined: 2004-09-09 18:07:11
Location: Utah
Contact:

Post by midwinter » 2005-07-22 08:31:09

I've finally managed to get a real project going in NWE (instead of importing old projects from Word), and I'm curious: why are footnotes not contained in the footer? If I remember correctly, most other word processors stick them there.

Edit: footnotes are maintained when opening the same file in Word (and considering Word's had a bug with widows and orphans since 1997, I say this: um, woo?), but are entirely lost in Pages.

jwx1
Posts: 35
Joined: 2003-05-12 08:48:44

Errors

Post by jwx1 » 2005-07-23 17:58:54

Below are a few of the sys log entries associated with opening a new file and typing a new text. Looks like something is having a problem:

Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextClipToRect: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextConcatCTM: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextSetPatternPhase: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextGetCTM: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextClipToRect: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextConcatCTM: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextSetPatternPhase: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextClipToRect: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextConcatCTM: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextClipToRect: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextResetClip: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextSetFlatness: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextBeginPath: invalid context
Jul 23 15:00:31 JWMac /Volumes/Master 2/Nisus Beta/Nisus Writer Express beta1.app/Contents/MacOS/Nisus Writer Express: CGContextMoveToPoint: invalid context

It goes on.For hundreds of lines.
There was no drawing, image or coloring going on at the user level, just plain vanilla text entry.

Thanks for all your efforts.
John

shades
Posts: 118
Joined: 2002-11-12 18:51:49

SOFT RETURN still not working

Post by shades » 2005-07-24 16:47:19

I have commented on this on several of the Alphas. It still does not work in NWE 2.5 Beta.

To get a soft return, press SHIFT + RETURN. However, this has never worked on any version of NWE, and still is unusable in 2.5 Beta.

I'm using OS X 10.3.9.
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

once in a while

Post by gemboy27 » 2005-07-24 18:26:51

alpha 7
os 10.3.9

I am having an occasional problem. Mainly it happens if I have had NWE open for a long time, as in a day. What happens is it will crash, but the odd thing is -- though I can't get to it, either by clicking on it or tabbing to it, I can see that it is open. In other words it hasn't crashed closed, it has just crashed in-accessible.

Beyond that (and I am sorry that is it) I don't have any other tidbits that happen to explain it.

gem*boy
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

midwinter
Posts: 333
Joined: 2004-09-09 18:07:11
Location: Utah
Contact:

Re: once in a while

Post by midwinter » 2005-07-24 19:44:00

gemboy27 wrote:alpha 7
os 10.3.9

I am having an occasional problem. Mainly it happens if I have had NWE open for a long time, as in a day. What happens is it will crash, but the odd thing is -- though I can't get to it, either by clicking on it or tabbing to it, I can see that it is open. In other words it hasn't crashed closed, it has just crashed in-accessible.

Beyond that (and I am sorry that is it) I don't have any other tidbits that happen to explain it.

gem*boy
I noticed this same behavior while I was working in NWE for long hours a couple of weeks ago. It would take *minutes* for it to close.

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

unless

Post by gemboy27 » 2005-07-24 20:25:49

unless I force quit, it would stay open
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

midwinter
Posts: 333
Joined: 2004-09-09 18:07:11
Location: Utah
Contact:

Re: unless

Post by midwinter » 2005-07-24 20:28:03

gemboy27 wrote:unless I force quit, it would stay open
Was a7 the last alpha? If not, can you upgrade? The beta is working nicely.

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

a7

Post by gemboy27 » 2005-07-24 20:32:37

Alpha 7,


don't know abouy b1, just downloaded that today
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

charles
Posts: 481
Joined: 2002-11-26 11:40:35
Location: San Diego, CA
Contact:

Post by charles » 2005-07-25 15:24:58

Hi:

We fixed a memory leak that was causing a long delay when trying to quit Nisus Writer Express after it has been open for a long period of time in the beta. Also, when you have an application like Nisus Writer Express open but you don't use it for a long time, Mac OS X might save most of its memory to the disk to make more room for other applications you are using in RAM. When this happens, it can take a long time to switch back to Express making it appear to be hung.

If the problem you were experiencing goes away with Beta 1, then it was probably the memory leak bug that you were experiencing. Otherwise, it is probably this paging issue, which is a "feature" of Mac OS X and will happen with any application if you don't use it for a while.

I hope that helps.

-Charles
Charles Jolley
Nisus Software, Inc.

JBL
Posts: 167
Joined: 2003-04-25 14:33:59

Post by JBL » 2005-07-26 13:02:28

When I try to find spaces, if I use "space" in the "special characters" submenu, it finds both spaces and paragraphs. One can work around this by just typing a space using the spacebar. Maybe "space" is supposed to me "white space" but then why is there a separate menu item for "space or tab"? Anyway, it is a minor issue but one that is liable to confuse people the first time they encounter it.

martin
Official Nisus Person
Posts: 4605
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: SOFT RETURN still not working

Post by martin » 2005-07-26 13:14:32

shades wrote:To get a soft return, press SHIFT + RETURN. However, this has never worked on any version of NWE, and still is unusable in 2.5 Beta.

I'm using OS X 10.3.9.
Unfortunately the text layout system on 10.3 does not support soft returns. You can insert them, and they should display properly for users on 10.4, but you they will lay out as if they were hard returns for you.

Parelius
Posts: 9
Joined: 2004-11-25 09:33:10

Re: Express 2.5 Beta Feedback Thread

Post by Parelius » 2005-07-27 01:32:26

Problem with font Family menu in Tooldrawer.

When opening NWE (or some times, just opening a new document in NWE), the pulldown menu of the font Family is just blank. If I click the cursor in the Typeface menu, and then tries the Family menu, it works fine.

OSX 10.3.9

shades
Posts: 118
Joined: 2002-11-12 18:51:49

Re: SOFT RETURN still not working

Post by shades » 2005-07-27 07:05:19

martin wrote:
shades wrote:To get a soft return, press SHIFT + RETURN. However, this has never worked on any version of NWE, and still is unusable in 2.5 Beta.

I'm using OS X 10.3.9.
Unfortunately the text layout system on 10.3 does not support soft returns. You can insert them, and they should display properly for users on 10.4, but you they will lay out as if they were hard returns for you.
That's interesting - because Mellel, Word, Pages, RagTime ALL support soft returns on OS X 10..3.9.

Do you mean that NWE does not support soft returns in 10.3.9?

Regardless, such a limitation makes NWE useless for me, and this is frustrating, because I like the NWE "feel".
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08

Post Reply