mis-placed softwrap

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
dushanm
Posts: 9
Joined: 2013-06-25 09:05:19

mis-placed softwrap

Post by dushanm »

I’m running NWE 4.2 under macOS 13.6, and would like to fix two issues that I sometimes run into. I’ll split them into two posts.

The first one is long-standing over several previous versions of NWE, namely: Soft-wrapping occasionally misbehaves by sending the next word to a new line long before it needs to. Here’s an image showing the behavior:
softwrap1.png
softwrap1.png (11.34 KiB) Viewed 818 times
But if _any_ character other than a space, not just the comma shown below, is placed after that next word, the misbehavior disappears:
softwrap2.png
softwrap2.png (10.64 KiB) Viewed 818 times
How do I prevent this weird behavior?

User avatar
martin
Official Nisus Person
Posts: 4899
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: mis-placed softwrap

Post by martin »

This is an (intended) quirk of the line wrapping rules, as decided by Apple and the Unicode consortium. You can read more about the behavior in this forum thread.

The quick solution is that you can prevent the undesirable wrapping by inserting a "zero-width non-joiner" character. You should see that character listed in Nisus Writer's special characters, under the "Spaces" category.

I hope that helps!

dushanm
Posts: 9
Joined: 2013-06-25 09:05:19

Re: mis-placed softwrap

Post by dushanm »

Thanks for the explanation, bizarre as it is, and for the solution. Yes, I did notice the "zero-width non-joiner" and will use it next time.

Post Reply