gap at page-bottom

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
dushanm
Posts: 9
Joined: 2013-06-25 09:05:19

gap at page-bottom

Post by dushanm »

NWE 4.2 running under macOS 13.6. This is the second of the two issues that I sometimes run into. I did not have this problem with previous versions of NWE.

For a multi-page file, an undesirable gap is sometimes left at the bottom of the page, even though there is room for one or more extra lines of text. Apparently, if NWE is unable to fit an entire paragraph in the remaining space, it treats it like an image and puts it on the next page. The first snapshot below is an example.
gap1.png
gap1.png (66.77 KiB) Viewed 1085 times
If a tiny bit more space is made available on an earlier line by decreasing the ‘Space After’ from 5 to 4, the whole two line paragraph is accommodated:
gap2.png
gap2.png (56.43 KiB) Viewed 1085 times
If the two-line paragraph is split by a hard return at the end of the first line, it is fitted into the original gap.
gap3.png
gap3.png (66.05 KiB) Viewed 1085 times
I would like to have this behavior with soft-wraps as well, filling the page with as many lines as will fit. How can I do that?

User avatar
martin
Official Nisus Person
Posts: 4899
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: gap at page-bottom

Post by martin »

What you're seeing here is an often desirable feature called widow and orphan control. Nisus Writer automatically works to prevent single lines of text from appearing by themselves at the start/end of a page.

If you don't like the feature you should disable the option. You will see it listed on the menu under Format > Paragraph > Prevent Windows & Orphans, or in the Paragraph palette under "Grouping".

This feature is applied per paragraph; a single document can include paragraphs that both prevent and allow these lines. However, if you don't like the feature, you probably want to disable the option for your entire document by editing your style sheet. Usually that means you will want to adjust your document's Normal paragraph style so it allows widows and orphans. Taking that a step further, you may want to disable the option for all new documents you create by editing your new file template.

dushanm
Posts: 9
Joined: 2013-06-25 09:05:19

Re: gap at page-bottom

Post by dushanm »

Ah, great, thank you. I would not have stumbled on this on my own.

Post Reply