Page 1 of 1

Ownership of new files

Posted: 2005-10-12 15:12:39
by mypointofview
When creating a new document in NisusWriter Express, the group setting for the document is set to wheel.

On my Mac, I have never seen that behaviour. I can verify it easily because I view my drive through Pathfinder in list view with colums Owner/Group/Permission.

I find this strange, as I'd like to have as a "group" setting some other group - not wheel.


Thank you and kind regards, M.

NisusExpress 2.5 on MacOSX 10.39

Posted: 2005-10-12 19:50:33
by Ryan
That's really interesting. It's the same for me. I looked at the groups for other apps, and they're all over the place. Some have the group being the same as my user, and some even have "unknown". None of those programs have settings for this.

Just to poke around a bit, I tried setting my Custom New to have a different group, thinking that would perhaps start things out right. Nope.

Of course, after all this, I realized that it still doesn't matter at all to me, since I almost never use the UNIX groups anyway. It's a very interesting question, though.

Posted: 2005-10-13 09:43:23
by mypointofview
1. The group setting should be automatically the same as the parent folder. Try it out with any other newly created file in a folder of your choice.

2. The group setting can be of significance -- why do we have it to begin with :wink: -- say if you are another user and want to have access to those files.

To be very honest, I don't know what "wheel" means. I've set up my user account with group set to "admin" so only other admins can have access to my files.

I think it's a bug in Nisus since no other program behaves like this - overriding the parent folder's group setting.


Posted: 2007-07-10 10:28:32
by Regu
I’d like to resurrect this topic to see if a more definite conclusion/resolution can be reached.

NWE and now, NWP write my new files to disk with the Unix file owner as "me" and the Unix file group owner as "wheel." To correct the condition, I must change the group owner to "me" using some other method (generally a script in Voodoo Pro, or via Xfile). This is doable, but an annoying use of time. I'd prefer the group owner to be set -- as is my understanding of Unix -- to the group owner of the parent directory and in this way, maintain consistency in the file security.

I've searched the Nisus forums and faqs for the topic with a singular result: ... ight=wheel

My ownership settings and the mode of the folders I believe to be in question are (I have used the Desktop folder for illustration and simplicity):
/Users/me/Desktop = me/me 0750
/Users/me = me/me 0750
/Users = root/admin 1775

My ownership settings and the mode of folder where the application (NWP) is stored:
/Users/Applications = me/me 0700
/Users/Applications/Nisus Writer = me/me 0755

The only other application I am aware of that writes new files with the group owner of "wheel" is PDFpen from Smile On My Mac.

I wonder if a little enlightenment from others with more expertise in these matters might be forthcoming?

Thank you.

Posted: 2007-07-10 12:25:17
by martin
This is some kind of bug and we'll look into it. I'm not sure why we're afflicted with the bug, since we use the standard Apple document framework (which includes provisions for saving documents). But we must be doing something to disrupt the normal behavior.

Posted: 2007-07-10 12:41:04
by Regu
Thank you for the prompt reply. I've struggled with this one for a while and am unable to resolve it. I am looking forward to the 'fix.'

Thanks again.