Page 1 of 1

Empty drawer - no palettes

Posted: 2006-06-13 05:35:12
by Tribulatio
I am a registered user. I have had Nisus installed for two years on two Macs: my iMac G4 and my iBook 12'' G4. Both are up to date, regularly maintained. My user language is French on both Macs.

This week, I have upgraded to Nisus Writer Express 2.7 on both Macs. No problem on my iMac, it works as usual.

Not so on my iBook: everything is fine - except for the drawer! It is empty: no palettes at all. There are just the icons on the top of the drawer (Writing, Format, Table...). If I click on one of them, I get a message asking me if I want to create new palettes. No way of making the palettes appear in their respective categories.

The only way to see individual palettes is to go through the menu: Window, Palettes, etc. Then I can make a floating palette appear (not in the drawer, which remains empty).

I have attempted to reinstall NWE on my iBook, but it has changed nothing. Of course, it makes NWE of little use. I had first thought about a bug in NWE 2.7 - but it is probably not, since it works fine on my iMac and the problem is only on my iBook.

Any advice about how to solve the problem? For instance, is it possible to delete preferences list somewhere in order to make it work correctly again? I have sent a message to support 48 hours ago, but no reply. So any solution would be much appreciated! Thank you!

Posted: 2006-06-13 09:13:20
by altracan
I've got exactly the same problem... iBook 12", French as main language...
Erasing the preferences do nothing. I switched back to the 2.6.1 version!

Posted: 2006-06-13 11:05:49
by Tribulatio
Glad to hear I am not the only one! So it might be a bug affecting some iBooks. Let's see first if users with other languages report a similar problem, or if it is only in French.

Posted: 2006-06-13 12:54:16
by martin
We're not sure what could be causing all the palettes to be missing, but perhaps some questions may reveal the source of the problem:

1. altracan tried deleting the preferences file. Did you make sure to quit Express, delete the preferences, and then relaunch Express?
2. Are you using any software that manages localizations across applications for you?
3. Can you manually add palettes to the Tooldrawer using the Palette Library? eg: drag the palette from the Library into the Tooldrawer. If so, do these palettes persist after you've restarted Express?

Posted: 2006-06-13 13:24:59
by Tribulatio
Thank you for your concern!

No, I don't know about altracan, but I do myself not use any software that manages localizations across applications. I didn't even know there was such software! And I have many more different softwares installed on my iMac than on my iBook (on which I have only the most important ones for me), and NWE works perfectly on my iMac, but not on my iBook, so I do not think the problem comes from such a source.

I have indeed attempted to drag palettes from the Library into the Tooldrawer, but this unfortunately does not work, I drag them and they disappear instantly. It is as if the Tooldrawer just refuses to accept palettes.

After reading your message, I have made an attempt to delete preferences, and then restart NWE. I was hopeful, since it asked me questions as if it was a fresh restart - unfortunately the problem persists.

I really don't understand, I cannot understand what could cause that only on iBooks, and moreover only on iBooks using French as a language.

Oh yes, a detail which I have just noticed, although I do not think it is related: in Library / Application Support / Nisus Writer, I have noticed that I have two folders: one called Languages (with English, French-Swiss and French .nlang files) and one called Langues (only with French-Swiss). But all those files are older than the 2.7 install (either 2004 or 2005), so they are probably not related to the problem. However, I wanted to mention that detail, just in case...

Curious to know if you can find some solution! I thank you in advance for your efforts and suggestions! Did you get any similar report of people working on iBook G4 in other languages?

Posted: 2006-06-15 07:44:29
by altracan
To Martin>
First, I deleted all the Nisus related files (including the ones in /home/library !), to be sure to have a fresh installation and that no corrupted files could cause the issue).
When I saw the issue was here again, I tried to re-install a backup of the 2.6.1 version, then updated to 2.7 (to keep the preferences). Again, the tooldrawer is lost.

In fact the palettes work if floating around or in new palette groups, but we can't use the standard ones nor modify them!

My iBook is from fall 2005, i've got 1GB of Memory and a French version of many Programs (MS Office for example). Because the system is by default multi-language I don't understand the issue (I tried to switch the system to US english - nothing happened to Nisus)

Posted: 2006-06-15 08:41:36
by Tribulatio
Same for me: I tried also to switch to English as a user language, but this did not solve the problem.

I would be curious to know if users of other languages have experienced similar problems, or if it is only users in French. This might help to identify the problem. Moreover, since it works fine on my iMac, obviously it is not just a question of language. On the other hand, it is Mac OS X on both iMac and iBook: it is difficult for me to imagine what would be so different on an iBook, so as to cause such a problem?...

Posted: 2006-06-15 12:38:16
by martin
I'm afraid to say that our investigation so far has not yielded a solution to this problem. Some more questions if I may:

1. Both of you say that you tried the English language and there was no change. Can you clarify for me that you ran Express using the English localization (eg: our interface was in English)?

2. When you click one of the pre-defined palette group icons (eg: the pencil), a pop-up menu appears correct? Once the pop-up menu is dismissed, does the palette group icon remain highlighted blue?

3. Are you using any menu haxies (eg: Fruit Menu, Magic Menu, Menu Master, etc)? If so, could you try disabling them, restarting Express, and seeing if the problem persists.

I'll say that we've only had reports of this problem from French users, and then only from you two.

Posted: 2006-06-15 13:13:33
by Tribulatio
OK, I think I have progressed in identifying the problem. After reading your post, I realized that I had changed the language only in the preferences for Nisus, but not in System Preferences. So I went to System Preferences, I put English as the first language, French second... and suddenly everything was fine, palettes were back in the Tool Drawer!

I then closed Nisus, went to System Preferences again and put English as my second language instead of the first (i.e. between French Swiss and French). I launched Nisus again... and palettes had again disappeared.

So it is obvious now that the problem is related to language rank in System Preferences on SOME Macs (not on all of them, since my iMac puts French Swiss first and has no problem with the palettes).

I hope this will help you to find a way out.

Regarding what happens wen I click on one of the icons in the Tool Drawer: a menu appears (for creating new palettes), but the icon remains grayed (not blue). After I close the menu, the icon comes back to normal (neither blue nor greyed).

No, I do not use and have never used menu haxies.

Very strange - but definitely related to ranking of languages in system preferences. I have made another attempt: to put German first in list, no problem. But when I put Italian at the top, then I have the same problem as with Swiss and French Swiss. So it seems that some languages produce the problem, but other languages (eg English, German) don't. I don't know what the logic behind all that is, but it might provide a clue?

Posted: 2006-06-16 08:14:01
by altracan
Today I found a sort of workaround :
I used the version 2.6.1 last night, and tried to update to 2.7 today. The Tooldrawer seems to work for now!

To be sure I totally deleted nisus and the associated files (even the /library/.nisus folder)
When trying to use the 2.7 version, the tooldrawer failed to work.
But if I tried to use the 2.6.1, then delete only the /library/.nisus folder, then use the 2.7 version it worked.

I think that in the French localisation, there is a problem with licensing in some situation! We must keep the 2.6.1 preferences but not the licensing infos...

I don't use any Haxie, nor have changed the localisation of the system today!

Posted: 2006-06-16 08:33:21
by altracan
I forgot one thing wich happens to be necessary : when using the ver. 2.6.1 and before installing the ver.2.7, I had to close some palette! I just re-tried my workaround to be sure.

Posted: 2006-06-19 13:52:04
by martin
Thank you very much for the extra information, I think we've hit upon a solution:

0. Quit Express if it is running.
1. Download the file at ...
2. Unzip the archive, which should yield the file com.nisus.NisusWriter.plist.
3. Copy or move this file into your user's preferences folder at ~/Library/Preferences/
4. Launch Express. Your palettes should now be operational.

I'll see about updating 2.7 itself to fix this issue permanently. Cheers!

Posted: 2006-08-01 00:35:50
by bluespot
hurrah, it works like a charm now !

thank you very much :D

Posted: 2006-10-30 14:12:03
by Tribulatio
Just an update, since I had no longer followed the thread: you are right, it works very well with the plist which you have kindly made available!

Thank you for having provided a solution, this is really good support, and I will begin to use NWE again!