BUG: Normal Find misses most occurrences

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
Bob Stern
Posts: 154
Joined: 2006-03-12 12:32:47

BUG: Normal Find misses most occurrences

Post by Bob Stern » 2006-09-20 10:23:49

I discovered that Normal Find works correctly if I use the Find All or Replace All buttons, but misses most occurrences of the search string if I use Next or command-G.

PowerFind does not have this problem.

This has happened in several documents. The current document is 6300 words or 40,000 characters.

I also reported this bug directly to Nisus using "Send Feedback", but I wanted to warn the user community because you could really mess up a document if you're not aware of this.

ssampler
Posts: 85
Joined: 2006-06-29 07:56:30
Location: Hudson River Valley, NY

Post by ssampler » 2006-09-20 12:40:13

Thanks, Bob.

I also found that Normal "Find Next" does not work--sometimes misses occurrences of the word and occasionally alternates back and forth between two occurrences.

This happens whether or not "Whole Word" " and "Ignore Case" are checked.


OS X 10.4.7 PB G4

Steve

martin
Official Nisus Person
Posts: 4567
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin » 2006-09-20 13:13:13

I received the feedback report you sent in Bob. Is there any chance either of you could send me the file in which the problem occurs? It would also be very helpful to know what exactly you are searching for. Thanks for your help Bob & Steve.

Bob Stern
Posts: 154
Joined: 2006-03-12 12:32:47

sample document

Post by Bob Stern » 2006-09-20 13:55:43

I would have attached the document to the feedback report, but it is confidential. Tonight I'll look for a non-confidential example.

I'll assume submitting another feedback report is the best way to forward the example document unless you instruct me otherwise.

Bob Stern
Posts: 154
Joined: 2006-03-12 12:32:47

Post by Bob Stern » 2006-09-20 13:59:10

Martin, in response to the last part of your question, my last two searches in which the bug appeared were searches for "13" and "Hz". The scope was Entire File, and both Whole Word and Case Sensitive were turned off.

Bob Stern
Posts: 154
Joined: 2006-03-12 12:32:47

Post by Bob Stern » 2006-09-21 15:49:56

PLIST file was the culprit!

I discovered the problem occurred on only one of my two computers. I copied the Nisus plist file from the good computer to the bad one, and the problem disappeared.

Martin, do you want me to send you my good and bad plist files so you can figure out what went wrong, or should we forget it unless the problem recurs?

It is worrisome that one other member of this forum has the same problem.

ssampler
Posts: 85
Joined: 2006-06-29 07:56:30
Location: Hudson River Valley, NY

Post by ssampler » 2006-09-22 07:26:21

Deleting the plist worked for me, too. Thanks, Bob!

Steve

Post Reply