Reply to topic  [ 5 posts ] 
Speed Issues 
Author Message

Joined: 2006-11-10 06:34:48
Posts: 4
Hi,

I'm using Nisus Writer Express on a 2.0 Ghz Core Duo Macbook with 1 GB of memory and am experience significant speed issues as detailed below:

1. It used to take forever for NWE to launch. I read on this board that the launch time was likely getting delayed due to my large font library.

I tried to get around this by launching NWE only once and then keeping it open.

2. I notice now that if I want to open a document by simply double-clicking on it in the finder or in m e-mail, it takes a very very long time to open.

3. If I reboot the computer and open a document by double-clicking on it (while NWE is not even launched) it opens fairly fast.

4. After NWE is launched (after a fresh reboot) double-clicking a document to open it opens it almost instantaneously.

5. Now if I keep NWE open for a few days, the speed gets super slow.

I hope these observations help in fixing the issue.

Best,
NB


2007-01-23 18:26:32
Profile
User avatar

Joined: 2006-06-16 16:17:50
Posts: 124
Location: Brighton & Hove, UK
Hi

It does sound like a problem to me because Nisus Writer Express launches very fast for me. FYI I use an Intel iMac, but I couldn't tell you if it is a "Core Duo" or what-have-you as I am very bad with hardware.

I have found that turning off "Font menu shows previews" in the "Appearance" part of the preferences very much sped up launch of NWE.

However I don't know if it is going to help in your situation because it would appear that something is wrong imho.

_________________
Patrick


2007-01-23 19:26:40
Profile WWW

Joined: 2006-12-08 00:46:44
Posts: 417
Location: London or Exeter, UK
Post 
Yes, it does sound as if you've got problems. I'm using a 1st generation MBP, 2.16 Ghz with 1 Gig of RAM, so slightly faster than your MacBook. NWE normally loads very quickly, with the font display seeming to take up much of the time. I also have no problem whatsoever with it slowing down when left running for long periods, not that I've left it running as long as you seem to have.

I think you should try the old staple of deleting the prefs and letting NWE rebuild them. Do you have other apps running long term which are leaking memory--I don't remember reading about any problem with NWE doing this ... OmniWeb 5.5.x does with Java, that's well known--as that can cause your MacBook to have to start swapping out to disk much more, which slows things down. Also I've never done it, but try running Activity Monitor to see if there's anything hogging your processor cycles.

Good luck.
Mark


2007-01-25 03:36:24
Profile

Joined: 2005-03-21 14:35:43
Posts: 21
Location: Ontario, Canada
Hi, all.

I've just solved a problem I was having with NWE taking forever (like, say, approx. 5 minutes) to load, lingering mostly while "loading fonts" and also being slow to open documents I'd double-click or whatever. I came into the forum now to volunteer my solution, and see that others are having similar problems. I hope this helps at least some folks.

My fix came about as a result of doing some normal, but WAY overdue, maintenance on my PowerBook G4 (667 MHz / 512MB / 10.3.9). A friend had been after me for over a year to do this, but I only tried it for the first time ever last week, and voila! Everything got a hell of a lot faster — NWE's loading time got cut to about 1/10th of what it had been (now more like 30 seconds); it also opens docs quicker, and all my other software seems to be working so much faster and better, too. (A breathtaking improvement in Safari, for example.)

The fix: After running Disk First Aid to verify and repair disk and permissions, got Cache Out and ran it to purge all caches (Internet, User, and most System ones except for "delete virtual memory swap files" and "rebuild launch services database" as those are heavier duty and can take a long time). Then got Cocktail and ran all its tasks (under its Pilot grouping). That's all it took! I gained back over 1G of HD space just from purging a year's worth of junk that had obviously been clogging up operations. Am now happily reminded of just how fast a 667 MHz processor's is supposed to be able to handle stuff! Although everything seemed to be working great by now, to thoroughly finish doing maintenance I ran Disk First Aid again and then Disk Warrior. I'm taking my friend's advice seriously after this, and shall run Cache Out every morning and Cocktail every few weeks to keep things lean and clean.

Cache Out X: NoName Scriptware/Jim Mitchell Designs
Cocktail: Maintain

I'd love to know if this works for anybody else.

Good luck, all!


2007-01-28 06:37:58
Profile

Joined: 2004-02-12 00:11:45
Posts: 96
Location: UK
Post 
FWIW I do similar routine maintenance every couple of months or so. I use Onyx to repair permissions, clear caches and rebuild the launch services dBase as well as doing the routine Unix stuff.

I then startup from a separate disk and use the tools in Techtool to check my disk over. In total it takes around an hour, but I simply start it up and go and have a coffee.

My G4 has been running for some 4 years on this routine without any troubles.

Onyx is free and you can find it here:
http://www.titanium.free.fr/pgs/english.html

HTH

_________________
History is a nightmare from which I am trying to escape.


2007-01-28 10:47:49
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software