Reply to topic  [ 14 posts ] 
Inconsistent "Curly Quotes" 
Author Message

Joined: 2002-11-12 18:51:49
Posts: 118
I was working on a paper this afternoon and noticed an inconsistency when typing double quotes (US style). In the Preference pane, I have set to automatically use curly quotes. However, when I was writing several sentences and used this ", sometimes the quote would automatically produce the correct and other times it would produce the backward quote . But there seemed no logic or reason for the application of the Preferences.

Pargraph style "List" (my own defined style)
NWE 2.7
OS X 10.4.8

Anyone else have this problem?

_________________
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08


2007-02-03 16:08:42
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Post 
The rules that govern which way the quote will curl are somewhat complicated and depend on the surrounding text and quotes. If you ever notice an incorrect curl then save a copy of the document in its current state and send it to us. Please include a description of where in the document the problem occurs.


2007-02-03 16:46:28
Profile WWW

Joined: 2002-11-12 18:51:49
Posts: 118
Post 
Okay, I started a new document and typed two lines. The first line, the leading curly quote was correct, on the second line, the leading curly quote was backward.

(PS I sent under my real name).

_________________
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08


2007-02-03 17:30:01
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Post 
I haven't looked at what you sent in, but from your description I take it that this was a multi-paragraph quotation? Eg:
Quote:
"First line of quote.
"Second Line."

If so, that's a known bug with Express and will be fixed with our next release.


2007-02-03 18:10:32
Profile WWW

Joined: 2002-11-12 18:51:49
Posts: 118
Post 
No. Each paragraph has a sentence, and in each sentence is a quote of a few words.

Here is the entire text in the rtf file (not including the double lines):
===================

This will be the first test when we start.”
1. But we never knew what happened.”


===================

The first line, the leading curly quote is correct.

The second line (different paragraph), the leading curly quote is incorrect.

_________________
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08


2007-02-03 20:23:27
Profile
User avatar

Joined: 2006-06-16 16:17:50
Posts: 124
Location: Brighton & Hove, UK
Post 
As a test I typed out the text as displayed on the web-page in NWE and it seems to be okay with me.

It is a bit of a mystery, I'm wondering if the 1. at the beginning of the second para has anything to do with it. I tried it with the number applied from the "list" style rather than just typing it but it didn't make any difference, it still works fine for me.

The only other thing which occured to me is that maybe there is some gremlin character before the first double quote in the second line rather than a space. How it would have got there I don't know.

_________________
Patrick


2007-02-04 04:35:29
Profile WWW

Joined: 2002-11-12 18:51:49
Posts: 118
Post 
I wondered about that. There is a tab after the 1., but there are other words before the quote. And it seems inconsistent.

_________________
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08


2007-02-04 10:14:18
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Post 
Thanks for sending in the document shades, I've taken a look but can't find any reason the quotes would curly incorrectly.

Can I assume that you typed the text and quotes directly as they now appear? eg: you typed the characters in the exact sequence that they logically appear on the page? In other words, you didn't add the quote marks in after the text had already been typed.


2007-02-05 15:37:44
Profile WWW

Joined: 2002-11-12 18:51:49
Posts: 118
Post 
martin wrote:
Thanks for sending in the document shades, I've taken a look but can't find any reason the quotes would curly incorrectly.

Can I assume that you typed the text and quotes directly as they now appear? eg: you typed the characters in the exact sequence that they logically appear on the page? In other words, you didn't add the quote marks in after the text had already been typed.


That is correct. I set the paragragh style, and then just typed as I normally do.

_________________
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08


2007-02-05 17:11:23
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Post 
One final question: were these two paragraph the only content in your document? Eg: was the document completely empty when you typed it?


2007-02-07 00:16:52
Profile WWW

Joined: 2002-11-12 18:51:49
Posts: 118
Post 
For the sample I sent you, yes. It was a brand new document, and those were the only things typed in.

When I first noticed it, I had begun on a 10 page study guide, and it appeared several times.

_________________
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08


2007-02-07 04:36:50
Profile

Joined: 2005-09-22 09:08:09
Posts: 53
Location: bugmenot.com
Post 
Just to add on: Another (probably unrelated) curly-quote problem is that Nisus uses the open-quote form before numerals, where nine times out of ten one is not beginning a quotation but abbreviating a year, writing something like '99 instead of 1999 (this requires the close-quote form).


2007-02-07 11:54:47
Profile WWW

Joined: 2006-09-13 17:42:08
Posts: 11
Location: Japan
I had this problem once and asked here--as I recall the answer that solved my "problem" came from two people here.

I was importing (English) text from documents that had come from machines used here in Japan, and I was getting curly quotes in one part of a file and straight in another part. It turned out that the language setting was different in different parts of each file.

Select all, and then click on the flag icon in the lower right corner of the window and choose English-(U.S.) from the pop up window.

YMMV, but it solved my problem.


2007-02-10 17:25:43
Profile

Joined: 2002-11-12 18:51:49
Posts: 118
Post 
Thanks for that.

However, in my case, it is happening with a new document that I created. And it seems to be inconsistent (not every quote is wrongly curled).

_________________
MBP 2.4 GHz, OS X 10.5.6
NWP 1.2, Mellel 2.6, iWork 08


2007-02-10 20:31:41
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 14 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software