nisus.com
https://www.nisus.com/forum/

Latin language support?
https://www.nisus.com/forum/viewtopic.php?f=8&t=261
Page 1 of 1

Author:  Stoic [ 2003-07-26 06:02:51 ]
Post subject:  Latin language support?

I've been a Framemaker user for many years, but Frame may be dying. And I loathe MS Word, so I'm interested in Nisus Writer Express. But, in addition to more general academic writing, I'm studying Latin, which requires the use of macrons. For this purpose, I use a font called Garamond Latin, which is understood by both Frame and MS Word. But in the demo version of Nisus, I don't seem to be able to create macrons by the same means that work in those other two applications.

Any suggestions?

Bob Jones

Author:  mongmong [ 2003-07-27 06:13:35 ]
Post subject: 

I don't think it is possible as of this moment to use "smart quotes" either in NWE through any combination of keys. However, you can copy and paste smart quotes that you typed in some other program, like Word.

Perhaps the same thing could be done with the special "macron toting" vowels.

Just copy them into one of the Nisus clipboards and then you might also configure the clipboards to paste with a special key-combo.

(personally I have started to load a lot of repetitive text into CopyPaste, a very good shareware clipboard program http://scriptsoftware.com/copypaste/index.html )

I think that all the special characters that you can use in Nisus are on p 17 (actually p 23 in the PDF) of the NWE manual.

Author:  drjdg [ 2003-07-27 20:27:02 ]
Post subject:  Fonts and Smart Quotes

While I haven't found a way to turn "smart quotes" on and off (since I really don't like them all that much), one easy way to use them is to simply use option-[ ( “ ) and option-shift-[ ( ” ). This works for most fonts I've tried.

As far as the disappearing macrons are concerned, I'm a bit puzzled. I designed a font for Germanic linguistics with macrons and various other odd Germanic characters and it works just fine. Ditto my Gothic font (i.e. the old Germanic language) and several other custom fonts. These, however, were all saved as TrueType fonts many years ago. They have migrated to OS X without a hitch. Perhaps you're using an old PostScript font that OS X doesn't like?

I've had no font problems with NWE Beta 1,2,3 or the 1.0 initial release - all of my “special” characters are right where they should be.

Author:  Stoic [ 2003-07-29 04:45:51 ]
Post subject:  still a problem

Simple cutting and pasting doesn't seem to work. The macrons convert to umlauts.

Garamond Latin is a truetype font, so that's not the problem either.

If someone knows of an alternative Latin font I might try, I'd be willing to give it a go. This one doesn't seem to want to print bolded characters, although that's a minor problem.

I'm just experimenting now. I can't even consider Nisus until they provide better paragraph formatting, numbered lists, bulleted lists, footnotes, etc.

Author:  rasmus [ 2003-09-16 09:46:44 ]
Post subject:  Re: still a problem

Garamond Latin is a "hacked" font, with macrons where umlauts should be. I don't know why it doesn't work, but it would be a bad idea to continue to use it even if it did work ...

You need a Unicode font that contains macrons at their own code points. Not a few fonts that come with Jaguar have them (including Times, Palatino, and so on--Didot may be the closest to Garamond). Use the Character Palette to find them--turn it on in System Preferences > International > Input Menu.

Look under "Accented Latin" in the "Roman" view, and check "Show only fonts containing selected character" (click on the triangle at the bottom of the window).

The OpenType version of Adobe Garamond also has them.

For input from the keyboard, you can try my "Latin Extended" Unicode keyboard:
http://homepage.mac.com/chinesemac/LatinExtended/

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/