Styles don't stick...

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
Posts: 6
Joined: 2003-05-05 06:01:23

Styles don't stick...

Post by dbuffington »


In many cases, in NWE 1.0 (and 1.0.3) applied type styles aren't saved. For example, I can apply the bold style to a word, save and close the document, then reopen the document and the word is not bold.

Any suggestions?

Dave Buffington

Posts: 353
Joined: 2003-09-30 21:33:58


Post by gemboy27 »

just to see, I made a word bold, close and opened and it worked for me, are you saving the file, I know that is a stupid question, but I can't figure out why it would not stick...

Posts: 6
Joined: 2003-05-05 06:01:23

Post by dbuffington »

Yup. Saved it. Doesn't stick. It's enough to make me use Word. Ugh.

Posts: 481
Joined: 2002-11-26 11:40:35
Location: San Diego, CA

Post by charles »

what file format are you saving in? Make sure you are saving in RTF, RTFD, or Word formats to saved formatted text.


Posts: 290
Joined: 2003-04-03 08:38:41
Location: Linköping, Sweden

Fonts do not stick while saving and opening in Word

Post by MacSailor »

I have tried to save some documents within NWE as RFT and then opened them from Word, and the font does not match the font I used within NWE. Doesn't NWE send the correct font info, when saved as RFT? Or is it the Word that does not understand their own RFT format?

It's the same when I am exporting a document from Mellel in RFT format and opening the same in Word. Could it be that Microsoft, Nisus and Mellel are using different versions of RTF?

The RTF document from Mellel is opened without any changes in the format by Nisus, but Word is messing up the font.

And if I take the same first RTF document saved within Nisus, and then tries to open it from Mellel, I always get the font Lucida Grande. I thought RTF was a trustworthy format!

If I write something within Word and save it in RTF format, the format seems to be retained when it's opened by Nisus or Mellel. :?

Posts: 15
Joined: 2003-10-30 07:07:29

Re: Fonts do not stick while saving and opening in Word

Post by mirko »

Peter Edwardsson wrote:Could it be that Microsoft, Nisus and Mellel are using different versions of RTF?
I am sure that it is.

Microsoft I believe invented the RTF as an open standard, but then (all MS-y) proprietarily modified it to be sort-of compliant with open standards, at best.

Mellel has (since v 1.65 I believe) good import capability for RTF, but the export capability is minimalist at best (until v1.7 which promises extensive RTF export support as well)

Mariner Write has a long development tradition in import and export of RTF, and is fully compliant for as far as my experience goes

I do not have much experience with Nisus yet, but based on what I know from the design philosophy, I expect it to be fully compliant as well. The real limitations lie in the app as it is right now, at v1.0.x

But maybe Charles can comment? I am only guessing here!

Posts: 19
Joined: 2003-05-19 17:33:34

have you done a repair permission?

Post by bbrowncashdollar »

Have you run Repair permission from Disk Utility in /Applications/Utilities/Disk Utility? I think technically you're suppose to run it from the Mac OS X CD, but I've run it from the hard drive with apparent success. If you haven't I would recommend doing so. Just a note if you run it from your hard drive you should let that run and walk away for about 20 minutes. Working in other apps, wiriting to pref other files can under mine the repair. Then see if they stick. If you haven't tried that yet, I bet that'll take care of it, sounds like something similiar that has happened to me. good luck

Posts: 6
Joined: 2003-05-05 06:01:23

Post by dbuffington »

Alas, I have tried repairing permissions. No difference. I've trashed the preferences (plist) file. No difference. Sigh.

Posts: 19
Joined: 2003-11-26 22:19:02

1.1a styles

Post by Cocoapastor »

In 1.1a, the only style component that I can’t get to save is line spacing.

Posts: 6
Joined: 2003-10-14 05:55:21

Same here

Post by catspec »

Am using Nisus Express 1.0 on OS X 10.2.8 and have noticed the same thing - I saved a document the other night five times after bolding it, and each and every time I opened it to check, there was no bold. I didn't think this was extremely major for me, but it sure could be if only portions were bolded. I don't think this acts like a machine specific problem, it seems like a software bug, since everything else seems fine.

Post Reply