Losing Data

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
jfrost4
Posts: 1
Joined: 2008-08-26 08:55:37

Losing Data

Post by jfrost4 » 2008-08-26 09:02:09

I have been using Nisus Writer Express about three years. Currently, I use version 3.1 on a Mac with OS 10.4.11. I haven't tried a new document, but when I make changes to an existing document and save it under another name, I lose the data. When I open the document, all that appears are quote marks, apostrophes, and maybe some other punctuation marks. How did I lose the characters? This happened with one document long ago. Some of the stuff I work on I have worked on for months. I fear for the safety of my documents. J

User avatar
martin
Official Nisus Person
Posts: 4358
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Losing Data

Post by martin » 2008-08-26 11:48:31

That is quite a serious problem- are you able to replicate the issue every time you save this particular document? If so, would you be able to send me the original (intact) document? Please email me directly at the following address:

Image

User avatar
martin
Official Nisus Person
Posts: 4358
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Losing Data

Post by martin » 2008-08-28 13:09:40

I've corresponded with jfrost privately and just wanted to follow up here in case anyone else ever runs into this problem.

When you save a file the font applied to your text determines how exactly the characters are saved. If text in a specific font(s) goes missing on save & reopen it may be due to a system font corruption.

The contents of jfrost's file were exceedingly simple, just a single font the whole way through. To diagnose this jfront switched the font applied to his text from Courier to Lucida Grande. After the change text was no longer lost upon save & reopen.

To fix a corrupted font, I recommend the following steps:

1. Launch Apple's "Font Book" application. Once launched, select all the fonts in the listing. Then use the menu File > Validate Fonts. Check the results to see if it detects issues with any of fonts. Once that is complete quit and restart Nisus Writer to see if the problem persists. (Note: this step did not help jfrost, but I would still try it out).

2. Delete your system font caches. There are several applications that can do this for you, some free, others not. We can't comment on their effectiveness or safety, so you're on your own if you choose to use one. Here are some that turned up during a quick search:

FontNuke
Onyx
Cocktail

3. Delete (or simply move away) the defective font. Then reinstall a fresh copy from the system (OSX) installation DVD.

After any of these steps you may want to restart your system.

Post Reply