Removing U.S. English

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
gimlach
Posts: 2
Joined: 2009-02-18 05:04:20

Removing U.S. English

Post by gimlach » 2009-02-18 05:18:24

Hello

I've searched and can't find this specific problem in the archives, so I'm hoping somebody can help.

I've set British English as my default language, but U.S. English keeps reasserting itself despite all my efforts to get rid of it.

I've edited my new document template preferences to select British English, and I've also gone into the Languages preference pane and removed U.S. English form the list altogether.

However, once I open a new document and paste in any text from another application, as I often do, the lower-right language icon instantly changes to U.S. and I have to change it back manually. The same goes for any Word or rtf. documents I get sent as email attachments.

How can I stop this happening and get rid of U.S .English permanently?

Thanks in advance

Gary

User avatar
martin
Official Nisus Person
Posts: 4251
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Removing U.S. English

Post by martin » 2009-02-18 19:11:20

Hi Gary,

The first point to make clear is that language is an attribute of text, like font, and not a property of the document as a whole. So you can have different parts of a single document marked in multiple languages.

So, when you paste/insert content from an external source (email, Word, etc) it may be that the text has been explicitly marked as US English. This language would take precedence over any language you have otherwise set in your document. You could work around this by pasting as "text only", if other formatting is also not important to you.

Another possibility is that the text from the external source has no language applied. In this case Nisus Writer will assume the text should have the system language applied. You should make sure "British English" is at the top of your system language list (under OSX's "International" preferences), and not the generic "English" most Macs ship with. You'll have to restart Nisus Writer before any changes in your system preferences take effect.

gimlach
Posts: 2
Joined: 2009-02-18 05:04:20

Re: Removing U.S. English

Post by gimlach » 2009-02-19 04:15:39

Martin

Hi, thanks very much for the reply. It was the second of your suspects - the international language preferences at operating system level - that was the culprit. I could never understand why US English appeared in its own section at the bottom of the language list in the Nisus Writer tooldrawer even though I'd removed it. Apparently that was why.

All fixed now as far as I can see.

Thanks again

Gary

Post Reply