Reply to topic  [ 11 posts ] 
I'm not American 
Author Message

Joined: 2004-09-10 11:47:28
Posts: 2
No matter what I try Nisus Writer 2.0 sets my language to U.S. English. But even more annoying than that it sets my keyboard layout to U.S from British. So I have disable U.S. English from with in the app. I have removed the U.S. keyboard layout as an option. But yet still Nisus Writer 2.0 opens with U.S. English selected.

No offence to any Americans reading this. But right now I would be happy if I could just remove the flag.


2004-09-10 12:18:10
Profile

Joined: 2002-11-26 11:40:35
Posts: 481
Location: San Diego, CA
Post 
Hi:

It sounds like there are two issues here: your keyboard layout changing and your language issue.

To avoid having your keyboard change, do the following:

1. Choose "Preferences" from the "Nisus Writer Express" menu.
2. Click on the "Languages" button in the Preferences window.
3. Uncheck the box labeled "Switch keyboard when language changes."

As for the language issue, I need a little more information:

1. What is your Mac OS X system language? British or US English?
2. Are you having problems with your language being set to US English for new document or for documents you opened previously or for all documents?

Cheers,
-Charles

_________________
Charles Jolley
Nisus Software, Inc.


2004-09-10 13:13:13
Profile WWW

Joined: 2003-12-04 18:51:11
Posts: 24
Post 
Seconded,
NWX2 will not take format preferences at all as far as I can see.
They register in the preferences, but nothing is reflected in documents,before or after restarting the programme. American 12pt Times only }:-(

In addition, the Font menu in the tool bar is non-functional: the list flashes briefly then dissapears. The font list in the Menu bar works.

Bugs, Bugs, Bugs,

sighhhh..........
N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2004-09-10 14:36:14
Profile

Joined: 2002-11-26 11:40:35
Posts: 481
Location: San Diego, CA
Post 
If you are having trouble with using the New Document setting to change how your new file behaves, another way to change your New Document settings is to edit your Nisus New File directly.

To get to your Nisus New File:

1. Open the New Document preferences pane.
2. Choose the "Advanced" tab
3. Click on the "Edit Nisus New File" button.

Make the changes you want to the document that opens and save it.
Any changes you make will be reflected in all new documents.

I suggest that when you open your Nisus New File, you switch to the Style Sheet view (choose "Style Sheet" in the "View" menu) and then look for the style named "Normal" and click on it. Now apply your formatting changes to this style so they will be reflected in the rest of your document. You can apply a language setting to this style and it will be used throughout your document.

-Charles

PS: propstuff: I'm not sure what you mean by the Font menu in the tool bar. We do not offer a font menu in the tool bar. Do you mean in the Character palette?

_________________
Charles Jolley
Nisus Software, Inc.


2004-09-10 14:51:16
Profile WWW

Joined: 2004-09-10 11:47:28
Posts: 2
Post 
Thanks my problems are solved.


2004-09-10 17:12:22
Profile

Joined: 2003-12-04 18:51:11
Posts: 24
Post 
Charles,
Font selection:
Yes Character Pallette is what I mean.
The button for the size can be changed, but the font and style drop menus are non-functional.

Preferences:
System is set to Australian English.
NWX preferences; ditto
NWX New File set and saved via the Advanced tab in the New file preference; ditto, Arial 10pt.

Result:
New file will now show Australian. Font size is 10pt, Font is still Times.
Existing files show American. Font is still Times. Font is correct (Arial, Australian) in Word.

N.

_________________
Nicholas
550MHz TiBk, 512Mb, OS 10.2.8 NWX 2.0


2004-09-10 23:18:40
Profile

Joined: 2002-11-26 11:40:35
Posts: 481
Location: San Diego, CA
Post 
Propstuff:

Please contact our support team directly about these issues: support@nisus.com. We have not received reports from other users about issues like these, which hopefully means you are just experiencing some configuration or other issues that we can help you resolve quickly.

-Charles

_________________
Charles Jolley
Nisus Software, Inc.


2004-09-11 13:05:17
Profile WWW

Joined: 2004-09-11 15:07:24
Posts: 2
Post 
I have the same sort of problem. I haven't experimented with fonts, but the language always defaults to American English.

I just upgraded to 2.0 today, and am running 10.3.5 with British English.

If I set up British English in new document preferences (after first adding it to the language list) it seems to save the setting OK (I quit and restart and the setting was still British English 5 times out of 6 - reverted to US English once).

Default document on startup with this setting is still US English, and if I re-check the new document preferences, then get a new doument it's US English again.


2004-09-11 15:13:18
Profile

Joined: 2004-09-11 15:07:24
Posts: 2
Post 
Just wanted to add that my keyboard layout doesn't change, as I don't have US English set up as an option on my menu bar.


2004-09-11 15:15:39
Profile

Joined: 2004-09-11 18:47:19
Posts: 1
I have the same problem. I'm using NWE 2.0. My Mac OS system language is English (Canadian). I set my preferences in NWE to use English (Canada) and the Canadian keyboard, but each time I create a new document, it reverts to U.S. English. The preferences just don't stick. I deleted U.S. English from the list of languages and it seems to have fixed the problem.

When I choose French (Canada) as the language, the keyboard switches to the Canadian keyboard, but shows the icon for the French keyboard. (There are two separate keyboard layouts for French speakers in Canada and in France).


2004-09-11 18:57:40
Profile

Joined: 2002-11-26 11:40:35
Posts: 481
Location: San Diego, CA
spudz wrote:
I have the same problem. I'm using NWE 2.0. My Mac OS system language is English (Canadian). I set my preferences in NWE to use English (Canada) and the Canadian keyboard, but each time I create a new document, it reverts to U.S. English. The preferences just don't stick. I deleted U.S. English from the list of languages and it seems to have fixed the problem.

When I choose French (Canada) as the language, the keyboard switches to the Canadian keyboard, but shows the icon for the French keyboard. (There are two separate keyboard layouts for French speakers in Canada and in France).


I just wanted to point out three issues with the language settings:

First, the Nisus New File that ships with Nisus Writer is set to use the "System Language", which means that NWE will try to determine which writing language. We try our best to get the right language from the OS, however, Mac OS X is very bad about reporting the correct language information so it is possible that if you set your system language to some variant of English, the system and NWE may end up guessing US English instead.

Secondly, some people have reported trouble setting the default language using the New Document preference pane. If this is you, the for sure way to change the default writing language is to use the procedure I described above to edit the Nisus New File directly.

Third, many people seem to have the "Switch keyboard when language changes" turned on and that is causing the problems with the keyboard changing all the time. This option is intended primarily for users who mix roman and non-roman languages, such as those writing in Japanese and English. For people working primarily in roman languages, such as any form of English, French, etc, it is best to turn this option OFF.
[/b]

_________________
Charles Jolley
Nisus Software, Inc.


2004-09-12 00:21:01
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software