Reply to topic  [ 7 posts ] 
Autosave 
Author Message

Joined: 2003-10-24 02:33:18
Posts: 4
Autosave is not working for me. I have turned it on/off in Preferences, but I get a message

'Disabling Autosave
Warning: Could not save document, autosave has been disabled.'

when its timer triggers.

I tried using the Document Manager to create a new doc, to see if that would allow autosave, but the problem persists. I tried different permutations of Autosave on/off and Keep new documents in document manager without asking me, but no go.


Craig

OS X 10.3.5 1 Ghz PB, 1 GB RAM.


2004-09-12 13:22:13
Profile

Joined: 2004-02-25 18:28:40
Posts: 419
Location: Maryland, USA
Post 
Hi, Craig.

I also get that message ("Disabling Autosave..."). I think what happens in my case at least is that Nisus looks for something in the document to use for a file name but finds impermissible characters. This typically happens when I've started the document off with an http:// URL or something like that. I don't really have a solution, just a possible cause. I notified Nisus of this a short while back but probably not in time for them to work a fix into 2.0.

--Craig C.


2004-09-12 16:44:34
Profile

Joined: 2010-02-22 15:06:48
Posts: 98
Hello All,
I hate to bump an 8 year old thread, but I've just started to get the 'Disabling Autosave' message as well. I've begun using NWP2 on a new computer recently and get this message the first time a file goes to autosave. Although it is a bit of a clunky work-around, here is a solution: go to Preferences > Saving, then reselect the location for the automatic backups (it is not that the location for backups originally selected is not displaying, it is). For me, re-selecting the backup location makes everything work fine for the rest of the NWP2 session — i.e., the backups are autosaved as normal.
Not exactly sure what the problem is, but there you go.
Josh


2013-02-23 09:42:41
Profile
Official Nisus Person
User avatar

Joined: 2003-02-11 10:49:05
Posts: 428
Location: Solana Beach, CA
Thank you, Josh, for "bumping" the thread. We periodically (though infrequently) see reports such as these. If anyone does encounter the problem…

The next time it occurs, please, when you first notice it:

1. Choose Send Feedback from the Help menu inside Nisus Writer Pro.

2. Describe what happened.

3. Include any files you think might be relevant (Preferences and/or the file you're working on).

4. Include a screenshot (sometimes a picture is worth a thousand words).

5. Send in the report.

If we're lucky we'll get some information about what's happening inside your computer.

This report goes directly to the Engineering Department. We'll let you know as soon as there's anything meaningful to report.

Thank you for your patience.

_________________
Write On!
Mark Hurvitz
Nisus Software Inc.


2013-02-23 17:07:18
Profile ICQ
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
There are a variety of causes that could trigger the "Disabling Autosave" alert. It could be something in the particular file that is preventing the save, or a more general problem like a misconfigured autosave folder. In Josh's case I believe the problem to be the latter.

Josh already helpfully sent in a feedback report, which I've taken a look at. In the collected error logs there was a warning about not being able to create the required autosave folder. Specifically it said that NWP could not create the folder "/Users/goldste4". That's a red herring because there should be no need to create such a folder– that folder is your home folder, which should already exist.

Josh's post here suggests the cause of this home folder mixup:
goldste4 wrote:
I've begun using NWP2 on a new computer recently and get this message the first time a file goes to autosave. Although it is a bit of a clunky work-around, here is a solution: go to Preferences > Saving, then reselect the location for the automatic backups (it is not that the location for backups originally selected is not displaying, it is). For me, re-selecting the backup location makes everything work fine for the rest of the NWP2 session — i.e., the backups are autosaved as normal.

If Josh copied his preferences between computers, that would have copied his autosave folder location. If his home folder / user name was different on the new computer, that folder would not exist, and hence why NWP could not autosave and why resetting the folder fixed the problem.

I hope that's clear. Let us know if you have any questions, or we've diagnosed this incorrectly.


2013-02-25 15:45:26
Profile WWW

Joined: 2010-02-22 15:06:48
Posts: 98
After some very helpful behinds the scenes emails, Martin figured out the problem. It was indeed caused by my copying preference files from one computer to another. The location for the autosave was then incorrect and needed to changed. The place to change it is: Preferences > Doc Manager and then choosing the correct location in the "Document Manager folder" path control at the top of that pane.

The initial difficulty Martin had diagnosing the problem, I realized, was caused by my confusion in my first post. When I was re-selecting the location for "Backups" under Preferences > Saving, I thought I was re-selecting the location for "Autosave". But once we got that sorted out, Martin suggested the change under "Doc Manager" and that did the trick.

Thanks again, Martin and to Nisus' dedication to customer service!

Josh


2013-02-26 05:35:38
Profile
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 4251
Location: San Diego, CA
Thank you for your kind words Josh! We very much appreciate hearing that we're keeping our customers happy :) I'm glad we could work together and get this problem solved– you're always very helpful and responsive in aiding us in a diagnosis.


2013-02-26 13:00:13
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software