Check spelling as you type bug?

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
HeatherKay
Posts: 78
Joined: 2004-04-13 04:44:40
Location: Chatham, UK
Contact:

Check spelling as you type bug?

Post by HeatherKay »

Hi

I'm generally happy to let my appalling spelling be flagged up as I type. However, some documents I work on contain a lot of company names, which appear almost completelt underlined in red.

I turned off the check spelling as you type feature, but the red underlines remain visible - even through page refreshes and changing between draft and page views.

I think this might be a bug.

OSX 10.3.2. NWE 2.0.1

rmark
Official Nisus Person
Posts: 428
Joined: 2003-02-11 10:49:05
Location: Solana Beach, CA
Contact:

Post by rmark »

HeatherKay,

You can turn this on/off in two places.

A. In the New Document Preferences

B. From the View menu.

Make sure you've turned it off in both places if you want to prevent any red squigglies.
Write On!
Mark Hurvitz
Nisus Software Inc.

HeatherKay
Posts: 78
Joined: 2004-04-13 04:44:40
Location: Chatham, UK
Contact:

Post by HeatherKay »

Thanks, Mark.

As ever, I fiddled around after firing off my problem to the list and I found the solution you mentioned.

What seems odd, though, is that you have to turn it off in two places for the options to stick. I generally want the spelling check on for all new documents, and only occasionally need it off for existing documents. I would have thought the ability to switch it off locally, ie one open document, would be better than a global toggle.

Maybe that is something for NWE3!

Thanks

rmark
Official Nisus Person
Posts: 428
Joined: 2003-02-11 10:49:05
Location: Solana Beach, CA
Contact:

Post by rmark »

HeatherKay,

Each of these options functions differently.

A. Turning it off in the New Document Preferences means that each and every time you open a new document it will not check your spelling as you type.

B. Turning it off in the View menu affects the current document only.
Write On!
Mark Hurvitz
Nisus Software Inc.

HeatherKay
Posts: 78
Joined: 2004-04-13 04:44:40
Location: Chatham, UK
Contact:

Post by HeatherKay »

rmark wrote:B. Turning it off in the View menu affects the current document only.
But it didn't, which is why I flagged it up.

One for the pot, perhaps.

WattsM
Posts: 40
Joined: 2003-11-13 13:50:17
Location: San Jose, CA
Contact:

Post by WattsM »

I'll have to second Heather's confusion here -- and I think this is either an actual bug, or something that's highly counter-intuitive: the option in New Document Preferences doesn't just affect new documents, but rather, for documents when created or opened. If you create a file and turn "check as you type" off in the Edit menu but it's still on in the New Document Preferences, then the option will be enabled again if you close and re-open the file, and in fact, will be re-enabled for that currently open document if you create or open a second document. And, if it's turned off on New Document Preferences, then existing documents will open with that option turned off, and again, if you turn it back on in the edit menu and then open/create a second document, it gets turned off for all windows again.

The way I would expect it to behave is simply to use the toggle in the edit menu, and save that state as if it were a preference: if I turn it off, it stays off until I turn it back on, and vice versa--no need for a New Document Preference setting at all, really. If you keep the state on a per-window basis and only use the setting from the New Document preference pane for new documents, great, but currently, the interaction between the two settings can create a little unnecessary frustration.

hatchmo
Posts: 86
Joined: 2004-03-01 10:35:56
Location: Cotati, CA

Check Spelling Design bug

Post by hatchmo »

To prevent red underlines from appearing in documents (old or new, makes no difference), you must still turn off spell checking in TWO places:

(1) In Edit->Spelling>Check Spelling as You Type
(2) Preferences>New Document>View

Unless you uncheck in both places, OLD documents keep returning with red underlines under suspect words.

Unchecking the "New Documents" preference should affect "New" documents. It should not be necessary for old documents. That's counterintuitive and confusing.

Nisus Writer Express 2.1.3, OS 10.4.
Al Hatch

Post Reply