Page 1 of 1

Questions from MW6 to NWE

Posted: 2005-01-24 13:11:11
by ngazidja
As I'm sure many before me have found (and some yet to come will do) there are differences between NW6 and NWE. I've not yet found answers to the following and would be grateful for responses.

1. "Cmd =" used to cycle through open windows. What's the new shortcut?

2. I really liked the way the cursor turned to an arrow for drag and drop, is that still an option? It meant I knew when I was ready to drag, now I "miss".

3. Can we still do split screens? The little box/window separator seems to have gone.

4. When I type "i" it automatically changes to "I". How can I turn this off?

5. Why do tab markers "tremble" when I drag them on the rulers? This is a seriously irritating feature. Is it a bug?



NW6 not MW6

Posted: 2005-01-24 13:12:13
by ngazidja
Of course I meant NW6 and not MW6. Is there even an MW6?

Posted: 2005-01-24 17:50:47
by cchapin
1. The OS X shortcut for this is cmd-` (that is, the command key plus the key to the left of "1" and above "tab"). However, Nisus used this combination for Normal paragraph style, so I suggest changing the keyboard shortcut for Normal paragraph style. That should re-enable the system's keyboard shortcut.

2. I don't think it does that right now.

3. Likewise.

4. Mine doesn't do this. I might have done something earlier to stop it. Here's a suggestion. Open Preferences and click QuickFix. Scroll down the list and see if you see i under "Typo" and I under "Correction." If you do, select it and click the "minus" button.

5. I'm not sure what you mean by "tremble." Do you mean that they "snap" to certain positions on the ruler (for me, quarter-inch increments)? If that's what you mean and you don't want to set your tabs at those positions, you can double-click the tab and set the location by typing a numeral.

And I'm not aware of an MW6.


Posted: 2005-01-24 18:11:40
by ngazidja
1. Thank you. I knew it would be there somewhere.

2. & 3. I can live without them, but the arrow would have been nice.

4. I had "fix typos" turned off and it didn't seem to be fixing any others, but I removed the "i" to "I" one anyway and it's stopped doing it. Strange.

5. When I very smoothly slide a tab marker across with the mouse the tab both jumps in discrete increments (so from 24.14 to 24.02, I can't stop at 24. 10, for example) but it also regularly hops "backwards (ie, from from 24.14 to 23.92 then back to 24.02 then on to 23.86), despite the fact that the mouse movement is smoothly in one direction (in this case from right to left). So when I drag the tab across rapidly it "quivers" or "trembles" to and fro in little jerking movements. I find this close to unbearable :(

Posted: 2005-01-25 08:48:57
by cchapin
2. & 3. Both issues were raised earlier on the forum, and I suspect (but don't know for a fact) that Nisus will add these features in at some point in the future.

4. That is strange.

5. You might be experiencing a bug that was discussed here, but your problem seems to go beyond that. Have you reported this via the Feedback mechanism (under the Help menu)? Until this gets worked out, you can set tabs precisely by double-clicking them.


Posted: 2005-01-26 13:09:43
by ngazidja
5. That seems to be it. I changed the units to inches and the tabs slide across very nicely, even pausing at regular (.25) intervals. Clearly a bug with the unit conversion. Let's hope it's fixed rapidly.

Changing preferences (was NW6 to NWE)

Posted: 2005-01-27 16:50:57
by ngazidja
1. I spoke too soon. When I try and change the keyboard shortcut for paragraph normal, it reverts to cmd-` on quit. I can't get it to stay changed. Should I trash preferences or something like that?

Posted: 2005-01-27 20:22:17
by cchapin
I had trouble with this too. I made the change in version 2.0, and it stuck when I upgraded to 2.1. However, I couldn't change it permanently after that. I guess I'm not the only one.

I don't know if this will work, but you might try deleting Normal, recreating it (or a style with a different name), then applying a different keyboard shortcut. However, I would back up your Nisus New File before you do.

(I recommend this because, in 2.0, I learned that making something other than Normal the default paragraph style caused endlessly spinning beach balls at start-up. Deleting Nisus New File fixed that, but of course I lost any customizations unless I had saved a back-up. Hopefully this problem is fixed in 2.1.1. I just haven't tested it.)

Since command-` is such a handy OS X shortcut, I really think the good folks at Nisus should find another default shortcut for its Normal style.


Posted: 2005-01-28 19:27:47
by charles
Remember to change the keyboard shortcut for all new documents, you need to open the Nisus New File and make your change there. To do this:

1. Choose "Preferences" from the "nisus Writer Express" menu.
2. Choose the "New Document" icon at the top.
3. Click on the "Advanced" tab.
4. Click on the "Edit Nisus New File..." button.

Now change the keyboard shortcut and this will be applied to all new documents you create.

Also, we have changed the default shortcut key for new documents in the latest version of Nisus Writer Express, but if you have modified the Nisus New File already, we do not replace it. To get this update, click the "Restore Factory Defaults" button in the Advanced tab of New Document in the Preferences.

The next release of Nisus Writer will also correct this problem with the keyboard shortcut.


Posted: 2005-01-29 10:10:25
by cchapin
Hi, Charles. Thanks for giving good, clear instructions for modifying the Nisus New File.

I just tried what you suggested, and I am still unable to change the keyboard shortcut for the Normal style.

First, I tried this (again) by editing the Normal paragraph style in the Style Sheet in Nisus New, but the change didn't take effect and wasn't reflected in the tool drawer style list or the Format menu.

So then I restored factory defaults (after renaming my customized Nisus New File for back-up purposes). At that point, the Normal paragraph style says its keyboard shortcut is command-`, but it is actually shift-command-`. (This is the shortcut I used in version 2.0.) When I changed the shortcut to control-option-command-n (which is what I would prefer since all of my other style shortcuts use the control-option-command combination), it seemed to accept that change. However, when I switched back to Draft View, the tool drawer and Format menu still indicated that the shortcut was command-`, and the actual shortcut remained shift-command-`.

Are others able to change the shortcut? I'm using NWE 2.1.1 under OS X 10.3.7 on a PowerBook G4 with 768 MB RAM.


Keyboard shortcuts

Posted: 2005-01-31 13:26:53
by ngazidja
I've had several unsuccessful attempts to change keyboard shortcuts. I also had this from Nisus:

"Try this:

1. Choose Style Sheets from the View menu.

2. Select the Normal Style.

3. Select the Shortcut field.

4. Press the Delete key.

That should do the trick."

But it didn't work either.

I've also noticed that I can't change the shortcut for Redo (I liked cmd-R). Obviously I haven't tried them all but it seems that any user-defined keyboard shortcuts that try to override the default settings are lost on Quit.