Nisus compatibility with osx 10.8?

Everything related to our flagship word processor.
Post Reply
lellius
Posts: 40
Joined: 2002-08-15 22:06:44

Nisus compatibility with osx 10.8?

Post by lellius » 2012-07-02 00:51:30

Hello Martin
I read in the site
http://roaringapps.com/app:1792
that Nisus Writer Pro doesn't work in the next osx release 10.8.
Can you please confirm or deny this statement and occasionally tell us what you intend going to do to make Nisus full compatible?
Nisus is too important for me, and before upgrading i must be sure of full and trusty functionality.
Thanks
gb

xiamenese
Posts: 424
Joined: 2006-12-08 00:46:44
Location: London or Exeter, UK

Re: Nisus compatibility with osx 10.8?

Post by xiamenese » 2012-07-02 06:34:33

As far as I can see, that comment was posted in March, therefore not very up-to-date!

exegete77
Posts: 187
Joined: 2007-09-20 17:58:56

Re: Nisus compatibility with osx 10.8?

Post by exegete77 » 2012-07-02 06:50:39

From the Nisus Newsletter June 26, 2012:
"I read that Apple has announced Mountain Lion and that it will be released in July. Will you be updating your products to be ready for Mountain Lion soon?"

Yes, we will be updating our products for Mountain Lion and they should be ready before Mountain Lion ships. We will have more news on that when the release date for Mountain Lion is announced.
iMac 21.5” / MBP 13” Retina
Mac user since 1990

lellius
Posts: 40
Joined: 2002-08-15 22:06:44

Re: Nisus compatibility with osx 10.8?

Post by lellius » 2012-07-03 00:55:49

ok, thanks, better twice than none.
gb

User avatar
martin
Official Nisus Person
Posts: 4386
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Nisus compatibility with osx 10.8?

Post by martin » 2012-07-04 14:36:41

xiamenese wrote:As far as I can see, that comment was posted in March, therefore not very up-to-date!
That's very true- there's been many months of development on 10.8 since then.

But in any case, we'll make sure Nisus Writer 2.x runs properly on 10.8. If an update to version 2.0.2 is required, it will be a free update.

mrfearless47
Posts: 2
Joined: 2012-07-08 13:40:20

Re: Nisus compatibility with osx 10.8?

Post by mrfearless47 » 2012-07-09 20:13:47

I can confirm without breaking NDA that NWP 2.0.2 seems to run fine with sox 10.8 GM build, released to us developers today. No problems that I can see so far. Quite fast too on an iMac late 2011 model with 3.4 GHz quad core i7 and 32 GB. Of course, as a 32 bit application, NWP doesn't take advantage of the additional memory space.

Mrf

mwdiers
Posts: 10
Joined: 2010-07-17 15:39:18

Re: Nisus compatibility with osx 10.8?

Post by mwdiers » 2012-07-14 17:33:09

I'm using 10.8 GM (I have a developer account), on a Retina Macbook Pro.

On Lion everything works flawlessly. On 10.8, I can consistently lock up NWP if I double-click on a style (character or paragraph).

Of course, there is no reason to double-click on a paragraph style when a single-click will do, but sometimes I forget.

FYI - Sample attached of locked NWP process attached.
Attachments
Sample of Nisus Writer Pro.zip
(75.51 KiB) Downloaded 211 times

User avatar
martin
Official Nisus Person
Posts: 4386
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Nisus compatibility with osx 10.8?

Post by martin » 2012-07-25 17:08:06

mwdiers wrote:On Lion everything works flawlessly. On 10.8, I can consistently lock up NWP if I double-click on a style (character or paragraph).
This can be a problem, as discussed in another thread. But we should have an update of NWP ready for OSX 10.8 any day now.

lellius
Posts: 40
Joined: 2002-08-15 22:06:44

Re: Nisus compatibility with osx 10.8?

Post by lellius » 2012-07-25 22:55:01

I confirm, NWP works splendidly with ML X.8.
So why does http://roaringapps.com/app:1792 still report: Doesn't work in 10.8? Should they be... prosecuted?
:)
gb

dshan
Posts: 333
Joined: 2003-11-21 19:25:28
Location: Sydney, Australia

Re: Nisus compatibility with osx 10.8?

Post by dshan » 2012-07-26 00:09:04

lellius wrote:I confirm, NWP works splendidly with ML X.8.
So why does http://roaringapps.com/app:1792 still report: Doesn't work in 10.8? Should they be... prosecuted?
:)
gb
They seem to be talking about NWP 2.0 for some reason, not 2.0.2. And it seems even 2.0.2 has some minor issues with OS X 10.8.

User avatar
martin
Official Nisus Person
Posts: 4386
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Nisus compatibility with osx 10.8?

Post by martin » 2012-07-28 02:23:03

We've just made available Nisus Writer Pro 2.0.3, which resolved all known issues with OSX 10.8.

Anne Cuneo
Posts: 164
Joined: 2004-09-23 02:15:46
Location: Switzerland
Contact:

Re: Nisus compatibility with osx 10.8?

Post by Anne Cuneo » 2012-08-12 11:15:15

I am totally confused here: the messages on Nisus Interactive, on the Nisus Dartmouth List and here are contradictory. I do not doubt Nisus 2.0.3 and 4 work with OS 8, but what about US, who are still on 10.7.x? I couldn't use 2.0.3 until now, and I have to wait for my French Dictionary to go on 10.8. So do 2.03 and 4 work with 10.7, and if they do, why so many of us have a problem using either? I for one had to go back to 2.0.2. Confusion… confusion… Please help! :(
Anne

User avatar
martin
Official Nisus Person
Posts: 4386
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Nisus compatibility with osx 10.8?

Post by martin » 2012-08-13 00:16:48

Anne Cuneo wrote:I am totally confused here: the messages on Nisus Interactive, on the Nisus Dartmouth List and here are contradictory. I do not doubt Nisus 2.0.3 and 4 work with OS 8, but what about US, who are still on 10.7.x?
Nisus Writer Pro 2.0.4 is compatible with OSX 10.6 to 10.8. You should have no trouble running Nisus Writer Pro 2.0.4 on OSX 10.7.

If you're ever confused about which version of NWP to use, or which version of OSX is supported, please visit our version history page.

If you have any troubles running Pro 2.0.4 on 10.7, please contact us directly.

User avatar
Elbrecht
Posts: 337
Joined: 2007-03-31 14:59:22
Location: Frankfurt, Germany

Re: Nisus compatibility with osx 10.8?

Post by Elbrecht » 2012-08-13 00:46:26

Hi Martin -

the NWP 2.0.3/4 product page has: "For Mac OS X 10.6.6 or later"

HE
MacBook Pro i5
SSD 840/850 Pro
MacOS Sierra 10.12.6
Nisus Writer Pro 3.0

User avatar
martin
Official Nisus Person
Posts: 4386
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Nisus compatibility with osx 10.8?

Post by martin » 2012-08-13 12:09:51

Elbrecht wrote:the NWP 2.0.3/4 product page has: "For Mac OS X 10.6.6 or later"
Thanks for the correction Elbrecht; NWP 2.0.4 does indeed require OSX 10.6.6 or later, not 10.6.0. I often don't make the distinction in my mind, because it's free to update from OSX 10.6.0 to 10.6.6. But as you say, it's true that the latest versions of Nisus Writer require OSX 10.6.6 or later.

Post Reply