Smart quote problem in Comments, but not in main NWP window

Everything related to our flagship word processor.
Post Reply
NisusUser
Posts: 292
Joined: 2011-01-12 05:32:38

Smart quote problem in Comments, but not in main NWP window

Post by NisusUser »

I recently noticed that when I type in comments in NWP 3.3, the opening quotation mark does not convert to a proper (for English) smart quote. Rather it goes the other way and is a closing quotation mark. However, when I type in the main NWP window, smart quotes work properly.

Any ideas what I could do to change this behavior?

Thanks!
B.Otter
Posts: 25
Joined: 2021-02-06 15:24:00

Re: Smart quote problem in Comments, but not in main NWP window

Post by B.Otter »

I can't reproduce this behavior on v. 3.3 running macOS 12.6, no matter where or how I begin a quoted phrase inside of comments. Have tried this with my default font, Baskerville, as well as Courier New.

--Brad
NisusUser
Posts: 292
Joined: 2011-01-12 05:32:38

Re: Smart quote problem in Comments, but not in main NWP window

Post by NisusUser »

I'm on 10.14.6.
User avatar
martin
Official Nisus Person
Posts: 5129
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Smart quote problem in Comments, but not in main NWP window

Post by martin »

The most likely culprit is the effective language of your text. Each language can have different smart quote settings, as configured in the Nisus Writer QuickFix preference pane.

Please check what language is showing for your comments. I would guess that your document's "Comment" paragraph style is not in harmony with your "Normal" style. They probably enforce different language formatting. Or perhaps you manually changed your document text's language without updating your stylesheet.
NisusUser
Posts: 292
Joined: 2011-01-12 05:32:38

Re: Smart quote problem in Comments, but not in main NWP window

Post by NisusUser »

Martin,
Thank you. I plan to check. I think you are probably right. I hadn't thought of that.
Post Reply