Preferences - Languages

Everything related to our flagship word processor.
Post Reply
bryanh
Posts: 2
Joined: 2019-07-29 19:04:44
Location: Newcastle, Australia

Preferences - Languages

Post by bryanh » 2019-07-29 19:16:34

There's a bug in 3.0.2; at least from what I can work out. No matter how many times I set the language preference to English (Australia) it defaults to English (U.S.) on opening a new document. Easy to change it back but I have to do this each time I start a new document. This didn't happen in previous editions. I've been a long time user of Nisus.
Could this be fixed (or shown how this can be fixed at my end). Thanks.
I did appreciate the previous version which showed (briefly) than Australian was a language in its own right.

martin
Official Nisus Person
Posts: 4610
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Preferences - Languages

Post by martin » 2019-07-30 07:43:37

I'm sorry you've had trouble establishing the Australian English language as your default. It sounds like you might have encountered a bug. If you choose a particular language in your New File preferences, it should naturally remain intact for all new documents you create.

However, after doing a quick test I was unable to reproduce the problem. That means there's likely something particular to your setup causing the issue. But hopefully we can work together to narrow it down and get this fixed for you. A few questions:

1. Is the language only incorrectly set for new documents that you create, or do your New File preferences also revert? That is, if you quit and relaunch Nisus Writer, do your New File preferences still show you the desired Australian English language? Or has that too reverted to US English?

2. When you create a new document does the unwanted language appear immediately, or does the language only incorrectly revert after you start typing or otherwise take editing actions?

3. What is the location of your Nisus New File template? You can see its file path in the New File preferences, under the Advanced tab. If the file location is in some kind of synchronized folder (eg: iCloud or Dropbox), maybe you could try choosing another location that is less likely to be influenced externally.

bryanh
Posts: 2
Joined: 2019-07-29 19:04:44
Location: Newcastle, Australia

Re: Preferences - Languages

Post by bryanh » 2019-08-11 22:27:23

Thanks Martin. I was attempting to set the language preference through 'Languages'. I thought that's where I did it last time. Obviously, I didn't. I'll stick to 'New File" preferences from here on.

martin
Official Nisus Person
Posts: 4610
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Preferences - Languages

Post by martin » 2019-08-12 09:21:42

So long as languages are working properly for you now, that's the important thing. Please let us know if you have any other questions or trouble in the future.

Post Reply