Spell Catcher problem in Nisus

Everything related to our flagship word processor.
Post Reply
exegete77
Posts: 194
Joined: 2007-09-20 17:58:56

Spell Catcher problem in Nisus

Post by exegete77 » 2019-11-08 11:28:41

I used Spell Catcher for years. With Catalina, it is no longer supported (nor is the app being updated). So I deleted the app using AppDelete.

However, in Nisus every time it launches this appears. And yet there is nothing I can find in Preferences to alleviate the message from appearing.

So, how do I fix this. NWP is the only app that continues to show. Mellel, LibreOffice, Pages, etc. none show this.
Attachments
Screen Shot 2019-11-08 at 11.24.25.png
Screen Shot 2019-11-08 at 11.24.25.png (72.95 KiB) Viewed 396 times
iMac 21.5” / MBP 13” Retina
Mac user since 1990

martin
Official Nisus Person
Posts: 4601
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Spell Catcher problem in Nisus

Post by martin » 2019-11-08 15:37:18

The most likely cause of the unwanted keyboard change is your language preferences in Nisus Writer. We let the user optionally associate separate keyboard layouts for each language. For example, you can have Nisus Writer automatically activate the French keyboard layout every time you enter some French text. I expect that you set one or more languages in Nisus Writer to activate Spell Catcher.

To fix this:

1. Open your Nisus Writer preferences.
2. Switch to the Languages pane.
3. From the list of languages on the left, select one of the languages you use.
4. From the settings on the right, look for the "Keyboard" setting and change it to "Do not change keyboard".
5. Repeat steps 3-4 for all languages that you use.

I hope that helps.

exegete77
Posts: 194
Joined: 2007-09-20 17:58:56

Re: Spell Catcher problem in Nisus

Post by exegete77 » 2019-11-10 20:58:14

Thanks. I went through every language (about 10) and all of them had been "Do not change the keyword." So no help in resolving.
iMac 21.5” / MBP 13” Retina
Mac user since 1990

martin
Official Nisus Person
Posts: 4601
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Spell Catcher problem in Nisus

Post by martin » 2019-11-12 14:04:52

Does your document text use any languages that are not shown in the preferences? Settings for any such languages could still influence Nisus Writer's behavior, even if those languages are not listed amongst your preferred languages. Please check the languages applied to your text and make sure you don't see anything unexpected.

exegete77
Posts: 194
Joined: 2007-09-20 17:58:56

Re: Spell Catcher problem in Nisus

Post by exegete77 » 2019-11-20 08:51:01

Well, long journey. I thought I had it fixed. But then the big surprise, my system got set to Greek for all apps (and I could find no way to change the default back to English). Couldn't find any way to change that, tried many possibilities. It's difficult to surf the web trying spell everything in Greek. Note, I use English as primary, then Greek and Hebrew secondary.

So, I finally called Apple tech support. He walked me through how to get back the default font to English. Yay! I could use all apps (not in Greek!!). Except Nisus still launches with the warning that I originally posted. At this point, I am not going to "trouble-shoot/trouble-make" Nisus. I will just click to dismiss the warning.
iMac 21.5” / MBP 13” Retina
Mac user since 1990

Post Reply